Sony Devices Binding

Hi, i deleted the scalar web thing since I had problems connecting to my TV. I would have hoped for it to show up in the inbox. But to add it as a thing again, I seam to need to manually enter IP, MAC, CODE and MAP. I don’t have a map. Is there a more user friendly way to get Scalar web to work with my Sony TV again?

Is this binding still under active development? The most recent version dates from november right?

I think not. I am considering my options for getting my vW760 to work with oh, and afaict, the only available option is to write a new dedicated binding. I am tempted, but I fear my java knowledge will mean it will take forever.

Maybe someone has already done something for the Sony projectors? (Open call)

I’m still here - just haven’t touched this in awhile (had some health stuff happen that has created an extended leave). I still plan on getting back to it because the latest version is a HUGE change over what you all have.



Thanks @tmrobert8. I hope you get well soon.

1 Like

Health stuff is way more important, hope you get well soon.

1 Like

I am looking for an example of a sony.things file.
Does anybody has configured the sony binding via things-file?

Man i’m really new to all of this.
I need some help.
I have a Sony TV (from 2018 model) and i managed to run openHAB and my motion sensors are up and running.
Now i need to find a way to controll my TV.
How to discover it ?
How to controll it?
What is a good “sitemap” for TV controll?
What happens when i plase an “addon” in the /addon folder?
How to see if something is working?
I plased an “” file there.
So what now ?
How to test?
Do i need to go in localhost and discover it ?
Maybe add same addon from there?

I think there is no documentation available regarding .thing files for this binding. I added the thing through paperUI and it works fine.

Adding add-ons:

You could login to the console to check if the bundle/binding is active and if not start it.

Afterwards, in paper ui you can add the thing Be sure the TV is ON.

If you do end up getting it all tied together you’ll need to keep an eye on your openhab.log

I have a 2017 TV (iirc) and after 6 hours or so the binding takes a dump and openhab goes with it.

That’s my experience, yours May differ.

Almost done. I can see the “Sony Binding” in the Configuratin -> Binfings section
(Supported Things:Sony Simple IP and Sony Ircc)
My TV is very new (2018) I have enabled on it the Simple IP and disabled all the power saving options so it can listen.
Now i’m finding “Configure Sony Simple IP” from the input section. For the IP i’m giving my TV local ip address. For “Commands Map File” what do i need to put? For now just “remotetv” to test.
Now I can see that it’s with status “online” so nice i found it. Thats my Thing.
Not comes the hard part… How to add the “item”?
From here “Configuration -> Things -> Sony Simple IP” All the Channels that i select and create didn’t work. I think that none ot the “Items” can connecft to a “Channel”.

From my log file: “Simple IP TV System now connected”

Do you have a model number? All channels under paperui > Configuration >Things > TV should be linkable to an item. My tv is recognized as scalar, so i wouldn’t know what to do with the map file.

My TV is a “Sony Bravia KD-55XE8096”

Should be recognized as scalar if you ask me. Don’t know what you can do about that in the settings, maybe someone else has the same model?

I desidet to type it:
Switch Tv_Power “Power” {channel=“sony:simpleip:home:power”}
Dimmer Tv_Volume “Volume” {channel=“sony:simpleip:home:volume”}
Switch Tv_Mute “Mute” {channel=“sony:simpleip:home:audiomute”}
//String Tv_Channel “Channel” {channel=“sony:simpleip:home:channel”}

sony:simpleip:home [ ipAddress=“”, commandsMapFile=“”, netInterface=“eth0”, ping=30, retryPolling=10 ]

Frame label=“TV” {
Switch item=Tv_Power
Slider item=Tv_Volume icon=“soundvolume”
Switch item=Tv_Mute icon=“slider”
//Setpoint item=Tv_Channel minValue=1 maxValue=100 step=1

I’m having problems with the “Tv_Channel” but the rest is working. Hope it helps and if you can help with the rest (including “Tv_Channel”) :slight_smile:

This is my configuration:


		Switch	    item=Bravia_Power label="Power SonyBravia" icon=television
		Switch	 	item=Bravia_IR label="Channel []" mappings=["Channel-Up"="CH +", "Channel-Down"="CH -"] icon=television
		Setpoint	item=Bravia_Volume label="Volume SonyBravia" minValue=0 maxValue=100 step=1 icon=soundvolume
		Switch 		item=Bravia_AudioMute label="Mute SonyBravia" mappings=[ON="ON", OFF="OFF"] icon=soundvolume
		Switch		item=Bravia_IR label="Entertainment []" mappings=["Netflix"="Netflix"] icon=television
	    Selection   item=Bravia_Input label="Input SonyBravia" mappings=[TV="TV", HDMI1="CHROMECAST", HDMI2="HDMI2", HDMI3="HDMI3", HDMI4="PS4"] icon=television
1 Like

Still not installable on raspbian due to missing apache modules… I could not find any trick, neither installing it manually from downloaded jar. Help!


I have a new Sony Bravia KD65-XF8505. I was able to install the binding using PaperUI. The TV was auto discovered and I could use the RQST as default to request a PIN, which was displayed on the TV screen. I could control on/off, switch to channels etc. - everything worked fine.

By mistake I deinstalled the binding (hit theuninstall button on the wrong line). Now I’m trying to reinstall it, which works, but I’m not able to discover the TV anymore. I see that the binding starts and registers for UPnP discovery, but nothing happens anymore.

2018-09-19 23:27:08.368 [DEBUG] [            ] - BundleEvent STARTING -
2018-09-19 23:27:08.398 [DEBUG] [            ] - BundleEvent STARTED -
2018-09-19 23:27:08.530 [DEBUG] [            ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.discovery.UpnpDiscoveryParticipant}={, service.bundleid=229, service.scope=bundle,,} -
2018-09-19 23:27:08.540 [DEBUG] [            ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.discovery.UpnpDiscoveryParticipant}={, service.bundleid=229, service.scope=bundle,,} -
2018-09-19 23:27:08.550 [DEBUG] [            ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.discovery.UpnpDiscoveryParticipant}={, service.bundleid=229, service.scope=bundle,,} -
2018-09-19 23:27:08.562 [DEBUG] [            ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.core.thing.binding.ThingHandlerFactory}={, service.bundleid=229, service.scope=bundle,,} -
2018-09-19 23:27:08.571 [DEBUG] [            ] - ServiceEvent REGISTERED - {org.eclipse.smarthome.config.discovery.UpnpDiscoveryParticipant}={, service.bundleid=229, service.scope=bundle,,} -

Binding show active on the OH console:

229 │ Active   │  80 │     │ Sony Binding

Installing, restarting binding and OH, clearing cache/tmp doesn’t make a difference. Maybe OH thinks that the device was already discovered and doesn’t calls the discovery handler anymore. I’m not able to initiate a manual discovery in the inbox - the binding doesn’t show up in the selection box. I’m running OH 2.3 on openHABian.

@tmrobert8 Any idea welcome. The binding worked fine for me, but if I couldn’t get it back to work…

ok, some progress. I also removed the HUE binding, which results in removing the UPnP support (because was the last binding defining this dependency in feature.xml). The Sony binding is not yet part of the standard release, which means OH doesn’t know that it requires UPnP.

to get UPnP support back you need to run

feature:install esh-io-transport-upnp

Now I get “Could not find the IRCC service for device: org.jupnp.model.meta.DeviceDetails@57f0f3”

2018-09-21 23:51:49.117 [DEBUG] [] - 5 * Sending client request on thread Start Level: Equinox Container: 10b85b66-808c-4181-b9b9-21ab3908af39
5 > GET
5 > Connection: close
5 > User-Agent: OpenHab/Sony/Binding
5 > X-CERS-DEVICE-ID: MediaRemote:00-11-22-33-44-55
5 > X-CERS-DEVICE-INFO: OpenHab/Sony/Binding
2018-09-21 23:51:49.126 [DEBUG] [] - 6 * Client response received on thread Start Level: Equinox Container: 10b85b66-808c-4181-b9b9-21ab3908af39
6 < 200
6 < Accept-Range: none
6 < Connection: close
6 < Content-Length: 323
6 < Content-Type: text/xml; charset="utf-8"
6 < Date: Fri, 21 Sep 2018 21:51:46 GMT
6 < Last-Modified: Fri, 21 Sep 2018 21:41:38 GMT
6 < Server: FedoraCore/2 UPnP/1.0 MINT-X/1.8.1
<?xml version="1.0"?>
<scpd xmlns="urn:schemas-upnp-org:service-1-0">
    <stateVariable sendEvents="no">
2018-09-21 23:51:49.133 [DEBUG] [] - >>> contents: 323: <?xml version="1.0"?>
<scpd xmlns="urn:schemas-upnp-org:service-1-0">
    <stateVariable sendEvents="no">
2018-09-21 23:51:49.143 [DEBUG] [.sony.internal.ircc.models.IrccState] - No actionsurl - generating default
2018-09-21 23:51:49.149 [DEBUG] [.sony.internal.ircc.models.IrccState] - No UnrDeviceInformation - returning default version
2018-09-21 23:51:49.153 [DEBUG] [y.discovery.IrccDiscoveryParticipant] - IRCC device didn't implement a valid actionURL - ignoring: (RemoteDeviceIdentity) UDN: uuid:63c471f2-782b-496e-81ce-7fb57bd3dec0, Descriptor:
2018-09-21 23:51:49.159 [DEBUG] [y.discovery.IrccDiscoveryParticipant] - Could not find the IRCC service for device: org.jupnp.model.meta.DeviceDetails@57f0f3
1 Like