Sony Devices Binding

openhab2
Tags: #<Tag:0x00007f51de6dea98>

(KD) #461

Does something have changed since the WE ? Before that I was able to power-on/off, but now, any commands are just not working anymore. I was only using simpleIP protocol (the rest wasn’t working anyway)


(Jonas) #462

Hi!

Sometimes (when your TV restarts) the binding is not working again properly.
Try rebooting openhab or your device it runs on so it’ll work again most probably, karld


(paulfaure) #463

Hi All,
Super excited for this binding. I have installed the version that comes with the marketplace.
Running OH 2.2.
Is there any documentation about the different types of things? Scalar Web, Simple IP, IRCC, and DIAL? Not sure which one i need to use.
I have an STR-DN1040 Sony Receiver. I am not too concerned about sending commands as i have a Harmony Hub remote, but i would like to get the current volume level, input type and the power state.
Thanks


(Tim Roberts) #464

Just a quick update for everyone - I’m still working on this. I’ve completed conversion of simple ip, ircc and dial and am working on scalar web now. Scalar web is a bit more difficult because I’m trying to integrate in some of the stuff @freke did.

I know alot of you are experiencing issues with 2.2+ - please be patient as these issues are fixed in the latest binding. Problem is that I just don’t have alot of free time and this binding is huge - so it takes awhile for me to do stuff.


(paulfaure) #465

No worries. Let me know if there is something I can help test.


(Jonas) #466

Thanks a lot for your effort! Cant wait to get the new version :slight_smile:


(Oren) #467

Hello.
I am trying to connect to a STR-DN1080 AVR unit without luck.

I installed the binding from marketplace and put the AVR into “HOME” mode. (From reading previous posts it seems like this is the pairing mode for this AVR). I can not find any new “thing”.

Also, not sure if it is a problem or not, trying to perform “http://10.0.0.17:10000/sony/guide” give me “{“error”:[501,“Not Implemented”]}” …

Any suggestions?


(Tim Welch) #468

Tagging myself into this thread for updates but…

I have successfully downloaded the .jar file and installed it into /usr/share/openhab2/addons on my RaspberryPi3. I restarted Openhab and in PaperUI 3 things were found - SimpleIP, IRCC, and Scalar Web.

I then created an items file with the following contents so that I am able to create simple buttons

Switch Sony_TV_Power "Power"	 {channel="sony:scalar:025148de-a6da-4080-bcbb-8b633e174fab:system-powerstatus"}
Switch Sony_TV_Netflix "Netflix" {channel="sony:scalar:025148de-a6da-4080-bcbb-8b633e174fab:appControl-com__0sony__0dtv__0com__0netflix__0ninja__0com__0netflix__0ninja__0MainActivity-appstatus"}
Switch Sony_TV_HDMI4 "HDMI4" 	 {channel="sony:scalar:025148de-a6da-4080-bcbb-8b633e174fab:avContent-content-extInput-extInput__3hdmi-0003-cn_status"}

In my default.sitemap I have the following

Frame label="Sony TV" {
		Switch item=Sony_TV_Power
		Switch item=Sony_TV_Netflix
		Switch item=Sony_TV_HDMI4
	}

This all appears to be working fine on my Bravia KD-49X8300C

Cheers, Tim


(KD) #469

In my case:
226 │ Active │ 80 │ 2.2.0.201711082312 │ Sony Binding

Got this in loop:

08:07:54.075 [INFO ] [y.internal.scalarweb.ScalarWebHandler] - Attempting connection to Scalar Web device...
08:07:54.202 [DEBUG] [binding.sony.internal.net.HttpRequest] - 1 * Sending client request on thread ESH-thingHandler-2
1 > GET http://192.168.0.26/sony/webapi/ssdp/scpd/WebApiSCPD.xml
1 > Connection: close
1 > User-Agent: OpenHab/Sony/Binding
1 > X-CERS-DEVICE-ID: MediaRemote:00-11-22-33-44-55
1 > X-CERS-DEVICE-INFO: OpenHab/Sony/Binding

08:07:54.351 [DEBUG] [binding.sony.internal.net.HttpRequest] - 2 * Client response received on thread ESH-thingHandler-2
2 < 200
2 < Connection: close
2 < Content-Length: 323
2 < Content-Type: text/xml;charset=utf8
<?xml version="1.0"?>
<scpd xmlns="urn:schemas-upnp-org:service-1-0">
  <specVersion>
    <major>1</major>
    <minor>0</minor>
  </specVersion>
  <serviceStateTable>
    <stateVariable sendEvents="no">
      <name>X_ScalarWebAPI</name>
      <dataType>string</dataType>
    </stateVariable>
  </serviceStateTable>
</scpd>


08:07:54.569 [DEBUG] [inding.sony.internal.net.HttpResponse] - >>> contents: 323: <?xml version="1.0"?>
<scpd xmlns="urn:schemas-upnp-org:service-1-0">
  <specVersion>
    <major>1</major>
    <minor>0</minor>
  </specVersion>
  <serviceStateTable>
    <stateVariable sendEvents="no">
      <name>X_ScalarWebAPI</name>
      <dataType>string</dataType>
    </stateVariable>
  </serviceStateTable>
</scpd>

Only simpleIP seems to work, and nothing is discovered via paperUI
What URI do you have in paperUI ?


(Killercorny) #470

Hello everyone!

I´ve got a Bravia KD-55XE8577 TV and I allready had this binding working. I could control my TV. Suddenly it doesnt work anymore, maybe because of an update of the TV´s firmware/software.
I removed the thing in paper UI and also the binding itself. But after reinstalling it, its not detecting the TV anymore.
I followed the instructions at github from this binding and I played around in the TV settings swiching off an on the remote controll. But nothing happens.
What do I have to do to trigger the detection? It worked once, but I dont remember how.


(Marcel) #471

Hello, i have an Sony Bravia W805C, a 2015 Bravia Model. I installed OpenHAB 2 and your Sony Binding and after some time, i got it running. The Auto Discovery of the Device does not work, Simple IP is activated on the TV, but it does not find it. So i addet the TV manually. I tried IRCC Method, but it says it is offline. It is not working. Then i tried Simple-IP Method and it found the TV and it is Online. I builded a sample Remote from the Demo in the Readme and everything is working fine so far! I can change Input, i can turn the TV on and off, everything is working but one thing not - the IR Commands and change Channels. When i try to switch to Channel 1 or 2 or 3 etc, nothing happens. I tried also the Channel Down and Channel Up, not working. Why does everything else work but not these commands? I am looking for a way to open the Video App, but it none of the IR Commands in the Readme and none from the generated .map File will work…

I hope someone can help me with that. Sorry for my poor English. Greetings, Caliban


(Jonas) #472

Heyo!
Using this binding for a long time now and everything is running great.
I recognized a bug:
Standard is that analog channels are being ignored and i switched that to none because i want to control the volume.
after a reboot i have to change that setting again because it’s not persistent.
Maybe you can implement a .cfg-file for that binding?

Best regards

Jonas


(Kristof Rado) #473

Is this binding works on the latest 2.2 release? I have installed this binding, but it can’t find my Sony TV automatically… there is something which I’m missing?

Ps.: Got working, however only SimpleIP works…


(Kristof Rado) #474

Now I’m getting this error:

OFFLINE - COMMUNICATION_ERROR Error connecting to simple IP tv

Device seems to be online, ping-able, etc…

Ps.: Can anyone provide a solution for this?

Restarting openhab, doesn’t help on this problem, but if I turn on the TV from the remote, the connection becomes available and I can remote control the TV from openhab. However I think this function turns off after some minutes. Anyone had same issues? Energy-saver mode is off, Remote Control is on… I can’t find any other settings on the TV related to this…

Using Wi-Fi instead of LAN can cause this issue? After the connection is lost (around 1min) I can’t even ping the device, the device disconnects from WiFi. Are there somewhere a toggle where I can turn this behaviour off?

This is a Bravia KDL32W705C


(Daniel Linder) #475

I have experienced the same issue with the binding, since a few months. (have a 2015 8005 series LCD TV). If i re-enter the access code, it gets online again. However, the current binding is so untstable with the daily 2.3 builds, that I’ve stopped using it.
Normally it runs fine for ~24 hrs. Then it starts to spew ridiculus amounts of errors in to the logs, eventually it makes the whole system sluggish. (if I remove the sony bidning, everythings runs nice and smooth as usual).
I waiting for the new “re-write” of the binding, hoping these issues will be resolved.


(Kristof Rado) #476

I’m using the stable 2.2.0 release and I don’t get any errors…
However I can’t even setup the IRCC, and other channels (just the SimpleIP). Restarting the TV and openHab doesn’t help, the discovery can’t find the device.

This is not my main TV and I can live with that I can only use the SimpleIP, because it has all the functionality (turning on-off, channel change, etc…) which I need, but this is really prevents using this binding that TV turns off completely after a few mins. And I think this is not the problem of the binding, because as soon as I turn the TV on from the remote control it connects to the TV. Years before I have tried a mobile app for this TV, but as I can remember it had this same problem, that I was unable to turn on the TV after not using it for ~10 mins.

I just saw that there is a value for which network adapter is used. However is it not so clear that this is the adapter of the TV or how the openhab server connects to the router?


( . ) #477

Do you need any help or testing? I own a sony-kd-49xe8005


(Kristof Rado) #478

I just want to ask that there will be any new to this binding in the new 2.3 stable release? If I’m currently on 2.2?

Also do you have any idea to this problem which I have?

Since then I have restarted several times the TV and openHab as well, but still can’t find it, just simple ip tv works… also it get’s disconnected after I turn TV off.

Thanks!


(Jonas) #479

Hi!

My bining is working nicely even at 2.3.0.
My binding is still at RQST code mode. But it works.
The only issue i have is that my changes of the ignored channels are not saved.
That’s kind of annoying because i don’t want the binding to ignore any …
Maybe this issue goes along with the not saved ignore-configuration.
I don’t know how to get my tv to provide a code i could enter there …


(Kristof Rado) #480

What kind of device do you have?

So that means that you can power your TV on anytime from openHab? My TV always gets disconnected from the internet…