Speedtest-cli Internet Up-/Downlink Measurement Integration


(Michael Schnaitter) #63

Can you upload the icons as SVG?


(davorf) #64

Hello!

Can someone tell me why this application report much slower speeds than speedtest.net website test? Using the same test server, I get around 25Mbps using this applicaton and over 95Mbps using website test.

Best regards,
Davor


( ) #65

I’m not seeing such problems. Did you do the website test on your openHAB system? Maybe your system or your systems link to the network is the problem!?


(davorf) #66

Hello!

Yes, I’ve done website testing on the same machine application and OpenHAB are running.

Best regards,
Davor


( ) #67

And you are seeing the same results on the console? Maybe your situation is a bit special and you need to choose one specific server. 95MBps is not nothing and some of the servers are in fact low at times.


(davorf) #68

By the way, I’ve tried with few different servers, testing application and website one after another. I’ve also tried testing in different times of day, but the results are the same - application shows speed almost 4 times slower than website.

Edit: Yes, console shows the same speed as items in OpenHAB. And it’s 4 times slower for both, upload and download speed.

Best regards,
Davor


( ) #69

Then you need to contact the developer, check issues and create an your own with your findings. Seems like the software is reliable on mine and many others internet connection… good luck!!


(davorf) #70

Thank you for your help. I’ll open an issue on github.

Best regards,
Davor


(Rich Koshak) #71

This may not be the cause in your case, but some ISPs cheat by throttling your network speed unless it detects you going to a speed test website. Then they open up so it looks like you get full speed.


(davorf) #72

Hello Rich!

I don’t think it’s the case here, because my downloads go over 11 MB/s and that’s much more than 25-30 Mbps latest (v1.0.3-a) speedtest-cli reports. I found out that v1.0.2b shows results much closer to speedtest website. Thank you for your help.

Best regards,
Davor


( ) #73

If you were able to resolve your problem, please let us know.


(davorf) #74

Hello!

The solution for me is using an older version (v1.0.2b). The results are pretty close to the speedtest website, few Mbps less, but it’s less than 10% difference. The difference between current and older version is even more obvious on upload (0.2 Mbps with latest version, 5.5 Mbps with 1.0.2).

Best regards,
Davor


(Sir Leone) #75

Anyone managed to have chart working correctly ? Rule set to measure speed every hour which works and shows mbits every hour :slight_smile:

 Time cron "0 0 * * * ?"

my items :

Chart item=SpeedtestResultDown label="Download" refresh=60

my rrdj4.persist:

Items {
        zasobnik_temp, SpeedResultDown, dining_room_ambient_temperature_c : strategy = everyMinute
}

where zasobnik_temp and dinig_room_ambient works ok, but for SpeedResultDown there is no info in log about storing values in rrdj4 database nad therefore there is no graph in chart.


(Scott H.) #76

Your chart items name is SpeedtestResultDown and in your persist file the item name is SpeedResultDown. The names do not match.


(Sir Leone) #77

thank you, it was so stupid that i am ashamed of this mistake :wink: Of course chart is working correctly :slight_smile:


(Scott H.) #78

I was running the test every hour but it was using around 4 Gb a day and slowing down my video streams. I so only run it once a night now.


(Djuscha) #79

Speedtest Works !Thank you very much
What is with statistics display. How often do you have to test it so that the ad appears?


( ) #80

I am persisting the introduced items to influxdb and am drawing grafana graphs from them. These are then displayed under statistics. I decided to not make that part of this tutorial as it is not really related. For more details check (speedtest can be seen in the middle of the first posting):

The ad?


(Djuscha) #81

Sorry Google translate :slight_smile:
Thank you very much Now I have something to read …


(Djuscha) #82

It has all worked … and now suddenly no more … what am I supposed to do? Please Help.:frowning:

pi@raspberrypi:~ $ speedtest-cli --simple
Traceback (most recent call last):
File “/usr/local/bin/speedtest-cli”, line 9, in
load_entry_point(‘speedtest-cli==1.0.0’, ‘console_scripts’, ‘speedtest-cli’)()
File “build/bdist.linux-armv7l/egg/speedtest.py”, line 1400, in main
File “build/bdist.linux-armv7l/egg/speedtest.py”, line 1376, in shell
File “build/bdist.linux-armv7l/egg/speedtest.py”, line 1086, in upload
File “build/bdist.linux-armv7l/egg/speedtest.py”, line 497, in _create_data
MemoryError