SSH Password

Hi - I’m just starting with this and I’m working through the openHABianPi installation. All seems to be working well and I can get to the openHAB 2 dashboard.

When I’m attempting to ssh to the pi from terminal (ssh pi@ it is requesting a password. I’ve tried openhabian:openhabian as per the Quick Start but it is coming back ‘permission denied, please try again’.

Any ideas what could be the problem?



Try pi:raspberry as that is the default Pi login.

1 Like

Thanks for the reply- tried that but it didn’t work.

Not sure about the distro you’ve mentioned, but on Jessie based installs, SSH is disabled by default… either go into raspi-config and enable SSH – or add a file to /root named ssh on the SD card.

openhabian:openhabian is the default username password combination for openHABian (since version 1.1). That means that both username and password are “openhabian”

So what you need to do is connect with ssh openhabian@ and enter the password “openhabian” when prompted.

@Max_G this is not the case for openHABian as it is intended as a headless installation.

1 Like

Thanks ThomDietrich! That solved it.


I am having the same problem. I can login using ssh pi@“ip address”, using raspberry as password. But if i try using ssh openhabian@“ip address”, using openhabian as password I get permission denied. I am using the terminal on my mac os to do this. Any ideas, thanks

Raspberry pi worked for me. I was getting frustrated before I tried your solution. Everybody thinks everybody’s install is the same, but apparently, some things don’t work out perfectly.