Start smbd (samba) at boot: chkconfig not found

I’ve installed openHAB3 in Portainer (Docker) and want to access the filesystem via samba.

What I did:
apt-get install samba samba-common-bin
and edit /etc/samba/smb.conf.
After that I start the service via service smbd start. But when I reboot the container, samba is not started automatically so I have to enter service smbd start after every restart.

I’ve read that I can chkconfig smbd on but this tells me bash: chkconfig: command not found.
Anyone having a hint for me? Thanks in advance!

Did you try

systemctl enable smbd


sudo systemctl enable smbd

yes, it’s enabled

that means it works now ?

No, unfortunately not.

Did you check ( with command testparm ) if the smb.conf is correct and does not contain any error ?
An other question: is samba installed inside of your container or outside/on host ?
I have the impression samba is installed on host and not inside your container.

For openHAB in the portainer, testparm shows that the smb.conf is correct; no errors.
But you are right, I run portainer in proxmox and samba / samba-common-bin is not installed over there.

Thank you for your help! Marking as solution.

1 Like