Start/stop KNX 2

Hi

I’m trying to migrate my complex KNX configuration to the KNX2 binding.
But how can I migrate a start/stop diagram sending dimmer?

I have a buttons that control DMX lights. In the old binding I could add “ss” to it to get it working like this:
Dimmer DMX_spot_office "Hoofdlicht [%d %%]" (Lights_random, Lights_DMX) {knx="<1.001:0/2/0, 0/2/1ss"}

I tried creating the button in the GUI with these properties, but the dimming isn’t received:
Start/stop: 0/2/0
Abs dimming: empty
Rel dimming: 0/2/1

But it’s not received in OpenHab. I also tried with “0/2/1ss” although it’s never described, but it also failed.

I’m not sure if this feature still does exist in knx2.

I was afraid it didn’t. But I have a lot of KNX devices where start/stop is the only possibility. How do Connect those in the new binding? I also thought that this is the future recommended dimming method? It sure does reduced the number of messages on the slow KNX bus.

In fact, the recommended way to use dimmers is to use absolute dimming.

There is no command “STOP” for dimming at all, and I doubt that there will be such a command, as this behavior is very special for knx.
Please also be aware that the configuration

Dimmer DMX_spot_office "Hoofdlicht [%d %%]" (Lights_random, Lights_DMX) {knx="<1.001:0/2/0, 0/2/1ss"}

is used the other direction, so openHAB will only receive START/STOP dimming.

Hi

Yes, that openHAB only receives the dimming is how it’s designed. The KNX device is a button (one button dimming) and the DMX device is a RGBW LED light. openHAB is the bridge in between.
There is no use in reporting the dimming status to the button when toggling the light from within openHAB. Only the on/off status is reported to the switch so the toggling can work.

I use 5 types of KNX button interfaces (so inputs) in my house and non of them support absolute dimming.

  1. Berker 75341006, Berker 75341004, Gira 1118 00 and Schneider MTN6003-0002
  • No reading object where I can send absolute dimming value to.
  • Supports setting “Transmit stop telegram” to ON or OFF (currently set on ON)
  • Support setting “Telegram repetition” to ON or OFF (currently set on OFF)
  1. MDT BE-02001.01
  • No reading object where I can send absolute dimming value to.
  • No options to change the start/stop dimming to repetition dimming at all.

Also see this topic with the advantages of SS dimming and other devices that only support SS: https://github.com/openhab/openhab1-addons/issues/635

Yes, that’s correct. I meant the recommended way for openHAB is to use absolute dimming.
Every knx dimmer (not the wall button) should provide absolute dimming. This should also be true for dmx<->knx gateways. In fact, as openHAB itself has a dmx binding, you could use an interface to directly communicate to dmx (but that would mean to rely totally on openHAB as openHAB would be the gateway between knx and dmx)

That’s what I do currently: relying completely on openHAB. openHAB communicates with DMX using a USB DMX convert. The reason you don’t see the DMX binding in my rule from my first post is because I have RGBW lights, so 4 channels. So the dimmer controls a value 0-100 in openHAB and at every change a openHAB rule calculates the red, green,blue and white values (0 - 100) that are send to the DMX binding.

So the KNX button controls a percentage in openHAB that is used as input to control 4 new values that are send to DMX. It is very cool except at the moments that my openHAB server is broken again and that most of the lights are off in our house.

Therefor the problem is that:

  1. Some KNX devices like the one from MDT only support sending a start and stop diagram. I can’t receive them in the KNX 2 binding while I still can in the first KNX binding. There is no setting on those devices to let it repeat the dimming diagram.
  2. Repeating the diagrams fills the KNX bus even more. My KNX already is saturated.

Ah, I see… :slight_smile:

Please feel free to open an Issue at https://github.com/openhab/openhab2-addons, start/stop dimming should be provided at least for receiving commands (i.e. dimmer-control channel)

Seems that I was using the wrong channel. When I switched from dimmer to dimmer-control I found a value to repeat the dimming commands and it’s working with start stop!

Cool!