Startup and performance issues


I’m using OpenHAB for about 6 month now. In general, I’m quite happy and things are running smooth. Well, allmost :frowning: So here is the issue that is driving me nuts: I’m running openhab 1.8.3 on a Notebook under Ubuntu 16.04 Server. I’ve got running: Astro, Weather, ZWave, Squeezeserver, NW Health, MySQL, Mail, HABMin Bindings.Installed a local TTS. My Startup time was something around 2 Minutes and a java process using between 0,x and 5 % processor. Then, from one day to the other, I’m up to 20 minutes startup time with a java process using 190%(two processor system) CPU. Once startup is finished, java process uses 30% and shoots over 100% when opening any sitemap. I did a complete reinstall of everything to no avail.Then yesterday, I added a new item and startup ended while loading this item file. So I copied the content to GEdit, deletet the file and pasted the content to a new file. Bam, startup back to 2 Minutes and processorload at a smooth 1-5%. But unfortunatly not for long. Today I saw a processor load of 30%, did a restart and now I’m back to 20 Minutes startup. My initial guess that it was some kind of codepage problem seems debunked. I’ve deleted every item, sitemap, rules file and it behaves the same. Between the first log message and “OpenHAB runtime started” it takes 2-3 minutes:
Aug 20 19:14:30 JARVIS systemd[1]: Starting Starts and stops the openHAB Home Automation Bus…
Aug 20 19:14:33 JARVIS systemd[1]: Started Starts and stops the openHAB Home Automation Bus.
Aug 20 19:17:13 JARVIS[3205]: 2016-08-20 19:17:13.408 [INFO ] [.o.core.internal.CoreActivator] - openHAB runtime has been started (v1.8.3).
Then persistence, items, sitemaps, rules are loaded.
I have tried both Oracle Java 1.8 and openJDK 1.8 with the same results.
Has anyone seen such behavoir or any hint how to pinpoint the problem? Any help appreciated as I’m completely out of ideas.
Many thanks in advance,
Best regards,

Today I purged the openjdk-8 i was currently running on and reinstalled Oracle Java 8:
`java version "1.8.0_101"
Java™ SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot™ 64-Bit Server VM (build 25.101-b13, mixed mode)

However, situation did not change. The java process takes literally all procesor time there is during startup and stays at `30-40 % when idle. During startup, this leads to timeouts when trying to connect to the MySQL Server. When opening HABDroid, it takes severall seconds until sitemap is diaplayed. Pushing a simple switch item takes load over 100%, Item icon takes 1-2 seconds to update it’s state. Pushing a Number Item to trigger a simple rule (e.g. Nightlight - turn light on and start timer to shut it off in 5 minutes) also takes seconds until light turns on. If i open HABMin, processor load shoots to 180%, opening the branches for any ZWave device is a nightmare. Here is a typical log:
start openhab executed at: Aug 23 10:17:28…Then two minutes of silence and runtime starts:

2016-08-23 10:19:48.196 [INFO ] [.o.core.internal.CoreActivator] - openHAB runtime has been started (v1.8.3).
2016-08-23 10:20:38.901 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - mDNS service has been started
2016-08-23 10:20:42.665 [INFO ] [o.o.i.s.i.DiscoveryServiceImpl] - Service Discovery initialization completed.
2016-08-23 10:20:49.552 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'mysql.persist'
2016-08-23 10:20:59.910 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'wetter.items'
2016-08-23 10:21:01.718 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'wecker.items'
2016-08-23 10:21:02.115 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'astro.items'
2016-08-23 10:21:02.561 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'zuhause.items'
2016-08-23 10:21:03.550 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'test.items'
2016-08-23 10:21:04.293 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'diverse.items'
2016-08-23 10:21:05.368 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'squeeze.items'
2016-08-23 10:21:06.748 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'lights.items'
2016-08-23 10:21:44.313 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'control.sitemap'
2016-08-23 10:21:53.172 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'Cara.sitemap'
2016-08-23 10:21:53.606 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'zuhause.sitemap'
2016-08-23 10:21:55.807 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'oli.sitemap'
2016-08-23 10:22:36.224 [INFO ] [] - Started REST API at /rest
2016-08-23 10:22:43.795 [INFO ] [.o.u.w.i.servlet.WebAppServlet] - Started Classic UI at /classicui/
2016-08-23 10:23:03.705 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'diverse.rules'
2016-08-23 10:23:08.284 [INFO ] [io.squeezeserver.SqueezeServer] - Squeeze Server connection started.
2016-08-23 10:23:13.608 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'anwesendheit.rules'
2016-08-23 10:23:22.916 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'sicherheit.rules'
2016-08-23 10:23:23.323 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'test.rules'
2016-08-23 10:23:23.852 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'wecker.rules'
2016-08-23 10:23:24.392 [INFO ] [c.internal.ModelRepositoryImpl] - Loading model 'zuhause.rules'
2016-08-23 10:23:37.761 [INFO ] [] - Started HABmin REST API at /services/habmin
2016-08-23 10:23:43.980 [INFO ] [.service.AbstractActiveService] - NTP Refresh Service has been started

Normally all this should happen within seconds, not minutes. This leads to a backlog, A rule that should fire every minute is executed 5 times in a row until the system has caught up.
Are there any extra java arguments i could add to the startup for more log output? I tried setting debug to “yes” but that did not help.
many thanks in advance for any helpfull tipps,
Best Regards,