i just started carrying out my own system , i have burned the openhabian image on the sd card and inserted it in the raspberry for booting . i have a problem , i’m trying to follow the progress of booting but i have this message ?!! any help please …


You can log into the Raspberry with ssh to see if the initinal setup has finished or if there are any issues. With openHABian it takes a while until all required files are downloaded and set up. The progress can be seen, if not automatically visible use

sudo tail -f /boot/first-boot.log

on your Raspberry.

Then follow the instructions and information for the initial openHABian use here:

1 Like

I don’t think this will help @mohamed, @Hans_Lree.

The Error shows the hostname openhab cannot be solved to an ip address.
So I don’t think he can connect to the device via ssh either.

But you are right.
Looking into the log file (via monitor and keyboard) should help.

Can you look in your wifi/dsl router to see if your Raspberry is connected to your network? Maybe you find the ip address there.

Did you use ethernet cable or wifi?
Did you configure your wifi credentials?

1 Like

It’s also possible that your Windows computer simply can’t resolve the //openhab hostname to an IP address. mDNS hostnames on a local network are not terribly reliable, and the problem could be your PC, your router, or both.

Try using the actual IP address of the RPi instead of the hostname. If that works, then you can stick with using that to connect to your RPi. Make sure to assign it a static/reserved IP so that it doesn’t change on you in the future.

  • i’m using an ethernet cable .
  • once i put the sd card for the first boot , i checked the RPi connection to the internet through the " advanced ip scanner " program . it seems that it is connected and given an ip adress , but after passing 45 mins i have unplugged the RPi , connected it again , then checked its connection to the internet again and found that it isn’t connected . !!
  • during the booting process i tried to log into the raspberry using its IP, not the hostname , and this failed aslo

If the raspberry shows up in the network scanning programme and it has an IP on your internal network, you should be able to log in with ssh. How did you try to connect, something like

ssh openhabian@192.168.XXX.XXX


That’s what I meant with my first reply. As soon as you boot the Raspberry up for the first time and are able to ssh into it, sometimes the first-boot.log progress comes up automatically, sometimes it doesn’t and you have to call

sudo tail -f /boot/first-boot.log

yourself to see the progress. 15-45 minutes is already a vague time estimate, and I have encountered very quick first boots and sometimes very slow and long ones, it all depends on the day and your internet connection then.

The first-boot.log gives you vital information if everything is installed correctly, and yes, on the odd occasion the first-boot progress does come up with errors, which then means your initial automatic setup hasn’t succeeded.

Please let us know if you can ssh into the Raspberry right after you boot it up and it has an IP address in your network scanner.

1 Like

well , i concluded that :
1- i have to ssh to my raspberry during booting process to follow its progress :
i will make so , but i think i have to format the raspberry for the new start . is it enough to format the sd card and rewrite the openhabian image ?

2- i may have a problem in the settings of my router or my pc that makes me unable to log into the raspberry through its ip . any suggestions for that ?

Yes, reformat the SD card and burn the openHABian image onto it again.

If the Raspberry is on the same network as your PC, and if it gets an IP address from your router - as you previously stated - from the top of my head, I cannot think of a reason why you shouldn’t then be able to ssh into said Raspberry with

ssh openhabian@192.168.XXX.XXX

Then follow the openHABian installation and setup progress with the first-boot.log

1 Like

i have burned the file image on the sd card again and inserted it into the raspberry . i have also checked the IP of the raspberry , then tried to ssh to my raspberry using its IP in order to check the booting progress but i have given this message !!!

Did you try the ssh session as mentioned here?

obiously with the the username openhabian and password openhabian

No experience with PuTTY here. Can you ping the Pi from your Windows machine?

yes , i followed the same steps , but i still unable to ssh . given the same error message .

Hello - I am new to this! Tried to boot up my new RPi4 I thought I had followed the instructions correctly - I flashed Openhabian to SD card, inserted into RPi4, connected Ethernet cable, turned on power. I get this msg:
Raspberry Pi 4 - 8GB
bootloader: 940f978d Mar 19 2020
board: de3114 2c6b7dc dc:a6:32:b8:48:1b boot: mode 6 order Ox00000001 rsts Oxe0001000
SD CID: 00035344534333324780eof78b670146
part: O mbr (Oxoc:00002000 0x83:00084000 exe0:00000000 Ox00:00000000] tw: start4.0lf fixup4.dat
net: down 1p: sn: gw: 0.0.o.o tftp:
lba: 8192 oem: ‘mkfs. fat’ volume: ’ boot
rsc 32 fat-sectors 4033 C-count 516191 c-stage 1 r-r 2 r-sec Read config.txt bytes 1735 hnd ex0000029f hash 564723ab5538422a
recovery 4.elf not found
recovery.of not found
Read start4.elf bytes 2759172 hnd exe0009280 hash 2691df2baa2d24dc Read fixup4 .dat bytes 6068 hnd exe00002b2 hash dab44fd1oc87ae51
Oxood 3114 Ox 00000000 ex 00000000 start4…elf: 1s not compatible Os
This board requires newer software. Get the latest software from:

What am I doing wrong?

Hi Gordon, and welcome to the community!

Your problem appears to be different from what’s being discussed here, so it would be better if you started a new thread to ask for help. It gets confusing when there are two different help requests in a single thread. As well, new posts are more visible.

Before that, we typically suggest that new members read this thread to learn the forum etiquette.

I unfortunately don’t know the answer to your question, so I won’t be able to to assist. However, there are a lot of folks whom I think will know how to help.

Thanks - I realised that I posted in wrong place, and did indeed start a new thread. My problem was solved by booting up from the latest beta version from github. While I realised the RPi4 8GB was over-specced, I didn’t realise it would actually be incompatible. Kudos to Markus Storm, I am now back on track

1 Like