Status updates for Qubino Relays/Dimmers generally do not work

Hi!
I have 30+ modules form Qubino, different type.
And the same problem with module state updates.

Im working on OH2 testing and can help you on testing

I also have the same issues with Qubino devices. Even the dual relay switches keep being initialized as static. is there something i can do about that?

Ok excluding and including the device back in solved the static issue.

If it helps to solve the problem:

Status updates from manually switching the relays do work with me as written here with the relais of Qubino “ZMNHBD Flush 2 relays”. I am running 2.1.0-SNAPSHOT Build #927 on OS X version 10.10.5. Inclusion was done with Z-Stick Gen5.

I still get lots (just cleaned out ~1700) of those “ghost” group associations in the /userdata/org.eclipse.smarthome.core.thing.Thing JSON file with my ca 10 Zwave devices as described here. I get duplicate “ghost” association entries even when just working in Habmin. This might be a connected problem, maybe?

I have seen your post previously and have also tried that, probably followed every reasonable suggestion in the forum in over 40 include/exclude etc. attempts. I also have Z Stick Gen5 and also am only using the Switch1/2 channels, not the “legacy” ones. In an earlier releases I at least had a Flush 1 Relay working (but this only was because I used the legacy channel), now it doesn’t work anymore either. Part of the problem is regression related, I am pretty sure about that (bugs introduced in the context of code changes).

I think the problem is pretty much narrowed down to a problem with association groups in the context of multi channel association at this point. As a point in case, This is nicely visible in the channel settings of the device. Association group fields generally are all blank, and if I try to add the controller to Group 1 / Lifeline it vanishes again at some point. More importantly, NOTHING gets written to org.eclipse.smarthome.core.thing.Thing.json, even though this is what I set in Habmin:

(this setting will go away latest at next reboot)

You can check my org.eclipse.smarthome.core.thing.Thing.json here, the screenshot above corresponds to node 26:

I am afraid it’s not that simple, at least not in current snapshot 2.2.0. With no lifeline association with controller, updates are not going to work… :frowning:

@Chris will hopefully solve this at some point.

Ah, finally someone else is having this issue :wink: We also discussed this here, but nothing came out of it (back then). I’m still looking for a solution and am still offering to test.

I think I’ll need to buy a Qubino device to resolve this :frowning: . I’m a little hesitant to do this as Qubino were not very supportive when I tried to discuss this with them some time back (unlike a number of other manufacturers that are really helpful).

Chris, I will donate one to you. Let’s discuss via pm what device makes most sense and how to proceed. Your work here is greatly appreciated and you are already donating a lot of time to this project.

I have seen some rather controversial discussion on the board about financing the OH development and the like. As much as everyone appreciates the open source community, not everyone is a programmer and able to contribute in the same way. I feel that you having to go out and buy hardware to support devices you possibly don’t even use yourself, crosses the line imo. This is where this fantastic project needs some kind of donation platform to help finance things which are needed to keep it going.

On another note, I am disappointed by your experience with Qubino support. I have talked to Ales Humar from Qubino in the past, and found him to be quite helpful. But it does seem clear to me that they are under staffed and probably don’t have the resources required to properly support their products, specially when confronted with issues that require more complex interaction than canned responses like “try to exclude & include the device again”. In any case, I will discuss your complaint with him. Perhaps you can give me more details about your unfruitful interactions via pm. In case they don’t want to cooperate, I feel that users must be clearly warned about buying into Qubino, which will not be good for their business.

Please get in touch with me so we can discuss details about device needed and Qubino support, if you agree.

Cheers,
Allen

1 Like

Thanks Allen - drop me a PM and we can discuss, but I appreciate it. I guess one of the multi switch/dimmer type devices might be most useful.

I know not everyone likes the idea, and it’s clearly personal preference. I’ve personally spent quite a lot to support OH and do receive a few donations which helps a little…

I too was a little disappointed, but I can understand their position. It’s interesting though - I’ve had really good support from a number of manufacturers who have supplied information and devices for testing (Aeon, Sensative, Fibaro and Zooz - although as Zooz are US only, it’s not quite so useful). I had a phone call with Qees/Qubino about a year back, but they said it was company policy not to provide test devices. I forget who I spoke to and can’t find the email right at the moment - I did get another name to try within the company, but had no response there…

Chris

Hey @chris, I have the ZMNHAD lying around with the same problem.

It’s useless to me now, so if it helps you fix the problem I will gladly ship it to you (free of charge, of course).

Let me know!

Hi Chris did Qubino R&D specialist contacted to you?
They promise me to give some technical support to this issue.

Yes, they have been in contact - thanks. I think the issue is understood - I just need to be able to test it to find out why it’s not working. I have a 2 relay device arriving today or tomorrow I hope. However it’s good to have the contact as it will surely help if there are issues or questions.

@MLowijs thanks for your offer - I didn’t see this until today and now have a 2 relay device coming (courtesy of a donation from @automatic).

1 Like

Hi Chris!
Any news about qubiono modules? Did you manage to locate and solve problem?

Im crossing my fingers for this!

I plan to look at this over the weekend so please keep your fingers crossed :wink: .

3 Likes

@chris were you able to take a look at this? We’re eagerly awaiting your findings :grin:

Yes - I spent some time on it last weekend and hopefully have a fix (at least I have it working here). I just need to do a slightly better test to make sure it doesn’t cause problems elsewhere before I merge it into the development binding.

I’ll try and get it merged in the coming days (or maybe the weekend as I’m quite tied up this week).

1 Like

Is it already merged? I can do some testing

Just click on the link and take a look if it says “Merged” … :grinning:

Yes - but note that it’s merged into the development branch.

See here -:

It gets hard to keep track on all those changes :sunglasses: … not only with the zwave binding.