Steinel IS140-2 PIR sensor


I’m currently using openHAB 2.5.6 and since the upgrade the binding is reporting errors for the Steinel IS140-2 device.

2020-06-29 08:53:52.675 [ERROR] [class.ZWaveMultiInstanceCommandClass] - NODE 14: Endpoint %d has invalid device class. generic = 0x2, specific = 0xf0.
2020-06-29 08:53:52.739 [ERROR] [class.ZWaveMultiInstanceCommandClass] - NODE 14: Endpoint 3 has invalid device class. generic = 0xff, specific = 0x2.

Furthermore i am unable to save changes in the Association Groups settings. Any changes are lost after saving. This happens in PaperUI as well as in HabMIN. Thus i cannot associate the On/Off control to my switch so that the light is turned on after movement. Also the luminance value is not reported to the controller.

Any advices what i can do?


I enable more detailed logging and it seems that the binding is busy sending messages to the device. I assume that is not normal?

openhab.log (789.1 KB)

It seems that the device doesn’t respond to a request on endpoint, so the binding resends the request. It is stuck in this loop unfortunately - the binding is unable to continue without this information.

Hmm … i excluded it and included it again but i do get the same errors. Additionally the following is logged once after inclusion

 [INFO ] [ommandclass.ZWaveVersionCommandClass] - NODE 17: Command Class COMMAND_CLASS_ALARM has version 0!
 [INFO ] [ommandclass.ZWaveVersionCommandClass] - NODE 17: Command Class COMMAND_CLASS_VERSION has version 0! 

Previously the device worked as expected and it was just a minor openHAB upgrade (2.5.4 to 2.5.6). Anything that i can try or do?

I can’t think how to work around this at the moment. There hasn’t been any change to the binding and it seems that the device is simply not responding to the request.

Ok strange. Thank you anyway!

I wanted to debug the endpoint issue and prepared a dev-environment. Unfortunately the issue is not reproducible. When launching from eclipse the device is discovered and the node.xml is written. No errors are reported. :confused:

Unfortunately the issue with the association group remains. I cannot update them. I set a breakpoint and found out that the device does not have a single association group set. The association group map is empty. I added the groups manually by editing the xml file. Now i can store the associations. But i am not sure why the binding would not discover them. Need to debug that in the next days :slight_smile:

@chris: Saw that you fixed the issue with the endpoint log. Wanted to contribute that but you where faster :smiley:

@mheiss: Do you have any news about this issue?
It seems, I have the same or similar issue not being able to change the association groups. Or a hint how you changed it manually?
Many thanks in advance!

Sorry for the late answer. I managed to create the association groups by changing the XML in the file-system. I forgot the details what i did BUT this did not help at all. The device is not sending any events. There was a short time frame where the device worked as expected but then it suddenly stopped working. I have no idea why and i did not further invest more time since then. Now that it is dark again in the evening i might start another try to get that damn thing working :smiley: