Strange behaviour when running Jython Script in OH1

I have created a new Jython script that acts as light scheduler for my house, when I am away. I have for some time developed omn it on my Windows machine where it started just fine. Yesterday I wanted to put it on my Raspberry Pi controlling my house. Then something strange occurred…
It threw an Folder exception and it seems that some of the Item files didn’t load, and thus it complained about missing zwave items ( I have split my items into multiple files, thus giving me a modular design). If I named my Python script so that it wouldn’t load at startup, then everything loads just fine on my Raspberry. After a minute I could rename the python script and now it loads just fine.

I tried to moved execution to a Ubuntu server, still the same behaviour. Then I tried to move all item declarations into a single file, and now it suddenly loaded just as expected on my Ubuntu server. Back on my Raspberry I tried to move every thing into one item file, with no success.

It seems that on a slower machine, items isn’t loaded before jython scripts is loaded? I saw a old posting in the forum, with that error, it seems that the load order of JSR223 was wrong at that time (it seems to be an error back in 1.7).

Is there a way to delay laod of JSR223 scripts from the config for a minute when starting?
Any suggestions?

It seems that I have found the cause pf my troubles, or at least some of it:
I once read about changing that FolderScan frequency from 10 to eg. 30 in my openhab.cfg:

Standard setting


My setting:


When running with 30 on my Ubuntu server it starts to fail consequently.
I have merged all my items script into one file, since I have noticed better performance when doing that.

Can somebody tell me if the above behaviour is “as designed” or is there some bug hidden somewhere ?