Strange error logs

(Simon Crump) #1

Hi Everyone,

Hopefully I have the right area to post this. I have Openhab setup and running on a Pi3, with various Sonoff/Tasmota devices around the home. I also have the homekit add on setup and use Siri to operate the devices. I also use Alexa. Everything was running fine until the other day I noticed my Internet was done and the router required a reboot. Was ok for another day and then it did it again. I have been working through everything in the house to determine whats going on and when I looked at the openhab logs I found this-:

2018-12-04 12:58:10.374 [ERROR] [lfe.hap.impl.http.impl.BinaryHandler] - Exception in binary handler

java.io.IOException: Connection reset by peer

	at sun.nio.ch.FileDispatcherImpl.read0(Native Method) ~[?:?]

	at sun.nio.ch.SocketDispatcher.read(SocketDispatcher.java:39) [?:?]

	at sun.nio.ch.IOUtil.readIntoNativeBuffer(IOUtil.java:223) [?:?]

	at sun.nio.ch.IOUtil.read(IOUtil.java:192) [?:?]

	at sun.nio.ch.SocketChannelImpl.read(SocketChannelImpl.java:380) [?:?]

	at io.netty.buffer.UnpooledUnsafeDirectByteBuf.setBytes(UnpooledUnsafeDirectByteBuf.java:447) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.buffer.AbstractByteBuf.writeBytes(AbstractByteBuf.java:880) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.channel.socket.nio.NioSocketChannel.doReadBytes(NioSocketChannel.java:242) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.channel.nio.AbstractNioByteChannel$NioByteUnsafe.read(AbstractNioByteChannel.java:119) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:511) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.channel.nio.NioEventLoop.processSelectedKeysOptimized(NioEventLoop.java:468) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:382) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:354) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:112) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.util.concurrent.DefaultThreadFactory$DefaultRunnableDecorator.run(DefaultThreadFactory.java:137) [226:org.openhab.io.homekit:2.3.0]

	at java.lang.Thread.run(Thread.java:748) [?:?]

2018-12-04 12:58:10.379 [ERROR] [.hap.impl.http.impl.AccessoryHandler] - Exception caught in web handler

java.io.IOException: Connection reset by peer

	at sun.nio.ch.FileDispatcherImpl.read0(Native Method) ~[?:?]

	at sun.nio.ch.SocketDispatcher.read(SocketDispatcher.java:39) [?:?]

	at sun.nio.ch.IOUtil.readIntoNativeBuffer(IOUtil.java:223) [?:?]

	at sun.nio.ch.IOUtil.read(IOUtil.java:192) [?:?]

	at sun.nio.ch.SocketChannelImpl.read(SocketChannelImpl.java:380) [?:?]

	at io.netty.buffer.UnpooledUnsafeDirectByteBuf.setBytes(UnpooledUnsafeDirectByteBuf.java:447) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.buffer.AbstractByteBuf.writeBytes(AbstractByteBuf.java:880) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.channel.socket.nio.NioSocketChannel.doReadBytes(NioSocketChannel.java:242) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.channel.nio.AbstractNioByteChannel$NioByteUnsafe.read(AbstractNioByteChannel.java:119) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:511) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.channel.nio.NioEventLoop.processSelectedKeysOptimized(NioEventLoop.java:468) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:382) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:354) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:112) [226:org.openhab.io.homekit:2.3.0]

	at io.netty.util.concurrent.DefaultThreadFactory$DefaultRunnableDecorator.run(DefaultThreadFactory.java:137) [226:org.openhab.io.homekit:2.3.0]

	at java.lang.Thread.run(Thread.java:748) [?:?]

I am not a programmer and very inexperienced with Openhab, could someone tell me what on earth this lot means or how I can go about finding out what it all means. It also appears that the cloud service has been disconnecting and reconnecting sometimes -:

==> /var/log/openhab2/openhab.log <==

2018-12-04 08:44:18.089 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = f40a0522-c696-4a2d-bf05-4bdd52816c08, base URL = http://localhost:8080)

2018-12-04 08:44:30.385 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = ************************************* , base URL = http://localhost:8080)

2018-12-04 08:48:18.412 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = ******************************************* , base URL = http://localhost:8080)

2018-12-04 08:48:53.821 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = *******************************, base URL = http://localhost:8080)

2018-12-04 08:51:34.534 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = ******************************, base URL = http://localhost:8080)

2018-12-04 08:52:18.780 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = ***********************************, base URL = http://localhost:8080)

==> /var/log/openhab2/events.log <==

2018-12-04 08:53:42.712 [vent.ItemStateChangedEvent] - Sonoff_relay3 changed from OFF to ON

2018-12-04 08:59:34.164 [vent.ItemStateChangedEvent] - Sonoff_relay3 changed from ON to OFF

==> /var/log/openhab2/openhab.log <==

2018-12-04 08:59:43.231 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = ******************************, base URL = http://localhost:8080)

2018-12-04 08:59:54.332 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = ***********************************, base URL = http://localhost:8080)

Any ideas? Thanks in advance.

Crumpy

0 Likes

(Anjana) #2

OpenHab cloud had a recent outage. See here details: openHAB Cloud down, AGAIN
This must be the cause for frequent disconnects, nothing to do with your setup.

0 Likes

(Simon Crump) #3

Hi,
Thanks for the response, yes I had seen that but its still doing it now every so often. Its done it again about 30 mins ago…

0 Likes

(Angelos) #4

ehmmm… no? :slight_smile:
http://status.openhab.org/

0 Likes

(Anjana) #5

I might be wrong, but the status says:

Dec 06, 2018

Automatic website monitoring identified an issue with openHAB Demo Server.

Automatic website monitoring identified an issue with myopenHAB Cloud Service.

Dec 05, 2018

Automatic website monitoring identified an issue with openHAB Demo Server.

Dec 04, 2018

Automatic website monitoring identified an issue with openHAB Community Forum.

Automatic website monitoring identified an issue with openHAB Demo Server.
0 Likes

(Simon Crump) #6

Can anyone shed any light on what these errors may be?
Looking at them it looks like something to do with the Homekit binding but it is way over my head.
Do I need to uninstall the binding or update it in some way?
I get this error about every 15 -30 mins constantly.

Is anyone else getting this?

0 Likes

(Anjana) #7

This looks like causing due to iOS device leaving WiFi intermittently. And error messages are harmless and the fix is to turn them off in debug log. See (https://community.openhab.org/t/homekit-not-working-properly/15259/43) for details.

0 Likes