Strange things happen to ui

I’m running OH (actually 3.2) on a Raspberry Pi 1b for some years now.
A few weeks ago my zwave setup (mostly roller shutters controlled by zwave -usb-stick) started to stop working…bad, but now it gets worse:

A few days I thought the some other things/ items in my sidemap won’t. But after a refresh i saw that the ui openhabianpi:8080 e.g. 192.168…:8080 can’t be reached :scream:…and the same to the log viewer (:9001). The only possible access was by SSH/Putty.

And now “worse on highest level”: I’ve mounted a vanilla sd-card,new OH-download … and… UI still not available…more: I’ve managed to call the log viewer one time (no entries - i think cause of the vanilla installation)…But now I can’t even get there.

Any suggestions? Is it the dry, hot summer? (Could not really be…installation is in the basement…no more than 31°C.

Thanks in advance


ssh to the machine and look at the OH logs directly. Also look at the syslogs for errors

i’m not sure where to find these correct files - i’ve checked the folder /var/log/openhab … there’s no file there. The “syslog.l” looks inconspicuous … but I am also unsure what to look for.

Here’s all files and subfolders in the /var/log:

openhabian@openhabian:/var/log $ dir
alternatives.log auth.log bootstrap.log daemon.log debug dpkg.log fontconfig.log kern.log lastlog
apt auth.log.1 btmp daemon.log.1 debug.1 faillog journal kern.log.1 message

You don’t say this but it looks like you are running openHABian. That’s important info.

Run sudo systemctl start openhab followed by sudo systemctl status openhab. Post the result.

Ok, here’s the result:

:thinking: :exploding_head:

PS: i’ve checked /etc/default/openhab … So that I am sure that not the ports 8080 / 8443 were diverted

Something is preventing openHAB from starting. Check your folder permissions. Try to start it manually and see if you can get something useful as an error.

Check with
sudo journalctl
for more Info about the root cause

I’m shure, that this don’t look good:

Here we get closer maybe:

… i’m not clever enough to readout unsuccessful the log-file - i’ve tried “less hs_err_pid11971.log”

Could this be some kind von ransomware :exploding_head: …because one (only) time at cold start I could e.g. see the logviewer ( call … now at the second try I get an error message

I doubt it. It’s most likely your SD card is wearing out and/or full. I’d try to migrate to a new SD card with a fresh install and restore of your configs.

Mmmh, o.k. - maybe the SD Card is too old … but to less space … nope:

I am wondering if the messages about “file has become inaccessible” and “file has appeared” means that there is some kind of log rotation which in short time rotates the logs ( old file is renamed; new file is created ).
What is the content of the directory /var/log/openhab ( ls -lt /var/log/openhab/* ) ?
This should show the size as well as the timestamps of the files and should give a clue about files’ sizes and last time an entry was added.

I think i’ve another hint - could it be, that a raspy 1.2 is no longer “openhabian-capable”?

I’ve installed openhabian on a brand-new SD-Card … and during an update process this abort / message occurred:


Right now I believe openHABian only supports “Bullseye”. openHAB itself has never been supported on a Raspberry Pi 1. From the beginning the minimum supported platform was a Raspberry Pi 2. So it is perfectly reasonable to expect that openHABian would not explicitly support running on an RPi 1.

From openhabian docs

We strongly recommend that users choose Raspberry Pi 2, 3 or 4 systems that have 1 GB of RAM or more. RPi 1 and 0/0W just have a single CPU core and only 512 MB of RAM. The RPi0W2 has 4 cores but only 512 MB as well. 512 MB can be sufficient to run a smallish openHAB setup, but it will not be enough to run a full-blown system with many bindings and memory consuming openHABian features/components such as zram or InfluxDB. We do not actively prohibit installation on any hardware, including unsupported systems, but we might skip or deny to install specific extensions such as those memory hungry applications named above.

Supporting hardware means testing every single patch and every release. There are simply too many combinations of SBCs, peripherals and OS flavors that maintainers do not have available, or, even if they did, the time to spend on the testing efforts that is required to make openHABian a reliable system. Let’s make sure you understand the implications of these statements: it means that to run on hardware other than RPi 2/3/4 or (bare metal i.e. not virtualized) x86 Debian may work but this is not supported.

The error message is about java VM. I remember that it happened several times that the java package was installed for the wrong CPU architecture because of changes on the page where the packages is downloaded from. It could be that this happened again - it also could be that this is due to the reason that RPi 1 officially is not supported.
Can you check which java version is installed ? Normally you can do that by running

java -version

As it looks like this will raise an error message what is returned by

ls /opt/jdk/