Success with Sonoff zigbee bridge and zigbee binding

Yes, with this command
socat -dd pty,link=/dev/ttyzbbridge,raw,user-late=openhab,group-late=dialout tcp:
after that everything is good. :grin:


I have also bought the Sonoff Bridge and flashed it with Tasmota. The Sonoff Button is working. I am using MQTT and I am able to control OH stuff with the Sonoff button

I am not sure but I found that Aqara Sensors are directly connectable to the bridge but for me the pairing was not succesful. Anyone got this working?
I set the pairing mode on the bridge and resettet an aqara switch and temp sensor but both dont connect to the bridge.

I was able to pair various Sonoff, Hue and Aqara sensors, including 2 Aqara temp/hum/pressure sensors WSDCGQ11LM :

zbstatus2 0xADEA
21:44:51 MQT: stat/zbbridge1/RESULT = {"ZbStatus2":[{"Device":"0xADEA","Name":"AqaraTemp01","IEEEAddr":"0x00158D000533C4AB","ModelId":"","Manufacturer":"LUMI","Endpoints":[1],"Config":["T01"]}]}

This model is reported as working on blakadder, but WSDCGQ12LM isn’t
What is exactly your model ?

I don"t exactly remember, but I guess I paired then typing zbpermitjoin 1 command on tasmota and then pressed the reset button for 5 seconds.

thanks for the reply. I have the same Aqara sensor like you mentioned (wsdcgq11lm). I tried severall tasmota firmware files on my Sonoff zbbridge. 8.5.1 and 9.1.0 without any difference. What version are you running?

I startet the zbpermitjoin 1 command at the console on the bridge and then pressed 5 seconds on the aqara sensor until the blue light flashes but nothing happened.

I’ve been runnning all the releases of tasmota since zbbridge support.
I guess i was version 8.4.x or 8.5.x when I paired these devices.
I will try to pair again one and let you know.

Which EZSP firmware (from are you using ?

Thanks for response. I tried both firmware files from this page. But I think ncp-uart-sw_6.5.5_115200.ota is not able to use with Zigbee devices so I am running ncp-uart-sw_6.7.6_115200.ota.

What parameters should I use at the configuration?

I’m using the same firmware:

Nov 30 16:56:57 zbbridge1 ESP-ZIG: Resetting EZSP device
Nov 30 16:56:59 zbbridge1 ESP-MQT: tele/zbbridge1/RESULT = {"ZbState":{"Status":1,"Message":"EFR32 booted","RestartReason":"Power-on","Code":2}}
Nov 30 16:56:59 zbbridge1 ESP-MQT: tele/zbbridge1/RESULT = {"ZbState":{"Status":55,"Version":"","Protocol":8,"Stack":2}}
Nov 30 16:56:59 zbbridge1 ESP-MQT: tele/zbbridge1/RESULT = {"ZbState":{"Status":3,"Message":"Configured, starting coordinator"}}
Nov 30 16:57:00 zbbridge1 ESP-MQT: tele/zbbridge1/RESULT = {"ZbState":{"Status":56,"IEEEAddr":"0x60A423FFFE1DBFBF","ShortAddr":"0x0000","DeviceType":1}}
Nov 30 16:57:00 zbbridge1 ESP-ZIG: Subscribe to group 0 'ZbListen0 0'
Nov 30 16:57:01 zbbridge1 ESP-MQT: tele/zbbridge1/RESULT = {"ZbState":{"Status":0,"Message":"Started"}}
Nov 30 16:57:01 zbbridge1 ESP-ZIG: Zigbee started

You cloud try a zbreset but you will need to repair all your devices.
Also, could you paste result of zbstatus and zbconfig commands ?

Hi again,

I unpaired an aqara sensor with zbforget, reseted it by pressing button for 10 seconds, and was still able to pair it again.
I’m currently running tasmota 9.1.0

Thanks for your response. Will try also and send the feedback soon

This is the outcome of zbstatus:

20:28:04 SRC: WebConsole from
20:28:04 CMD: Group 0, Index 1, Command “ZBSTATUS”, Data “”
20:28:04 MQT: tasmota/RESULT = {“ZbStatus1”:[{“Device”:“0x8A30”}]}

And this zbconfig:

20:30:32 SRC: WebConsole from
20:30:32 CMD: Group 0, Index 1, Command “ZBCONFIG”, Data “”
20:30:32 MQT: tasmota/RESULT = {“ZbConfig”:{“Channel”:11,“PanID”:“0x3498”,“ExtPanID”:“0xCCCCCCCCE3ABF498”,“KeyL”:“0xE3ABF49826BF40A1”,“KeyH”:“0xE3ABF49826BF40A1”,“TxRadio”:20}}

Only the Sonoff Button is connected. If I enable the paring mode the following lines appear. If I reset my aqara sensor in the meantime nothing happens in the log:

31:30 CMD: ZbPermitJoin 1
20:31:30 SRC: WebConsole from
20:31:30 CMD: Group 0, Index 1, Command “ZBPERMITJOIN”, Data “1”
20:31:30 ZIG: ZbEZSPSend 22003C
20:31:30 ZIG: ZbEZSPSend 3600FCFF00003600000000000000011E0103013C01
20:31:30 MQT: tasmota/RESULT = {“ZbState”:{“Status”:21,“Message”:“Pairing mode enabled”}}
20:31:30 zigbee.permit_end_time = 1868369
20:31:30 MQT: tasmota/RESULT = {“ZbPermitJoin”:“Done”}
20:31:30 ZIG: {“ZbEZSPReceived”:“220000”}
20:31:31 ZIG: NAK, resending packet 6
20:31:31 ZIG: {“ZbEZSPReceived”:“36000029”}
20:31:31 ZIG: {“ZbEZSPReceived”:“4500050000360000000000000029FF000000FFFF03013C01”}
20:31:31 ZIG: Internal ZDO message 0x0036 sent from 0x0000 (broadcast)
20:31:31 ZIG: {“ZbEZSPReceived”:“3F0006FCFF0000360000000000000029010000”}
20:31:40 MQT: tasmota/STATE = {“Time”:“2020-12-15T20:31:40”,“Uptime”:“0T00:30:19”,“UptimeSec”:1819,“Vcc”:3.532,“Heap”:28,“SleepMode”:“Dynamic”,“Sleep”:50,“LoadAvg”:21,“MqttCount”:1,“Wifi”:{“AP”:1,“SSId”:“Flitzpiepe”,“BSSId”:“98:9B:CB:50:1D:65”,“Channel”:11,“RSSI”:76,“Signal”:-62,“LinkCount”:1,“Downtime”:“0T00:00:13”}}
20:32:30 MQT: tasmota/RESULT = {“ZbState”:{“Status”:20,“Message”:“Pairing mode disabled”}}

Are there any special configurations I have to do? In the configurations section I choose the following:

  • zbbridge (75) at Configuration Module
  • everything is „0“ at Configure Domoticz
  • Emulation is disabled at section Other
  • at Configure template I am also using Sonoff zbbridge (75)

Any suggestions? Thanks for your help.

All this seems correct, as far as I can tell…

Did you try to remove your sensor battery and try to reset it (long press 5 seconds until it flashes 3 times) ?

Since you only have a single device already configured, I’d suggest you run a zbreset and, if not sufficient, to re-tastmotize your bridge with the Erase Flash option and zbreset again (and probably upload the zigbee stack).
Then start by pairing your sensor before tuning settings.

zbreset does not help. What do you mean with upload zigbee stack?
I will try to re-tastmotize later with the tastmotizer. Do you have a guide which I can follow?

For tasmotizer, you could follow the guide but this would require you open the box and connect Dupont wires again…
Instead, command Reset 1 should erase the all the configuration (not tested).

By “upload zigbee stack”, I mean flash again the zigbee firmware (ncp-uart-sw_6.7.6_115200.ota). It may be necessary after the factory reset.

Ok will do. With the wires this is no problem. I have already done during the first flash process. Keep you posted.

Today I re-flashed the Bridge with the Serial Adapter and Tasmotizer. If I flash tasmota.bin I am not able to upload firmware ncp-uart-sw_6.7.6_115200.ota within the webinterface. I’ll get the error message Magic byte is not 0xE9.

If I try to pair the Aqara sensor now it is still not possible. No entries in the console log. I changed the Configuration to Bridge (25) but still no change.

Just a question: I saw that there is a Sonoff zbbridge and a Sonoff rfbridge. I am using the zbbridge for Zigbee. Is this the bridge you are using with Aqara?

Did you flash with tasmota-zbbridge.bin (zbbridge specific build) ?

Yes, it’s a zbbridge.

BTW, tasmota v9.2.0 has been released.

Yes, used tasmota-zbbridge.bin, otherwise the npc-uart was not installable. I also noticed the new version because of some extra functions.
But my Aqara sensor still not appear in the console.

Sorry, I have no more ideas. Maybe is this related to your specific aqara sensor…

… and it brings integrated Zigbee map :

1 Like