Support for ZWave controller SD3503 (ZM5304)


I recently tried running the zwave binding on top of the aforementioned SoC but ran into the inability to add ZWave devices to the network due to a recurring error:

2016-08-24 17:50:15,586 | ERROR | ZWaveInputThread | ZWaveCommandProcessor            | 234 - org.openhab.binding.zwave - | Command processor error
2016-08-24 17:50:15,590 | WARN  | ZWaveInputThread | ZWaveController                  | 234 - org.openhab.binding.zwave - | TODO: Implement processing of Request M
essage = -- (0xA8)

A basic brochure of the controller can be found here.
I also tried adding devices using open-zwave but got an error with a strangely similar looking TODO message:

2016-08-24 17:57:46.923 Info, **TODO: handle request for 0xa8** Please report this message.
2016-08-24 17:57:56.887 Error, Node005, ERROR: Dropping command, expected response not received after 1 attempt(s)

Is it to be currently considered unsupported by both projects?

New devices may support new features, but that should not prevent support for standard functionality.

Please provide a logfile so I can see what is happening.

Here it is: pastebin.
I tried adding a Fibaro FGMS-001 device. The node is added to the network, but then identification fails.
I started from a clean condition (controller reset, all userdata/ wiped).

Thanks. I can probably decode this - it looks like an enhanced version of one of the other messages so I can likely do something to get past the initial error. The big question is if I do that, what happens next (ie if there are further changes required).

It’s probably something that would need a bit of effort to look at (unfortunately), but it is likely solvable with some time.

Thanks for your answer chris.
Meanwhile, someone from the openzwave team answered on the same issue here, basically saying that it is a message from the SerialAPI-level of the protocol, which is lower than Command Classes.
Hope we can get to something by joining efforts

I don’t agree with that statement. As I said earlier, I can decode this message.

I don’t have this device, so I can’t really do too much to help. It would take a little bit of time but from what I’ve seen, at least this message that you posted earlier could be decoded.