Suppress zwave stick event logging

My event log fills up rather quickly with the somewhat useless messages:

2016-09-09 14:27:49.128 [ItemStateChangedEvent     ] - zwave_serial_zstick_zstick_serial_sof changed from 915617 to 915618
2016-09-09 14:27:49.177 [ItemStateChangedEvent     ] - zwave_serial_zstick_zstick_serial_sof changed from 915618 to 915619

Is there a way to suppress the logging of these events? Besides the fact that it makes it difficult to find information that you actually need, I’m running on a SSD so I’d rather not be writing several megs worth of useless logs per day.

That looks like the events.log file. You can eliminate the events.log from being written to by changing the event logger to only log to the osgi:* appender.

In the file runtime/karaf/etc/org.ops4j.pax.logging.cfg change the following line:

log4j.logger.smarthome.event = INFO, event, osgi:*


log4j.logger.smarthome.event = INFO, osgi:*

NOTE: according to the docs there is a bug in the update of openHAB 2 through apt-get that will replace this file when you upgrade so you may have to do this after every update of OH2 until this bug gets fixed.

Correct, the events.log.

I was hoping there was a way to exclude just certain types of events. At this point I think I have most of my devices working correctly though so I guess turning it off completely and back on if needed will be ok.

The most efficient way would be to not even create the events in the first place.
Do you actually NEED the item zwave_serial_zstick_zstick_serial_sof? If not, remove it (resp. disable the channel of your ZWave controller Thing (disabling the channel means not link it to any item).

Thanks for the suggestion. That would be ideal, however when I click on the channels it does not do anything. I also tried deleting the respective items. From within Paper UI I get a 404 Error popup, and from Habmin it just doesn’t do anything.
I am running a somewhat old snapshot, but I’m hesitant to upgrade since I have everything else working pretty smoothly finally.