Switch component not working correctly when binded to KNX

I’m experienced with KNX, but new to openHab. OpenHab is and great project and I’m excited to get to know it better.

I was doing the first tests with it; firstly I tried out the Demo and everything was okay; afterwards I tried out to control one of my lamps over KNX.
The setup was simple:

  1. I added the KNX add-on to folder;

  2. Created new ‘openhab.cfg’ setting up the knx section with my KNX/IP router;

  3. Created items file ‘demo.items’ with contents:
    Group All
    Group Light (All)
    /* Lights */
    Switch Light_test "Light" (Light) {knx="0/0/1+<0/0/2"}

  4. Created the site map ‘demo.sitemap’ with:
    sitemap demo label="Demo House"
    Group item=Light icon="light"

Tried on the web interface, both locally and remotely, and both works well, but in the android app the switch of the light is unresponsive. The Feedback properly affects the light symbol, but the switch demonstrates some strange behavior: mostly doesn’t move

I didn’t have time yet do dig into the android app to find the reason. Does any one know the reason and/or solution?

Thank you so much!

I think first of all - you shlould use the correct syntax in the sitemap:

sitemap demo label="Demo House"
  Frame {
  Switch item=Light icon="light"

and try this way. As you want switch a single item and not a complete group.


I tried it, but problem persists… I got what you meant. I created a group consisting of just one item, bu it seems not to be the issue.

What is strange is that if I erase the binding {knx="0/0/1+<0/0/2"} the switch button works well (of course no message is sent to the KNX bus).

EDIT: It really feels like issue with the Android App. Anybody using android App with KNX binds? I’ve tried in my mobile phone and also in BlueStack “emulator”. In both I get same problem. BTW, I tried to import the Android Project but I got some errors at compiling; probably some configuration problems in my studio. I’ll try to get it working, then I’ll try to debug it.

Thanks for the tip though!

i have android with KNX - works smart with no issues.

which versions are you using?

mobile = 4.4.2, openHab
bluestacks = ?.?.?, openHab =
tablet = 4.4.4, openhab

could you pls check in debug modus if the KNX is connecting and what signals are been sent?

Is the item a pure light on-off switch? If so - what are the two addresses assgined to relavant for?

my swithches only have 1 sole KNX address.


KNX comm is okay. I can see the feedbacks and the web interface works well. I have one address to send and a feedback as you can see from my confs.

Yes, it is. One address is the control “0/0/1” and the other is the feedback “0/0/2”.

BTW, I’ve experienced same issues if I’m using TCP bind instead of KNX.

I’ve also noticed that the Application keeps the CPU busy. I turned on the openHab in the morning and noticed the phone was drawing battery fast, even heating. I checked the consumption of the battery and: