Switch not keeping ON state for dimmer/slider combo zwave light

When I press the switch it will turn on the light and the slider will move to 100%, but the switch itself shows the off state immediately in the basic UI sitemap. Same with the slider, when I move it to 100%, the switch stays in the off state, while the icon of the switch shows the correct state. Another (related?) issue: slider does not show the percentage. - edit % value seems to be showing in browser, not in iOS.

I have this issue with any of the 4 dimmers in my items below.


Switch Switch_A "Bamboo Deur" <light> [ "Lighting" ] { channel="rfxcom:lighting4:usb0:switch_17493:command" }
Switch Switch_B "Bamboo Hoek" <light> [ "Lighting" ] { channel="rfxcom:lighting4:usb0:switch_17685:command" }
Switch Switch_C "Staanlamp" <light> [ "Lighting" ] { channel="rfxcom:lighting4:usb0:switch_17733:command" }
Switch Switch_D "Luidspreker Bel" <soundvolume> [ "Switchable" ] { channel="rfxcom:lighting4:usb0:switch_17745:command" }
Dimmer DIMMER_TAFEL "Tafel [%d %%]" <slider> [ "Lighting" ] {  channel="zwave:device:52a72468:node2:switch_dimmer" }
Dimmer DIMMER_PLAFOND "Plafond [%d %%]" <slider> [ "Lighting" ] {  channel="zwave:device:52a72468:node3:switch_dimmer" }
Dimmer DIMMER_PLAFOND_MIDDEN "Plafond Midden [%d %%]" <slider> [ "Lighting" ] { channel="zwave:device:52a72468:node6:switch_dimmer" }
Dimmer DIMMER_PLAFOND_ZITHOEK "Plafond Zithoek [%d %%]" <slider> [ "Lighting" ] { channel="zwave:device:52a72468:node5:switch_dimmer" }
String HUB_ACTIVITY "[%s]" <video> { channel="harmonyhub:hub:HarmonyHubFonteinstraat:currentActivity" }
String SceneSwitch "Scènes" <colorlight>
Rollershutter SHUTTERS "Rolluiken" [ "Switchable" ] { channel="rfxcom:rfy:2e084c4c:shutter" }


sitemap home label="Home"{
	Frame label="Actviteiten"{
		Switch item=HUB_ACTIVITY mappings=["TV Kijken"="TV Kijken", Kodi="Kodi", Radio="Radio", PowerOff="Uit"]
	Frame label="Licht Scènes" {
		Switch item=SceneSwitch mappings=[MOVIE="Movie", COZY="Cozy", DINNER="Diner",ALL_ON="Alles Aan",ALL_OFF="Alles Uit"]
	Frame label="Lichten" {
		Switch item=Switch_A
		Switch item=Switch_B
		Switch item=Switch_C
		Switch item=DIMMER_TAFEL 
		Switch item=DIMMER_PLAFOND 
		Slider item=DIMMER_TAFEL
		Slider item=DIMMER_PLAFOND		
	Frame label="Overige" {
		Switch item=SHUTTERS
		Switch item=Switch_D

Did you get this issue solved? I have a similar issue with the ios app.

No, I never got this solved unfortunately. On the upside, I don’t need a solution anymore: I now use OpenHAB + NodeRed + contrib-node-red-homekit = full HomeKit compatibility and no more need for an additional iOS app apart from the built in Home app from Apple.

Okay, too bad that it isn’t fixed, but nice to hear you have found a work around - does that also provide remote access or is it wifi only?