Switch sends on ON command (MQTT)

having trouble with single switch over MQTT (to sonoff-tasmota), while having another one, that works fine, i had only to change the mqtt topic.
however it doesnt send OFF command.

the switch updates fine in Habpanel…

a working switch:

//Boiler Outdoor - tasmota
Switch BoilerOutdoor {mqtt=">[mosquitto:BoilerOutdoor/cmnd/power:command:ON:ON],>[mosquitto:BoilerOutdoor/cmnd/power:command:OFF:OFF],<[mosquitto:BoilerOutdoor/RESULT:state:JSONPATH($.POWER)]", autoupdate="false"}

this one, doesnt…
sending the command using mqttfx - everything is fine… cant figure out why it behahes differently.

//Light - tasmota
Switch NoamLight2 {mqtt=">[mosquitto:NOAMLIGHT/cmnd/power:command:ON:on],>[mosquitto:NOAMLIGHT/cmnd/power:command:OFF:off],<[mosquitto:NOAMLIGHT/RESULT:state:JSONPATH($.POWER)]", autoupdate="false"}

UPDATE: apprently, tasmota changed the hardcoded topics in the last build… after setting the correct values… everything is fine.