Switch state doesnt turn on for a ZWave Dimmer when the Dimmer is turned on

Hi All,

In the past this is due to associatons, but the lifeline is correct. Its a Aeotec Nano Dimmer. Latest 2.5 ZWave binding.

Items as below:

/*ZWave Switch Top Floor Stair Lights*/
Switch TopFloorStairs_Sw1       "Stairs"                                    (gAllLights,gInsideLights,gTopFloorStairLights,gAllTopFloorLights)  { channel="zwave:device:4711b0e7:node26:switch_dimmer" }
Dimmer TopFloorStairs_Dimmer    "Stairs"                                    (gAllLights,gInsideLights,gAllTopFloorLights)                       { channel="zwave:device:4711b0e7:node26:switch_dimmer" }

In the past it’s worked OK for me BUT, I had a switch_binary and a switch_dimmer. This device in the binding only has a dimmer channel, which should be OK as ON/OFF but I cant get the Dimmer to display as ON using a switch channel ?

Openhab 2.4 Stable is my version


The first suggestion would be to upgrade to a 2.5 version. Chris says it is difficult to debug the old 11 month old version of the zwave binding.
It is possible to just upgrade the binding manually but 2.5 stable is scheduled to be released this month.

Hi Bruce, it works on 2.4 though on another system. I absolutely dont want to upgrade to OH2.5.0. I’ll let the dust settle on that first.

@chris it seems the switch_ binary channel has been removed from the ZW111 device type in the 2.5 snapshot recently. Which is odd as binding from, also 2.5.0 Development has it for this device.

is this intentional? How do we get the switch_binary channel back.

For instance, if the Dimmer type has a number for its state, how do we tell if a Dimmer item is actually on? Previously, it was just checking the Switch type.

There should be no need for both a dimmer and a switch in openHAB. There are some exceptions, but for most devices you can use a dimmer or a switch item for a dimmer channel (this is standard openHAB stuff, right?).

I thought it was standard stuff to, but it appears to not work using the new binding as there is no switch_binary channel any more. If you’re saying I can use the switch item type on the dimmer channel, sure, but that failed to work for me.

Yes - that will work fine. If it doesn’t, which would be a surprise as this is standard in the binding for a really long time, then please provide a log.

1 Like

Shall do Chris

Hi Chris

Creating a Switch item on the same channel as the Dimmer item doesnt work. Previously, if you set the dimmer to anything more than 0, it would turn on the Switch item.

This does not seem to function now


/*ZWave Dimmer MasterBedroom Downlights*/
Switch MasterBed_Sw      "Downlights"                                         (gAllLights,gInsideLights,gMasterBedroomLights,gAllTopFloorLights)    { channel="zwave:device:4711b0e7:node25:switch_dimmer" }
Dimmer MasterBed_Dimmer1 "Downlight Dimmer"                                   (gAllLights,gInsideLights,gMasterBedroomLights,gAllTopFloorLights)    { channel="zwave:device:4711b0e7:node25:switch_dimmer" }
Number MasterBed_Num1    "Downlights - Consumption [%.1f W]"                  (gAllLightsUsage,gEnergyRealTime)                                     { channel="zwave:device:4711b0e7:node25:meter_watts" }
Number MasterBed_Num2    "Downlights - Usage [%.1f kW]"                       (gPowerUsage)                                                         { channel="zwave:device:4711b0e7:node25:meter_kwh" }


08:49:40.761 [INFO ] [smarthome.event.ItemCommandEvent     ] - Item 'MasterBed_Dimmer1' received command 70
08:49:40.769 [INFO ] [arthome.event.ItemStatePredictedEvent] - MasterBed_Dimmer1 predicted to become 70
08:49:40.782 [INFO ] [smarthome.event.ItemStateChangedEvent] - MasterBed_Dimmer1 changed from 0 to 70

Zwave Log:

The item is Node 25, Aeotec Nano Dimmer ZW111/ At 08:49 you see I send 70% to the dimmer item. The switch channel remains in NULL despite the dimmer item being 70%

Node25.txt (202.3 KB)

I don’t see any commands being sent as a SWITCH. They are all dimmer commands. Maybe I’ve missed this though?

Hi Chris, either do I. I guess thats the issue? Why would that suddenly disappear?

Sorry, I don’t understand. What has disappeared?

As I said, previously when you turn the dimmer item to more than 0, it turns on the switch item bound to the same channel. This no longer works.

Why are you using the dimmer item?

I use the switch item to show the dimmer is on in the UI, I use the dimmer item to dim the lights.

If you want to turn the lights off, then you should use a switch - this is the same as it always was isn’t it? You used to use the switch channel - now you are still using the switch, except you’re not - for some reason you’re now using the dimmer?

I’m a bit confused - sorry.

Its very very simple.

The switch item is bound to a group, type switch. It is grouped with many other Zwave items which are Switches, not Dimmers. I use the group to display the number of Switches that are ON. This allows me to monitor how many lights are on, be them being a switch or a dimmer. It doesnt matter.

The dimmer item is used as a slider to drag the value from 0 to 100, to dim the lights. You cannot send a dim value to the Switch item.

Therefore, I need BOTH Item Types for the device.

Ive setup another system for parents, using the latest Zwave binding (#846 from 2 days ago) using OH 2.4.0. It does not work.

It worked perfectly on a Zwave 2.5.0 dev binding from October 2019. Also on 2.4.0

So something has changed in the Zwave binding for this to now not function given the OH2 version is identical.

Sure - and you HAVE both item types. There’s no difference as far as I can see with what you used to have.

You say you used to send a swtich command, and you’re annoyed that the switch channel is no longer there as you used to use that, but you are not now using a switch command - you’re using the dimmer.

No - nothing changed. Nothing at all. What has changed is that you are sending a dimmer command, and expecting a switch command - just send a switch command and it should work.

That’s not right Chris.

How can I send a command of ‘70’ to a Switch item? It won’t work.

When I drag a slider for a Dimmer item to anything more than 0, ie 50, it should and used to, change the corresponding Switch item to ON.

What isn’t?

No - of course not!!! You have a DIMMER - send a SWITCH command to it - the same as you used to send to the SWITCH channel.

You told me tha you used to use the switch channel - correct? And you therefore used to send a switch command - correct? Why are you now sending dimmer commands?

cough I don’t want to get in the way … but isn’t the idea that setting a dimmer to 70% (by any means) should result in a linked Switch type status being updated to ON? Whether that is by a switch type channel or by a dimmer type channel

1 Like