Switch state doesnt turn on for a ZWave Dimmer when the Dimmer is turned on

@chris , that’s fine with me.

restoring the switch_binary channel I dont think will make a difference as in my working example, there are no items bound to it.

Maybe it will, I don’t know. But visually, it’s the only difference I can see between binding versions, despite Chris saying the binding has not changed.

If there is a bug, then shouldn’t we try and fix it? What the binding is doing is (as far as I understand) the correct implementation. A device should not provide both a switch channel and a dimmer channel - only a dimmer is required.

Sorry - it seems I now need to prove that I’m telling the truth?

So this is as I said earlier -:

This is clearly well before October when you said it was working.

Chris, if you have the means with a Aeotec Nano dimmer, test it using the binding I provided and 2.4.0.

That’s the only way I suspect, unless someone else can support my claims/issue

From the documentation -:

This states that the update of the channel information from the binding is delegated to the FRAMEWORK. ie what this means is that the binding updates channels, and the link from channels to items is handled by the openhab core. Not the binding.

Please see -:

Fair enough - your earlier version of the same advice for reference (and the warning that switch_binary may be removed :wink:

Yes, and isn’t that saying the same thing as I’ve been saying here?

2 Likes

I should also add that I don’t know what version of the device we are talking about here. I don’t know therefore if the device definition in the database has changed. Maybe a new version has been added with a different definition (there are 3 versions of this device in the database I think). Or maybe a channel was removed - I’m just not sure at the moment, so I can’t say that it can be “added back” - it may not have been there and it may just be new definitions for an updated version of the device.

Working version ZW111 Aeotec Nano Dimmer (this version has worked since binding back in October 2019)

Not working version ZW111 Aeotec Nano Dimmer (this device was not known to ZWave prior to the update done in build #846)

I just checked github, and the only change that has been made to this device in the past couple of months was 5 days ago when an additional type/ID was added.

Prior to that, a change was made in early October to change one of the labels -:

Even the original version of this device from September doesn’t have the switch channel included -:

I don’t know what else I can do here - I’ve spent a lot of time trying to help, and I’m sorry that you don’t accept my answers. I’ve tried to present the documentation and history that shows where the various features you claim the binding should implement are really meant to be implemented, and I appreciate that this is not accepted by you, but I’m now at a bit of a loss as to what else to do. Maybe there was a new version added to the database that your system has swapped to using, but unfortunately I don’t have the time to continue to chase this one at the moment.

Fair enough, well I can’t explain how this is all working just fine then on my system with the Switch item bound to the Dimmer channel.

@Kai Are you able to comment on why a Switch item doesnt work in 2.4.0 Core for a ZWave device? It has a switch_dimmer channel, of which a dimmer itemtype and a switch itemtype is bound too. When the dimmer receives a command, such as 50, the switch item does NOT change to ON.

This is occuring on a 2.4.0 Stable system. It does not occur on another 2.4.0 Stable system I have with the identical Zwave device.

The only difference between the two is the physical hardware and the Zwave binding

Thanks!

I wonder if this may have to with your “working” Things being created under a different/older binding version.

Then we cannot help you.
In my animated gif you can see how it works on a snapshot zwave binding with a Fibaro dimmer, my switch and dimmer items are bound to a switch_dimmer channel:

Switch FibFGD212_1_Sw (gRestore) { channel="zwave:device:uzb:node37:switch_dimmer1", autoupdate="false" }

Dimmer FibFGD212_1_Dim (gRestore) { channel="zwave:device:uzb:node37:switch_dimmer1", autoupdate="false" }

The switch turns on immediately after the dimmer percentage is set greater than zero.

That makes no sense. why should I have to upgrade to a non stable platform(2.5.0) to get a feature that works on 2.4.0?

Not following rossko57. What do you mean mate?

If it works on different platforms with both the stable 2.4 we cannot help you either because you are the only one who is able to find the differences between them.
Check your config, check your parameters (especially parameter 80)

understood Sihui! Thanks

Based on this, I presumed you had another system with ZW111 already configured and working as you expected. Those devices would necessarily have had their Things created under an older binding version.

It’s not really clear if you actually do have other, older ZW111 or if they are different versions from your new one, or if you have tried the “failing” new one on your older “working” system.

No mate, all ZW111s are the same.

I havent tried the new binding on the working system. I will do though!