Switching to Wifi help

  • Platform information:
    • Hardware: pi4 2gb
    • openHAB version: OH3

Hi all. Rather new to OH here but am having some issues getting it up and running as I’d like. I used the Openhabian SD card to install, gets up and running and am able to start configuring, but i can only access it via a wired connection (laptop/iPad do not see it) which I think is due to it not being setup for wifi? I have gone through the config 3 times now, sshing in, going to the openhab conf and pointing it to my wifi but each time after i restart the pi, it never seems to come back online. I cant hit it via a wired or wifi connection. I’ve waited hours and tried again, nope its gone. I have to wipe the pi and start it back over and re-setup from scratch each time. Am I missing something?

Can’t tell unless you provide a log of what’s going on. See debug guide. What do you mean by “going to the openhab conf and pointing it” ?

‘sudo openhabian-conf’ and using the menu option within for setting up wifi. The last step then prompts me to restart the pi, which i did, and then its unreachable. It does not appear anymore in my network, and I cant SSH to it.

  • did you connect a monitor to your Pi to see if it is booting ?
  • your PI may get a different IP address via Wifi in case naming resolution does not work did you try all the IPs resp. did you check the entries in your router’s overview ?
  • you may use nmap to find devices in your network

If your server is accessible on its wired IP you should not switch to WiFi.
Fix your local routing instead, Wi-Fi devices will then be able to access your RPi if you do that right.
How to correctly set up your network (W)LAN is out of scope for this forum, sorry. G**gle is your friend there.

Hi - i have a half setup RPI4 with Openhabian. I didnt setup the system to have wifi in the initial step.

Given i am a windows user (limited linux experience etc)
How would I set it up at this point? is there a post specificially to set this up in Openhab 3 (havent found something obivous yet)

If you are in a position where you have no LAN or WIFI access, you can configure the WIFI by placing a config file in the root directory of the SD card. Shut down the RPI, and remove the SD card. Put the card into your PC/Laptop, and create a file called ‘wpa_supplicant.conf’ in the ‘BOOT’ directory. Put the following in the file:


 ssid="<Your SSID>"
 psk="<Your Password>"

Put the card back into the Pi, and boot; you should then find your device on your network (Check by looking at the DHCP allocation page of your router).

openhabian-config option 36

hi Markus, thanks- to put it in terms i undertand - you mean to access via SSH and set it there correct?
For future me people, what I did was:

read from here openHABian | openHAB to gain access to the config tool

Cant be done from within the web interface of Open hab.