Synology and server started but no open port

Hi all. I am new here so apologies up front.
Previous version worked fine. 1.8

My problem I have server started and running but the port it states it is running on in the URL http://:8082/ is closed.
Ran a network connection test and no response to 8080 to 8089.

The mobile app set to http://:8082 just trying to sync continuous.

If there is a way to get a report or find out what port its running on.
Log file is empty.

Other threads to get it to this point… created user name first before install.
System is a DS214 DSM 6.0.2-8451 update 7.

Thanks in advance. Oh Happy new year.

  1. Why not beta 5? At this point beta 2 is really old and a lot has changed.

  2. By default it runs on ports 8080 and 8443. You have to go out of your way to make it use a different port. Did you assign it to a different port?

  3. If they is no openhab.log then openHAB isn’t running. Something went wrong. Have you tried to run it from the start script or looked at systemctl status?

Thanks rlkoshak

I know the server did not start as i test the ports.
But due to all the possible answers to resolve it are related to win or Linux or pi.
But you mentioned beta 5 for Synology, I can not find it on the net, can you provide a point for downloading it, it would be appreciated.

I have it working on win 10 but its a laptop I move around with, need it to be on my NAS.

Thanks to you next response.

I don’t know synology so am not sure. I assume those packages are kept up to date but I don’t know where.

Here is link

Thanks rlkoshak

Hi martinman
This is the same place I got my release with being the latest.
This is the one I am trying but having the problem with.

Has anybody got a step for step solution to Synology port problem. "why wast time if someone has done it"
As i don’t know Snology requirements as to java.spk format.

Looked at script and see port 8080 and 8443 used with and exit 1 if pre-used…
My error states port already used or reserved.
But if I test port 8080 there is nothing running on it , so it must be reserved some how by the system. "don’t know how"
So my solution is to move the port on to 8081 ect but ?

Has someone made the amendments or have a new.spk with the changers already,
“Am I the first to ask or try to resolve the problem on Synology, surely not”.

Any help would be greatly appreciated and once again thanks for the replies.

Look here, may be it helps:

Thanks martiniman

The problems I am encountering seem to go back to previous issues and no one has a clear way to resolve.
My script knowledge of Synology is null. Java ok, but can one install to a folder manually and run with out going through the package installing or are there other setting required on the Synology scripts.

Someone must know, someone created the scripts .spk…

Why is it still a problem.
Install files , provide a where one can change “edit” the port or
provide a better report system to explain what has gone wrong.

Because it not port related. see previous conversation
lost for words.

OpenHAB-2.0.0-beta2-DSM6-RC-syno-noarch-0.001 installed files but NOT running, attempts starting then stop
OpenHAB-2.0.0-beta3-syno-noarch-0.001 installed files but NOT running, attempts starting then stop
OpenHAB-2.0.0-beta3-DSM6-syno-noarch-0.001 fail port and no files installed.
OpenHAB- fail port and no files installed.

I would like to be able to use the version 8. on DSM6… and I am sure so will many other people as IOT is a up and coming topic.

My objective is to be internet free for the operations on the IOT products, but use what is available out there.
A stand alone voice system but don’t want to reinvent the wheel.Don’t have a problem with a bit of an education required and wiling to share my findings to the community. All for open source.

So any person you has a solution to version 8 on DSM 6… for Synology only to get it up and running as a starting point would be greatly appreciated.

Thanks to the reply’s in advance

I have the same problem with OpenHAB2- on DS214.

WhenI go to SSH in /var/packages/openHAB2/scripts I get the following result:

./start-stop-status start

Usage: grep [OPTION]… PATTERN [FILE]…
Try ‘grep --help’ for more information.
-sh: ./ No such file or directory
# ./

I find in /volume1/@appstore/openHAB2. When trying to run -/ from here, I get the following reulst

^C# ./
Launching the openHAB runtime…

But never gets acces to the server using

Any help i sppereciated


Hi there
After a lot of hunting around I managed to get it to work on DS214 DSM 6.1-15047 Update 1

  1. load java (latest)
  2. use PUTTY to find installed files ???.sh of other application that might hold port 8080 in the script.
  3. Delete the ???.sh if not in use. (see other question for help on how to find and delete.)
  4. Install normal manner OpenHAB- (if installation fails look for more ???.sh with port 8080
  5. Should be up and running in the package center.
  6. use browser to open UI from "synologyIP:8080"
    If no access to synology port look at firewalls on local PC being used.

This worked for me … Hope it will help you in the steps to follow.“Many hours to resolve” so enjoy

Hi David - thanks for reply.
I did all that but with
as this is the only available download now.
No other programs use port 8080.
I checked with
netstat -lptn
I use the same DSM update

You can have a port in a .sh file set to be used. But the port itself is
not active so Netstat command will return a unused result. install process
look at the .sh files even if they are not currently used. See hardware
synology forum look for script topic

Thanks again David.

I reinstalled my DS214 completely via synosly assistant.
Installed mc (midnight commander)
Installed Java8 (the doc. says cryptographic extension required - is this the correct version??)

I checked all .sh files for 8080 and found one (for mc). Changed it to 9090
Installed openhab2.

In package center, openhab2 is running, but no reaction from port 8080

Now something happens.

After a very long time (45min++) the webserver on 8080 is reacting.
Now I am waiting for UIs to load - this has being going on for 15min++

I have been running openhab2 on raspberry pi and ar used to a small time for things to load, but this is verrrrry slow!

Well - trees does not grow into heaven!.
After 2 days, I am still waiting for UIs to load!!!
(Well - I did try to reinstall Synology and openhab2 a few times in between but with the same result.)
Wonder if anyone ever have been able to make it run?

By the way. I examined some of the .sh files in the openhab package. A couple of them seems to use HTTP=8081 and HTTPS=8443 but it has no influence. It is still port 8080 starting and HTTPS never starts.

Hi there
Sometimes port 8080 and 8081 are used in conjunction with each other. Try
and free up both 8080 and 8081. Netstat them to make sure they closed . No
.sh carrying the port number. Reboot after all installed. And use the
version I have state before. Other versions are not working for me. The .sh
was preventing the installation. The script for installation was using port
8080 and possibly 8081.
Mine is working with no problems. Response time is 0.0023s latency from a 1g

Link to file. Synology DiskStation
Please down load remove the .pdf extension and install.

MAR 10 by levers jan topic 188/213
OpenHAB- (65.5 KB)

Enjoy and thanks to all who worked on this.

Wow thanksyou all to make me already join here but this really nice and good