Synology DiskStation

managed to install the package on my dsm by editing the install spk to my version of dsm so the check goes trough.
it installed fine exept i had to download the zipfile manually and place it in the public folder.
New problem , package is not starting as seen in many threads, can’t find the karaf folder

Regarding the not discovered public folder:
If you know how to SSH into the NAS, best is to set the link by yourself:

  • stop the service in the Syno UI
  • safety first: save the contents of /volume1/@appstore/openHAB2/conf:
    cp /volume1/@appstore/openHAB2/conf /volume1/@appstore/openHAB2/conf_orig
  • or alternatively copy the content to your public folder:
    cp /volume1/@appstore/openHAB2/conf /volume1/public/openHAB2/conf
    (this is most likely the safest to get it running)
  • then set a symbolic link from public to the openHAB2 folder:
    ln -s /volume1/public/openHAB2/conf /volume1/@appstore/openHAB2/conf
  • What I did is also to relocate the logs folder to the public dir, so you can easily from anywhere see what goes wrong:
    ls -s /volume1/public/openHAB2/logs /volume1/@appstore/openHAB2/userdata/logs
  • restart the server.
    Then you can for example use the Eclipse Smart Home Designer for editing by simply letting it point in windows or osX to your public folder.


Would you mind running through how you modified the spk for xpenology dsm5.2?

I am running the same here and have yet to try and upgrade to dsm6, waiting for quicknick to release his installer…

You can open the spk with notepad++ in the first lines you will see a check for dsm 6 , just change to your version.

Kindest regards

Ps: let me know after the install if it works for you cause here i can’t get it started

looks like the most convenient way to overcome this issue, but mount bind needs root access. How did you login with or su to root? Does not work on my 216+II

when i try to start the openhab via i get ./runtime/bin/karaf: not found

good i found a solution.

i downloaded the beta 3 spk and copied that to my pyblic folder:
then i downloaded the release zip from the openhab website so not the cloudbees.
i renamed the file to what beta 3 is looking for and placed it in the public.
now it runs.

this does mean that the package they now have is bogus and not working !

Has anyone experience with DS114? Installation is fine, but I can not access the webservice. Log has an error:

Caused by: java.lang.IllegalStateException: Could not load implementation object class

First post.

Hi, I’m moving to OpenHAB2 from Vera and am having some issues installing the Synology package (openHAB- on my Synology DS214play.

I followed the installation instructions, installed Java SE 8, then installed OH2 (see The installation seemed to go ok and I can access OH2 via the Paper UI from my PC’s browser. However, there doesn’t seem to be any configuration files on my Synology!

The installation instructions state that “The configuration files are located at: /volume1/@appstore/openHAB2/userdata/config”. And the OH2 app itself - when viewed from within the Synology Package Centre - states that: “If the directory /volume1/public/openHAB2/conf exists, the directory will be used for OH2 configuration files”.

However, when I check the NAS directory structure I only see a directory called /homes/openhab2. And there are only two items in the directory - a 1kb file called .profile. and a sub-directory called .karaf, which contains a 0kb file called karaf.history.

I tried uninstalling the OH2 package, creating a shared directory call /volume1/public/openHAB2/conf, giving the openHAB deamon read/write access and re-installed the OH2 package but there are still no configuration files.

Is this normal? Have i done something wrong?

I had the same issue, :karaf not found.

Pulled the pin and upgraded to dsm6 patched up to 8, with the jun loader.

Installed easy.

I found the following, which explains why there is no config file:

One thing to be aware of is any configuration done in PaperUI or Habmin gets saved to a non-human readable database. See

But surely i should see more files than the couple of empty files referred to above?

I might have to retreat back to my Vera unless i can start making sense of this!

@jamac Is OH working? If yes, then you haven’t done anything wrong.

My openhab files are in the @appstore location. Did you check there?

OH2 is working - at least for OH2 bindings. The problem is that i’m trying to get a legacy 1.x binding to work but it requires access to the config files, which are nowhere to be found! I don’t have a @appstore folder on my NAS - just /homes/openhab2, which only contains a couple of empty files.

Hi Jamac

In your web view the @appstore folder does not show up, but you will find the folder when you make a ssh connection to your Synology in a terminal. If you have not done that before, you need to change your configuration in synology control panel to allow ssh connections. Root password is the same as your admin password.

1 Like

Thanks! I think this is the missing information I was after. I’ve used Putty to make SSH connections to other devices so should be able to work it out for my Synology.

That’s great. I use WinSCP from my Windows 10 device to transfer files to the right folders etc.
Hope this means you’re sorted! :slight_smile:

OpenHAB2 version: “openHAB-”
Synology DS216+II (Intel processor) - DSM 6.0.2-8451 Update 9

All working fine with the exception of rrd4j graphs under the normal Synology account (if I start the service from “Package Center”) I get the valuates but the graph is showing a missing graphic icon. This happens on the demo install to.

But if I start the OpenHAB2 service from SSH with root access there is no issue and graph will be ok.
command is: “sudo ./” in the openhab directory (/volume1/@appstore/openHAB2)
I suspect a permission issue but I can’t figure it out.

Hi, i try to update my Synology OH2 #723 using this tutorial.
But no luck, package center shows it running, but it not.
Is there another way to update Synology OH2?

Hi, t try to upgrade my Diskstation using

The package center shows it running, but i can’t acces the webpage. The openhab2 folder only contain three *.sh files.

So i use the release and everything works out of the box.

Btw. I mount the openhab2 folder to /public/openhab2 on startup

Hi @derandi I try it already - not works at all, and i create issue.