Synology DiskStation

I success in installing the SPK to my SYNOLOGY 1515+. I just repack the spk file to a TAR file that I renamed SPK.

But it seems that the script in not run… The setup didn’t use time to download the openhab distribution files…


OK, i fix my packages, you can now download it:


It works with the last package. Thanks

1 Like

I have a trouble with the Synology Package 1.7.1 (and probably the older).
The date time displayed by openHAB are not the good one. They are UTC time,
I’m in France. Timezone is Europe\Amsterdam.
Then the date time must be UTC +2

I saw that the /var/packages/OpenHAB/scripts/ script try to set the TZ in the file /var/services/homes/openhab/.profile

But the generated result line is :
export TZ=’’
=>There is no timezone.

The update of the .profile TZ is done by these commands :

SYNO_TZ=cat /etc/synoinfo.conf | grep timezone | cut -f2 -d'"'
SYNO_TZ=grep "^${SYNO_TZ}" /usr/share/zoneinfo/Timezone/tzname | sed -e "s/^.*= //"
grep “^export TZ” ${DAEMON_HOME}/.profile > /dev/null
&& sed -i “s%^export TZ=.*$%export TZ=’${SYNO_TZ}’%” ${DAEMON_HOME}/.profile
|| echo export TZ=’${SYNO_TZ}’ >> ${DAEMON_HOME}/.profile

I’m not a linux expert to undestand but it seems that something do not the job.

As a workaround, I commented the both line and I set
export TZ=‘Europe\Amsterdam’
in the .profile file and I get the good date/time.

Can an expert check the command line to update the .profile ?

1 Like

Thanks, this worked for me, except I had to use:




Synology 214play, ohab 1.8.
I have this error on startup, but all settings from cfg file is applied:

2015-10-15 20:43:16.895 [ERROR] [o.config.core.ConfigDispatcher] - Main openHAB configuration file 'configurations/openhab.cfg' cannot be read. No such file or directory
       at Method) ~[na:1.7.0_79]
       at ~[na:1.7.0_79]
       at ~[na:na]
       at$ ~[na:na]
       at Method) [na:1.7.0_79]
       at ~[na:na]
       at ~[na:na]
       at org.openhab.config.core.ConfigDispatcher.processConfigFile( [org.openhab.config.core_1.8.0.201510100138.jar:n
       at org.openhab.config.core.ConfigDispatcher.initializeMainConfiguration( [org.openhab.config.core_1.8.0.20151010
       at org.openhab.config.core.ConfigDispatcher.initializeBundleConfigurations( [org.openhab.config.core_1.8.0.20151
       at org.openhab.config.core.ConfigDispatcher.activate( [org.openhab.config.core_1.8.0.201510100138.jar:na]
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.7.0_79]
       at sun.reflect.NativeMethodAccessorImpl.invoke( ~[na:1.7.0_79]
       at sun.reflect.DelegatingMethodAccessorImpl.invoke( ~[na:1.7.0_79]
       at java.lang.reflect.Method.invoke( ~[na:1.7.0_79]
       at org.eclipse.equinox.internal.ds.model.ServiceComponent.activate( [org.eclipse.equinox.ds_1.4.1.v20120926-2013
       at org.eclipse.equinox.internal.ds.model.ServiceComponentProp.activate( [org.eclipse.equinox.ds_1.4.1.v20120
       at [org.eclipse.equinox.ds_1.4.1.v20120926

I try to chown but this doesnt help:

chown -R openhab:users /volume1/@appstore/OpenHAB/

Do anybody have this error?

Your configuration file should be at /volume1/public/OpenHAB/configurations. Did you install the openhab demo package for synology?

Yes, OH at this path.
I use OH since v1.5 on Synology, and that error appear from v1.7.

Did you try:

chown -R openhab.users /volume1/public/OpenHAB/configurations


Just now tried that - doesn’t help.

I had a similar problem until I installed the demo package.

Installing demo - Doesn’t help.

Im a bloody newbie to this hole stuff. So please be patient if i don’t declare my problems quite as you wold suspect.
I Installed 1.5 as it was the only .spk file i found. (still currious how some people installed the 1.7.1**.zip **version)
The Installation worked, and i then installed also the demo on the syno and the App for OSX.
I then pasted the url i found in the installation, to the app internal browser and tata! there it is.
But now i tryed hard to find a way to access the config path. Over several ways, and nothing helps to find the config files…
I tryed FTP with root but that doesn’t let me connect.
So i tryed admin and there i can see the homes/openhab/.profiles but no config.
So i searched for solutions over the net and found OSXfuse, Installed it and used Macfusion to connect over sshfs. -What never worked, nether with admin or root or other users.
So i tryed to go in with terminal and there with ssh, i can reach the syno even with root, admin and a user without problem. But i have no idea how to use that terminal stuff…
So i tryed again with Fillezilla (as i did for FTP) with SFTP and that works again only with the admin not the root.

so im compleetly stucked and can’t access the Config files to get my openhab set up.
Can somebody help?

Regards, Novski

I use winscp for windows, there might be something similar for Mac.

The config files are in volume1/@appstore/OpenHAB/ on my synology. Have a look in the volume and find the @appstore.

ok. i used a windows and i can access it with root there. i now know where the config is stored.
I have to search for a solution that lets me use the on osx. i can’t configure my openhab config on on the windows i used now to test…
Or can i make openhab grab the config in a different folder on the syno?

And another question:
What is the password of the automaticaly generated openhab user?
Regards, Novski

@Nicola_Reina, I don’t understand. Whats about a Flag?

does not matter… I deleted the post and cannot access it anymore.
The problem was solved and… cannot even remember … :smile:

I managed to install openhab on the synology but after a while I have the nas really going slow in terms of reactivitry
I have a 212 . too small?

Since the recent updates of DSM, Synology allows running docker containers.
This is very sweet! You can take a good image or make your own, inject your config file and you are up and running.

I did not test yet with OpenHab but that should be trivial to get it to run. Docker is not available on all the Synology NAS though. I guess it is limited on the very small version as it would run too slow.

So far, the only issue I got with that is that you need to expose a device to the container is you want to use a USB device. That is unfortunately not supported by the DSM GUI so far and I did not find an alternate option yet.

Hi! Please help with creation of bash script for Synology OH start-stop-restart.
Maybe anyone have this one?