Synology DiskStation

After some more investigations, I am now pretty sure that your issue is related to running out of threads for your rules under several circumstances. It is reported to better merge rules, which are croned at the same time to lower the amount of threads. You may google for “openhab rules cron threads” and you’ll find the relevant hits.

This also means, that the rules in your “native” syno install may work only by chance. There is a possibility to increase the threads. Please look for that at the following link:

I guess if you increase the thread pool for the Rules, your docker setup should work fine like mine. In order to optimise your openhab in general - as I said - it is recommended to reduce the amount of cron rules(merge whatever is possible in the same rule).

Hope that helps.

additional info: you need to change all links in your userdata directory from “/volume1/…userdata/…” to “/openhab/userdata/…”

I appreciate the help but these are things long since worked through for me. I have many more threads running and have reduced Thread::sleep(s) to a minimum (maybe 3-4? not many). All links/folders are fixed when moving between installation types.
I’ve worked myself up a script recently to handle the syno-based version upgrade so I’m not too worried about it.

The only other possibility is I make my own docker image by adding nano and a couple other packages (like ssh) so that openhab can do a few execs via ssh. Perhaps that is influencing the crashes - i don’t know. not too worried about it.

While I would love to solve it, it doesn’t happen with any particular regularity and I really need it not to be happening (SWMBO) so I’m sticking with what works.

Thanks for these instructions.
My container crashes if I try to use the same network as Docker host. Is that likely to be a port conflict with another installation?

I have made a simple video guide how to upgrade and always have the latest OpenHAB version on your Synology NAS:

BTW, inbetween the versions have advanced, but the guide is very simple. All you have to do is to find the latest link and ZIP file for the OpenHAB.

Rok Rodic


Thank you so much! I know a lot of people will use this video. Great job!

Best, Jay

You are welcome. I am very happy to receive encouragement. Thank you. I hope it will help all of us (even me, when I forget how I did it) :slight_smile: .

Does anybody know if there will be a 2.5.1 syno package release?

hi everyone,

i’d like to install the OH v3 to my syno (214play no docker), if i know well it need Java 11, how can i install it?

thanks for the advices


probably everyone (including myself) moved on to docker. I doubt anyone will go through the trouble to get OH3 running natively on syno, sorry.

1 Like

I @TomiGonzo, I know that there’s no Docker for 214play. I ran OH2 nativley on my DS918+ but with OH3 I also switched to Docker because of the Java 11 issue and the delays of releases.
And I can tell you it’s a dream with Docker!
I can highly recommend you to buy a newer/higher Synology model with Docker support!

And also GreenEyedExplorer didn’t update his YouTube Video here for OH3.

In a nutshell: the update to OH3 without Docker is a pain! :unamused:

Thank you Tom,
i moved to a newer Syno, with Docker capability :wink:

is this method (like in the attached video) working working with the OH3?

Good question. Honestly, I don’t know because I didn’t find a Java 11 Update for Synology and therefore skipped this tutorial for OH3. I only used the tutorial several times for OH2.

ok, thanks,

i going to install OH by Docker,

Just install / unzip java11 in a directory of your choice and change the


echo Launching the openHAB runtime...

export JAVA_HOME=/volume1/@appstore/openhab-java11/jdk-11.0.8/
export PATH=$JAVA_HOME/bin:$PATH

DIRNAME=`dirname "$0"`
exec "${DIRNAME}/runtime/bin/karaf" "${@}"

Works fine for me.


1 Like

How to upgrade from 2.x to OH3? Looks like some of you have succeeded.

What is the right way? Can I upgrade with the Snapshot-spk and setup the final release version manually?

I use the OH - synology package (I currently use the version) only to have the start/stop mechanism from the package manager. I manually download and unpack newer versions of OH and make a link openHAB to the current version.

lrwxrwxrwx 1 root root 28 Feb 13 21:22 openHAB -> openhab-3.1.0-SNAPSHOT-2206/
drwxr-xr-x 7 openhab users 4096 Aug 19 11:01 openhab-2.5.5
drwxr-xr-x 7 openhab users 4096 Oct 15 21:05 openhab-2.5.7
drwxr-xr-x 7 openhab users 4096 Dec 19 18:32 openhab-2.5.9
drwxr-xr-x 6 openhab users 4096 Dec 23 21:47 openhab-3.0.0
drwxr-xr-x 7 openhab users 4096 Dec 22 21:17 openhab-3.0.0.RC1
drwxr-xr-x 6 openhab users 4096 Jan 15 20:20 openhab-3.1.0-SNAPSHOT-2144
drwxr-xr-x 6 openhab users 4096 Feb 3 19:41 openhab-3.1.0-SNAPSHOT-2177
drwxr-xr-x 6 openhab users 4096 Feb 13 21:20 openhab-3.1.0-SNAPSHOT-2206

Of course there are some additional things to do because the original SPK version have some directory linked to the home directory of the user openhab. That needs to be done manually.
In addition you must copy the ui directory from the original installation from the spk (openHAB/ui) to your new openhab directory, otherwise the package manager does not detect a running OH. I have never tried to figure out why.

And of course the above mentioned manual install of java11 and adoption of is needed.


Thanks, got it. Good to know that it can work. I’ll give it a try.

Nice. working as you said. Thank you.