Synology DS216play Installation Questions


I am trying to run OpenHAB 1.8.2 on my new Synology 216play but I am not sure what the correct steps / the best practice for installation is…

This is what I did so far:

  • installed Java8 through Paket Center
  • installed OpenHAB-1.8.2-syno-noarch-0.001.spk manually

If I understood it correctly, than the spk is only creating the specific base folders and files for synology (and no runtime files)

So I tried to copy the 1.8.2 runtime files to the created /volume1/@appstore/OpenHAB directory.

Here I got my first problem: the folder was created with the openhab user as owner and my administration user does neither have permissions to write to this directory, nor to change the permissions on this folder.
Since I don’t know the password of the openhab user (who would have the permissions to copy the files there), what should be the correct way to get the files there?

What I did was, I downloaded the folder locally, deleted it from the NAS and uploaded it again with my user as owner, so I had the permissions to copy the runtime files there. Afterwards I gave access to this directory and all subdirectories to the openhab user.

Nevertheless, it seems that the permissions are not applied to all subfolders correctly, since I got some permission denied errors in the protocol, when trying to start OpenHAB through the Paket Center. So I am not quite sure, if my workaround was a good one. I manually changed the permissions of the subfolders where I got the errors and then it seemd to work, as follows:

When I try to start OpenHAB through the Paket Center, I get no error messages in the protocol, but the status stays “stopped” (although the protocol says, that OpenHAB is running).

When I try to open the OpenHAB interface it is working well (so it seems like its running correctly but the status is not set correctly in the Synology NAS).

Further, I still get sometimes some permission denied messages on some subfolders of the OpenHAB directory, so I think my “workaround” with replacing the initial OpenHAB directory is not working perfectly, since some permissions were not set correctly.

Can anyone tell my, how to correctly copy the files to the OpenHAB directory or how the permissions can/should be set?

And does anyone have an idea, why the Paket is not displayed as running in the Paket Center?

And one last question: does anyone know, how to display the protocol (OpenHAB logs) more userfriendly than with the “show protocol” option (I cannot copy/paste anything from there or search for specific things…)

Thanks for your hints in advance!

Best regards,

Hi Jimmy,

I just read your post. I myself have a DS216play and I
was wondering if you ever got Openhab to run on it ok.

Best regards, Chris

For your information, I run openHAB on synology DS214play and it works very well. I have no issues at all. Only drawback that I found so far is that I cannot get InfluxDB/Grafana to work since docker is not supported on a DS214play (and probably also DS216play). So no fancy graphs for me.

For your information, I run openHAB on synology DS214play and it works very well. I have no issues at all.

ditto. I’m running the 2.2 snapshot 7 package, from here

Do note, however, that it takes perhaps 5 minutes to fully-start after the package manager says its running.

1 Like

Hi Chris,

yes I got it running in the end. I do not exactly remember what I eventually did to get it running, but do you have any specific problems or did you just want to know?

Best regards

1 Like

Hi Jimmy,

Thanks for the reply.

No, I was just wondering, since I read somewhere that openhab doesn’t run on DS216play.

I allready installed it yesterday, but I couldn’t get my zwave stick gen5 to come online.

So I started fidling around and crashed my DSM :slight_smile:

After a day of trying to get it back online, I managed to do so by reinstalling the DSM.

So I’m back to square 1 :slight_smile:

If you should know about a good tutorial concerning the installation of OpenHab on synology, you may always let me know.

Best regards,


You said you installed it ok. So it installs ok.

For configuring your zstick, see this post, which is how I’ve got mine set-up.