Synology HAB3 Port

Tags: #<Tag:0x00007fc8f8cb12b8>

Thanking you in advance again
Is there something I am missing / Just got win 10 to work with some help from user:hmerk
Not sure where to go from here / any suggestions are welcomed

I have installed and started HAB 3.0.0.000 on a DS 214 synology
I have moved the ports from 8080 and 8085 and 8443 to 8448.
I have nmap the ports and they are showing
8085/tcp closed unknown ,this is same for 8080
8448/tcp closed unknown ,this is same for 8443
OpenHAB is running and java8.0.275-0019 installed and running.
All files can be found in the public folders. addons/conf/userdata as created by hand / doc’s

.**************************************
Start service “start_stop” log
call start.sh.
wait_for_status: 0
wait_for_status: 0

PID file created.
.***************************************
Set instance variables… “install.log”
public: true
smarthome: false
home: false
TMPFS: false
Z-Wave: false
port: 8085
port: 8448
tmp: /volume1/@tmp
share: /volume1/public
oh: /volume1/public/openHAB
backup: /volume1/@appstore/openHAB-backup-202103
done
User that exec the Installation
root
Start postinst…
Create ‘openhab’ daemon user
Install new version
Extract openhab-3.0.1.zip
Move files to /volume1/@appstore/openHAB
No TMPFS Install needed
Move conf to /volume1/public/openHAB/conf and create conf link
Move addons to /volume1/public/openHAB/addons and create addons link
Move userdata to /volume1/public/openHAB/userdata and create userdata link
Fix permissions
done
No Z-Wave Wanted

Doesn’t OH3 need Java 11? (I may be wrong)

Indeed, openHAB 3 requires Java 11, recommended Zulu 11 …

1 Like

Look here and here (Java11) for explanation of OH3 on Synology DS.

Br,
Stefan

I have tried to find the correct JAVA 11 Zulu for my NAS running armv71 GNU/Liniux synology_armadaxp_ds214.
I few error show up : /bin/inc 247 interger expression expected
/bin/karaf line 95 and 301 same as above
/bin/karaf 337 can not exec binary file

Please can you be as so kind as to provide a link to be able to down load the same ver of java11 zulu so as to test for a problem or the one that fit’s my synology armv71 GNU/Liniux
Thanks in advance for any help.

Did you try one of these

https://cdn.azul.com/zulu-embedded/bin/zulu11.45.27-ca-jdk11.0.10-linux_aarch32hf.tar.gz
https://cdn.azul.com/zulu-embedded/bin/zulu11.45.27-ca-jdk11.0.10-linux_aarch32sf.tar.gz

Once again I would like to thank all who have helped to achieve the outcome.

Steps taken

  1. Installed openhub from snapshot 3.0 stable
  2. Install java 11 32 bit version " was my issue thanks Wolgang_S for the links"
  3. change start.sh to correct info paths

For a beginner: some commands used : "not 100% given just a guideline "
copy to a Public Folder then copy to location / create public folder inside synology DS 6
public folder found on path volume1/public
cp “path” to put zip files on drive where you want to unzip them
find -iname “folder names” to get paths
vi to edit and change the start.sh file
chmod -x start.sh to set up for run mode
./start.sh to run openhab server

Follow the work done by members they have done all the hard work / Thanks for all your help and patiences and understanding.

1 Like

Thanks all for the help / One last obstacle .
As i have manually install java 11 and openHAB 3 my synology only runs on a Putty manual start. I did mod the start.sh for java , But the problem is to start it auto when the NAS startup. Looking into the /usr/local/etc/rd.d folder , I don’t have any files there. I belive i need the start.sh with start and stop options. I don’t know how to start and stop openHAB via script , if Possible can someone please give an example if not the correct script file required and would there be an issue with file permissions too? Many thanks for any help
Any help would be greatly appreciated

have a look at Synology NAS - How to make a program run at startup · GitHub . As I do not own a Synology I couldn’t test it.

I have the Icon in the Package with RUN , When executing it
File Start-stop-status.sh found var/packages/openhab/scripts/
.**************************************
call start.sh.
wait_for_status: 0
wait_for_status: 0

PID file created.
.***************************************
But the service never starts
The Icon never goes to OPEN status. Meaning running.
Please NOTE the start,sh has mod to run java11
Script works from Putty if executed

My understanding running from the package manger.
openHAb/scripts/start-stop-status.sh will run first
then call start.sh in /@appstore/openHAB/ “The one i run Putty and works”

I have tried to put paths for java in the begging of start-stop-status.sh.
delete log file / run openHAB / new log file error above.*******

If you need the script i can post it , any help , Am I looking in the wrong place or script. Simply put I am lost.
Need synology assistant with coding. PS:i don’t know linux coding at all/ Thanking in advance .

Hi,
If you use Synology why don’t you to run your OH in docker container? It’s much simpler…

I have 2 nas one being a DS214 , DS218play I do believe that they can,t run Docker. Due to the shipping problems I can only get a $1000 nz nas without drives for Docker, Don’t think throwing money at the problem is the only answer.