Synology / MQTT Broker Moquette / Installation Problem

I’m a newbe with openhab hat this is my first try on my synology.
There are very good tutorial how to do it on Synology NAS, but I think I made a mistake on a step … but where …

Installed 2.5. package -> Works
Install Mqtt Bindig -> Works
Install MQTT Broker Moquette -> Works
Then I configured the MQTT Embedded Broker, first without any changes, A item was automatic found which I could add.

I do not know why I have done it, but I deinstall the package because I thougt I have to install the latest.

I installed then the same and performed the same steps, except I configured the brocker with my one values and SSL.
But now the item was not automated found.
In the openhabe.log I found following issue

java.nio.file.FileAlreadyExistsException: /volume1/@appstore/openHAB/userdata
at sun.nio.fs.UnixException.translateToIOException( ~[?:1.8.0_241]
at sun.nio.fs.UnixException.rethrowAsIOException( ~[?:1.8.0_241]
at sun.nio.fs.UnixException.rethrowAsIOException( ~[?:1.8.0_241]
at sun.nio.fs.UnixFileSystemProvider.createDirectory( ~[?:1.8.0_241]
at java.nio.file.Files.createDirectory( ~[?:1.8.0_241]
at java.nio.file.Files.createAndCheckIsDirectory( ~[?:1.8.0_241]
at java.nio.file.Files.createDirectories( ~[?:1.8.0_241]
at ~[?:?]
at ~[?:?]

I do not find the issue. also a complete delete, inc delete of the folders, tmpfs,… I run always now in the same problem.

Do someone have a hint for me where I could search the problem?


Remove the embeded broker and install mosquitto instead

But thoes do not solve the problem.
II have already read a lot in the forum that many use the Mosquitto,but I would like to know why it is no longer possible after a new installation, there must be something “left over” (after uninstalling).

I have the same issue. I assume it has something to do with synology. Probably permissions or the directory structure…

  1. Go to security settings
  2. Advanced tab
  3. Lower TLS/SSL security level to the mid level

Should work - it worked for me.