Synology OH2 installation: 'Port undefined configured'

Tags: #<Tag:0x00007f616ed85a28> #<Tag:0x00007f616ed85960> #<Tag:0x00007f616ed85870>

I have a
server: Synology DS415+
sever operating system : DSM 6.0.2-8451 Update 2

I am trying to do an installation of the OpenHAB-2.0-SNAPSHOT_a-DSM6-syno-noarch-0.002.spk

It is a manual installation with the Synology package installer from the .spk file in the public directory on the Synology.

After a few secs it gives an error:
‘Port undefined configured for this package is either used by another service or reserved for system use. Please disable or modify the conflicting service, or contact the developer to modify the package configuration.’

Before this I had OpenHAB 1.8 running and before that 1.6. This was installed on the same way with no problems regarding the port configuration. I already tried some things as the weather report and the Samsung LED TV remote control bindings. This worked fine.

I have done some fine tuning on the Synology with other packages and ports had to be redirected on my router and relocated on the Synology. For as far as I know this has not compromised the OpenHAB 1.8 installation.

list of packages running on my Synology:
Antivirus Essential
Audio Station
baikal
configure file editor
cops
download station
filebot
git
hyperbackup
hyperbackup vault
java7
logcenter
mariadb
mediaserver
mosquitto
notestation
oracle java se
perl
photostation
php
phpmyadmin
python
python module
python3
storage analyzer
surveillance station
text editor
timebackup
transmission
videostation
vpn server
webstation

After removing OpenHAB 1.8 I tried to install OpenhHAB 2.0 with the above mentioned error message as a result.

Googling gave some advice but apparently this was for different situations. (apparently Synology is also changing the environment and folders of the linux operating system.)

When I look in the installer files of the .spk (installer.sh and some other pre an post install scripts) I can’t find any port checking. So I don’t know where to find a solution regarding the double claims on this ports.

My question is where the port checking is done and which ports are checked that cause this error.

Because of the very long list of packages I felt ashamed that there were also packages I even did not use and therefore I cleaned out some packages on my server.

I have removed :
cloudstation
carddavserver
gitserver
lazy librarian
domoticz
(and some I forgot)

The problem was not Domoticz because that can live along openhab1.8. I used it for testing because openhab could not discover my syno usb port and domoticz could find it

And guess what ? …

after restarting the syno there is no problem installing OpenHAB2

I guess that the cloudstation package caused the problem.

PROBLEM SOLVED !

the next hurdle is popping op because there is an “unable to connect” error:
“Firefox can’t establish a connection to the server at 10.0.0.10:8080.”

but I’ll dive in to that and if I can’t solve it, I will ask you.

(maybe I can answer myself again then … :wink:)

Thanks for reading

To solve the problem I had to ssh to my syno en manual start the OpenHAB server
the script is in :

/volume1/@appstore/OpenHAB2

starting the server with …/start.sh gave some error message about the wrong java version
I installed Java8 in the Synology package center and removed the Java7 package

restarting the disk station took me one step further
the OpenHAB server on :8080/start/index

gives this error:

“HTTP ERROR 404
Problem accessing /start/index. Reason:
Not Found
Powered by Jetty://”

It turned out that no files were available to the directories
/public/OpenHAB2/addons and /public/OpenHAB2/conf
So I downloaded from the site openhab-offline-2.0.0-SNAPSHOT.zip and unzipped it
the contents of the above mentioned directories were copied to the right place.

in the configurationfile /public/OpenHAB2/conf/services/addons.cfg I added the line “package = demo”

Restarting the openhab server in the Synology package center.

Et Voila… the smooth and slick welcome screen of OpenHAB 2.0 appears in my browser :slight_smile: