Synology sitemap problem


Currently trying to install openHAB on my synology diskstation but having problems with sitemaps not discovering in basicUI

What i have done so far:

  1. Installed openHAB- with succes.

  2. OpenHAB is installed in:
    with the subfolders being:

    • All the readme files and subfolders show up after installation
  3. Set r/w permissons for the openHAB user in controlpanel for the public folder inside synology diskstation.

  4. Created a default.sitemap in \\public\openHAB\conf\sitemaps\default.sitemap as a .txt file.

sitemap default label="default" 

	Switch item=Presence_Mobile_Gabriel label="Gabriel's Mobile"

5.Created a default.items in \\public\openHAB\conf\items\default.sitemap as a .txt file

Switch Presence_Mobile_Gabriel "Gabriels Mobile" <network>

  1. Declared the default sitemap location to “default” in paperUI.

And now i get the error in basicUI “Available sitemaps, It seems like you have not defined any sitemaps yet. To build one, please check the documentation for guidance.”

Any ideas on what could be wrong?

The extension must be .items

How do i create a .items file? Sorry

the items file should be named as .items, and not as .sitemap

You said:
Created a default.items in \\public\openHAB\conf\items\default.sitemap

So sorry, that’s a typo on my part. Attached is the location where the .sitemap and .items are stored.

And it still does not work… :frowning:

It must be the type Items-File. Rename it.

have you looked in the log, to see if there’s an error?

And check also the extension of the sitemap-file.

Deactivate “Hide extensions for known file types” in the explorer.

@Gabriel_G untick the option Hide extensions of known file types for you explorer.

Then you will see that your files are called default.sitemap.txt but it has to be called default.sitemap and the items file default.items . This can be seen at the filetype column.


1 Like

Renamed it to Created a default.items in \\public\openHAB\conf\items\test.items

And the .txt file still contains

Switch Presence_Mobile_Gabriel "Gabriels Mobile" <network> { channel="network:servicedevice:192_168_1_216_80:online" }

Still not working :frowning:

How do i check the extension of the sitemap-file?

My file explorer is set to show hidden files(In danish but “Vis skjule filer, mapper og drev”= “Show hidden files, folders and drives”)

And wahat about the sitemap-file?

I dont know you language but I think ist sould be “Skjul filtypeavane for kendte filtyper”. Uncheck it.

@Josar Huge thanks to you! You were completly correct. I created the files with the normal windows notepad, so all the files were saved as test.items.txt instead og test.items… Fixed this using notepad++ and saving as .items and .sitemap

1 Like