SystemInfo binding: how to change priority of a channel?

Tags: #<Tag:0x00007f5c98e4a948>

I am using OpenHAB 2.4 on a raspberry pi 3B.
I installed the systeminfo binding and I am not able to change the “priority” of a channel, even if the docs tell that it is possible.
Here’s my thing configuration

systeminfo:computer:raspberrypi2 [interval_high=3, interval_medium=60]

And here’s the item definition

Number Sensor_CPUTemp      (gSystem)  { channel="systeminfo:computer:raspberrypi2:sensors#cpuTemp",priority="Medium" }

the priority keyword is my guess (probably wrong), as the syntax is not detailed in the docs. It does not work, but there is no error in the logs (the item still gets updated every 3 seconds)

At present I modified the interval_high keyword of the thing definition but it is not a satisfactoy solution. Does anybody knows how I can set the priority for that channel?
Thank you

Such has to be set in the channel definition of the thing and can’t be set at the item Level.
When configuring the things via PaperUI you can set it there for each channel.

Thank you.
I’ve found the setting in the paper ui, but i cannot save the new priority. It writes 409-conflict
I’ll try to remove the textual thing definition.

Can you please detail when you found priority seting in Paper UI.
I have configured a storage channel that seems to update ONCE on the reboot. I need to set it to medium but that is mentioned in the doc but no syntax is given.
TIA

On PaperUI select the Thing in question, now the Channels of that Thing should be displayed. From that list go yo the Channel in question and select the pencil icon, on the popup window “Configure Channel” you should see a selection for the interval which is set to “Low”. Change that to "Medium"or “High” and click the save button.
The actual update rate for those settings in seconds can be set by clicking ghepencil button of the Thing.

Ok now I feel like a stupid but I stil can’t find it:
When I enter the thing config I see two pensil icons.
Main one (green arrow)That is config for the local server thing, lets me change intervals for the High and Medium priority

and then there is not more chanel config option.
There is another pencil (red arrow) , for setting up a linked item but it allow only profile selection (default, follow, ofsset) (no idea what that does)

Any more clues?

Regards

Ups,
for me it displays differently. I do see a pencil for each channel, and for those channels that are linked to an item I see (when expanded) an additional pencil for the item.

A POSSIBLE explanation could be: Did you setup the “Local Server” via a .things" file. Changing the settings via PaperUI for things that are setup via files is not possible.

Ok that is a mystery, I don’t even have a thing file. I did setup a thing in PaperUI.
I do keep items file howewer but that should not influence the channel config

Number CPU_Load1            "CPU Load 1 Min [%.1f] "        { channel="systeminfo:computer:work:cpu#load1" }
Number Memory_Available     "Memory Available [%.0f MB]"       { channel="systeminfo:computer:work:memory#available" }
Number Storage_Available    "Storage Available [%.0f MB]"      { channel="systeminfo:computer:work:storage#available" }

Did you setup items in the Paper as well?
Is there a syntax in the items file to change the priority?
I run stable OH 2.4 and the binding version is 2.4.0.

Yes, via PaperUI
Not to my knowledge.
Also 2.4 stable!

Deleted the items in the item file, Restarted OH and the pencils in the chanel conf are there. Did item definition in the file again and chanell edit is still there. Wonders of OH. Thanks for help.


eeee but no there is no channel for CPU load 1m 5m anymore just single instant load. Meh.

Load for 1m and 5m? I can’t remember to have seen those. I do not have them as well.
Checking the documentation, this channels are mentioned for 2.2, 2.3, 2.4 and for the latest Version.

From your decription what you have done, a change in the channels should not have happened. A Change is only possible if the binding changed (which you didn’t do) or if the Thing was created using an older version, the binding got an update (like update to 2.4) and the Thing was not recreated (just kept). That way a change in the channels would be explained, but you didn’t do such!

I also see only CPULoad in the paperUI.
I defined CPULoad1m and CPULoad5m following the example in the docs and they are persisted correctly: clearly I had to use the workaround to change the interval_high parameter.
This seems to me a bug in the implementation of the binding: should an issue be raised on github?

Issue, yes

Took me a while because unfortunately this isn’t in the documentation, but below is a working example.
(Possible values: High, Medium, Low)

Thing: This creates a thing where the HIGH interval profile = 1 seconds, and the MEDIUM profile = 5 seconds, and sets the storage#usedPercent priority to HIGH:

Thing systeminfo:computer:openhab1	@ "Home"	[interval_high=5, interval_medium=5] {Channels:
	Type usedPercent : storage#usedPercent [priority="High"]
}

Item:

Number openhab1_Storage_Used_Per	"openHAB1 Storage Used (%)" channel="systeminfo:computer:openhab1:storage#usedPercent"}