Systeminfo error in log, still not fixed?


After upgrading to 2.4, I still get a

2018-12-31 11:24:35.121 [ERROR] [ding.systeminfo.internal.handler.SysteminfoHandler] - No information for channel network#ip with device intex 0 :
    org.openhab.binding.systeminfo.internal.model.DeviceNotFoundException: Device with index: 0 can not be found!
            at org.openhab.binding.systeminfo.internal.model.OshiSysteminfo.getDevice( ~[?:?]
            at org.openhab.binding.systeminfo.internal.model.OshiSysteminfo.getNetworkIp( ~[?:?]
            at org.openhab.binding.systeminfo.internal.handler.SysteminfoHandler.getInfoForChannel( ~[?:?]
            at org.openhab.binding.systeminfo.internal.handler.SysteminfoHandler.publishDataForChannel( ~[?:?]
            at org.openhab.binding.systeminfo.internal.handler.SysteminfoHandler.publishData( ~[?:?]
            at org.openhab.binding.systeminfo.internal.handler.SysteminfoHandler.lambda$2( ~[?:?]
            at java.util.concurrent.Executors$ [?:?]
            at [?:?]
            at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201( [?:?]
            at java.util.concurrent.ScheduledThreadPoolExecutor$ [?:?]
            at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:?]
            at java.util.concurrent.ThreadPoolExecutor$ [?:?]
            at [?:?]

Error. Searching around, I did find a PR but it seems not fixed (yet). Searching further, I found on github the following line:

logger.error("No information for channel {} with device intex {} :", channelID, deviceIndex, e);

here at line 445.

Does anyone else has this problem too?

It only occurs when OH is restarted so not a major thing but it would be neat if it is just fixed. I just assume ‘index’ should be ‘index’

Best regards