[TapoControl] - Control Tapo Smart WiFi-Devices with Openhab

@Bigdesaster yes I did exactly same configuration as the documenation.
Each time the message is :

Thing 'tapocontrol:P100:myTapoBridge:tapoPrise10' changed from INITIALIZING to OFFLINE (CONFIGURATION_ERROR): no brigde configured

(yes “brigde”, not “bridge” :wink:)
Thus the bridge thing is actualy OK and ONLINE.

WTF, completely missed advanced checkbox!
great again! really thanks again for your help and work for us!

your welcome :blush:

@funcat
yes you’re right. The configuration in readme was wrong. :crazy_face: See OH-Docs
Corrected readme now.

Any chance to send date/time to the P110 when the device is initialized ?

I can confirm that the energy monitoring is not working when device was plugged in without internet connection. Device has then definitely wrong timestamp and energy-usage-query returns only error code.
I tried to set the time with some commands, but i did not work. It’s anyway only a speculation that the wrong timestamp is the source.

So i see there no chance at this time.

Hi @Bigdesaster
I tried bridge textual thing configuration and it is working now for P100, thanks !
But does not work for P110.
Statut is : "OFFLINE (CONFIGURATION_ERROR): found type:'P110' with mac:'xxx'. Check IP-Address"
Thus IP is correct.
Tested with 6 P100 (all OK), 2 P110 (both KO)
I have one issue also : in IP configuration only IP format is accepted (obviously…) but it is mainly accepted to have network dns names also in this kind of parameter.
All network stuff are dns named in my house.
Anyway, again thanks for this addon.

It worked for me with the P110.
Can you post your config?

Hello,

Bridge  tapocontrol:bridge:tapoCloudBridge  "tapo cloud login Account"  [ username="xxx", password="xxx", cloudDiscovery=true ] {
    Thing   P100    prise10 "prise10 xxx (P100)"     [ ipAddress="xxx", pollingInterval=30 ]
    Thing   P100    prise11 "prise11 xxxx (P100)"        [ ipAddress="xxx", pollingInterval=30 ]
    Thing   P100    prise12 "prise12xxxx  (P100)"   [ ipAddress="xxx", pollingInterval=30 ]
    Thing   P100    prise13 "prise13 xxx (P100)"    [ ipAddress="xxx", pollingInterval=30 ]
    Thing   P100    prise14 "prise14 xxx (P100)"    [ ipAddress="xxx", pollingInterval=30 ]
    Thing   P100    prise15 "prise15 xxx (P100)"   [ ipAddress="xxx", pollingInterval=30 ]
    Thing   P110    prise18 "prise18 xxx (P110)"                    [ ipAddress="xxx", pollingInterval=30 ]
    Thing   P110    prise19 "prise19 xxx (P110)"                    [ ipAddress="xxx", pollingInterval=30 ]
}

P100 work fine. P110 still in error. Statut is : "OFFLINE (CONFIGURATION_ERROR): found type:'P110' with mac:'xxx'. Check IP-Address"
IP Address is correct.
Last addon snapshot installed on january 10th.

EDIT :
You can ignore this message.
I did post this without test for couple of days. Now it is working, my bad.
(thus i dont know what have changed now it is working)

I can now test P110 energy functionnalities ! Thanks !

Something weird happened today. I have 5 Tapo devices o/w 3 were put in use several days before the others. These 3 went offline today. Enabling / disabling the thing did not help. After enabling internet Tapo app was able to switch these 3 devices but not openhab. Only a power cycle made them availabe to OH (I’ve only power cycled 2 devices to be sure, the last one is still offline).

@Bigdesaster What test can I make to diagnose this situation ?

Ht, you can try to trace the remaining offline device.
But i wonder that got the same issue with one of my devices yesterday too.
The device login was succesfull but then it didn’t return a request until i plugged-out the device.
If it occur more often (maybe in the same interval) we may have to trace the commuication and look in the logs.
But it seem’s to be a problem with the device if it not responds to the requests…

hello, this issue is related to p110 or to other models?

It happened in 3 of my 4 P100’s.

Too late. I’ve left the internet on during all night and the device recovered suddenly at the middle of this morning. Here are relevant lines from events.log
tapo.log (20.8 KB)

I’ve tried to understand what happened when the device recovered. I have an external script to monitor my alarm system. The alarm is not managed by OH but I want to know its status. That’s the purpose of the script. It sends REST requests to OpenHAB when alarm status changes and then OH executes some commands (such as unlocking the garage gate) but none related to this particular P100. The timestamps are identical but I do not understand what possible relation this can have.

3.3.0.M1 includes the binding version that supports P110 :ok_hand: :ok_hand: :ok_hand:

Hello i’m here again! This time with L530 bulb. I’ve configured everything a couple of days ago,but today it stopped to work from openhab. From tapo app works fast and perfectly but not from openhab. Also i’ve seen that from colorpicker in sitemap,even if it is configured as the widget in ui,it doesn’t work. Today i had to restart my raspberry and router and now my L530E is online from openhab but unresponsive. Can i remove thing, set it to debug and send you the result to be analyzed?

Just set debug level to trace an post it here. Are you using the newest version?

Ok i had a openhab issue causing unresponsive items. Everything works except the colorpicker from sitemap. Seems it won’t send commands…

All my P100’s are offline in OH ( COMMUNICATION_ERROR

Invalid HTTP-Response). The P110 is ok. Yesterday everything was ok. Using the Tapo app all is ok.

Disabling/enabling the thing doesn’t help. Power recycle solved the problem. This also happened on Jan/17. What can be the cause ?

I’m still thinking that it’s caused by disabling internet connection to your devices. Got no problem withy devices.

I think so. Probably these devices “call home” periodically. I also have Kasa devices and they do not have this problem.

Maybe some keys changed in Tapo cloud and your binding is using the new keys instead of the old ones ?