Tasmota Homie support

after I have tested 2 sonoff pow, I ordered a number of them. mqtt 2 binding has come out last week. Now my question, is there someone working to support the homie protocol, for tasmota flashing? I like the idea of auto discovering and see a post on the tasmota GitHub. Is there already someone working on it than i will wait with all the flashing.

Btw the new binding Works super

There are issues open for both Tasmota and ESP Easy but I think it is waiting for work to complete upgrading the ESP8266 homie library before David can submit a PR. According to one reply there is already support for Home Assitant autodiscovery but you have to turn it on through SetOption19. Turn this on (don’t ask me how, I just learned this myself) and you should be able to create a Home Assistant MQTT Thing and it would be discovered.

Otherwise I think we just need to be patient. I expect Tasmota to have support first and then hope that EPS Easy gets it soon as well since I have a mix of both.

To set option 19 just go in the tasmota web interface console and type:

setoption19 1

Then hit enter. Might work, might break everything. Good luck!!

Edit - I checked the tasmota wiki and realized I had the command a little “off” from what it should be. Corrected now.


I don’t want to be the the bearer of bad news, but:
There was an error in the HA auto discovery that was fixed just yesterday. After discovering HA Things, you need to correct the Thing configuration.

Fixed … where? Mqtt binding? Tasmota? Openhab snapshot?

How would one go about taking part in the fixed version?

The more I research version 2.4 (especially mqtt) the more comfortable I am waiting a couple more months before upgrading my main openhab so the kinks can get worked out and the forums can fill up with solutions.

That bug was only discovered because someone actually USED the binding with that particular feature :smiley:
The generic Thing works. Homie works as well. And HA… I mean they are competitors, it is alright if their rather strange stuff doesn’t work from day one, I guess.

Cheers, David

1 Like

I did say I’m waiting on my main system - I’ve got 3 sonoffs in my backpack already so I can try the home assistant discovery at work tomorrow!

If you would kindly point me to the corrections I need to make so discovery works properly for testing I’d appreciate it!

I think you need to delete your HA Things and rediscover them, of course after upgrading to the latest snapshot.

Just some remarks/questions from my side:
The subject of this thread is about homie support. Isn’t it?
I’ve just tried “setoption19 1” on one of my sonoff S20s (with tasmota) and the device shows immediately up as “HomeAssistant MQTT Component” in the inbox.

As of my understanding, the homie mqtt spec is not the same as the homeassistant mqtt spec. It seems to me that the homie spec is a bit more generic than the HA one and looks as the preferrered one to me.
But it seems that homie support is not (yet?) for tasmota available.
Am i right? (Just curious. Yes, I know that this question should be placed on a tasmota forum, but the thread was already started here. Feedback welcome, too …)

The binding seems to support autodiscovery for both specs.

I’ve not yet switch completely to the new MQTT binding (due to lack of time) , which seems a very big step in the right direction. (Thanks to David et. al !!!).

What you want to do for a better HomeAssistant MQTT auto-discovery is to use OH 2.5 snapshots. There were some bugs fixed recently. Homie is preferred, yes. And it got way more testing during the development.

HomeAssistant developers contributed to a lot of DIY projects and integrated their MQTT support.
It is time for OH developers and affiliates to do the same with Homie.

My excuses for the late answer. Go try tonight. Will let you know how it goes and if I run into bugs. Can not add much to the development but can do some testing. Thanks for al the hard work!

Update i try to use the Home Assitant autodiscovery. i can find the sonoff but than the things still offline
Status: OFFLINE - GONE No response from the device yet.

    2019-01-08 21:19:30.296 [ERROR] [ansport.mqtt.internal.ClientCallback] - MQTT message received. MqttMessageSubscriber#processMessage() implementation failure

    java.lang.NullPointerException: null

    	at org.eclipse.smarthome.binding.mqtt.generic.internal.discovery.HomeAssistantDiscovery.receivedMessage(HomeAssistantDiscovery.java:168) ~[?:?]

    	at org.eclipse.smarthome.binding.mqtt.discovery.TopicSubscribe.processMessage(TopicSubscribe.java:52) ~[?:?]

    	at org.eclipse.smarthome.io.transport.mqtt.internal.ClientCallback.lambda$3(ClientCallback.java:90) ~[209:org.eclipse.smarthome.io.transport.mqtt:]

    	at java.util.ArrayList.forEach(ArrayList.java:1257) ~[?:?]

    	at org.eclipse.smarthome.io.transport.mqtt.internal.ClientCallback.messageArrived(ClientCallback.java:90) [209:org.eclipse.smarthome.io.transport.mqtt:]

    	at org.eclipse.paho.client.mqttv3.internal.CommsCallback.deliverMessage(CommsCallback.java:499) [200:org.eclipse.paho.client.mqttv3:1.2.0]

    	at org.eclipse.paho.client.mqttv3.internal.CommsCallback.handleMessage(CommsCallback.java:402) [200:org.eclipse.paho.client.mqttv3:1.2.0]

    	at org.eclipse.paho.client.mqttv3.internal.CommsCallback.run(CommsCallback.java:206) [200:org.eclipse.paho.client.mqttv3:1.2.0]

    	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]

    	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]

    	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?:?]

    	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:?]

    	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]

    	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]

    	at java.lang.Thread.run(Thread.java:748) [?:?]

Hello everyone.
because Tasmota dosnt have homie support, im working on my own ESP8266 firmware with Homie support.
Auto discovering worked one time but i need more information about the protocol.
When i have to send the state etc.
Any information?

regards TimoS

Very noble, but also consider to have a look at the homie-esp8266 firmware which was the actual base for the homie convention. If would help A LOT by adding homie support to Tasmota. The developers already agreed that they would merge such a support, but they won’t develop it themselves.

homieiot.github.io :slight_smile:

That’s right, but i have my own hardware (now 7 different devices) with my own firmware. Homie support will be great if it works.
I have parallel set up a openHAB 2.5 testserver to my active openHAB 2.3 and working now for Homie support.

respect for your realy great work at openHAB David thumbs up