TCP send command

Hi all,

I’m using the daily snapshot of openhab2 and I have installed the TCP binding 1.9 via paper UI.
I have a mobotix S15 (with IP on my maindoor. I have setup that the mobotix sends a tcp command via port 5100 to the openhab server everytime the door bell is activated.

In the tcp dump I noticed that the command is send on the correct port. Then I have configured the TCP binding as follows:

# all parameters can be applied to both the TCP and UDP binding unless
# specified otherwise

# Port to listen for incoming connections

# Cron-like string to reconnect remote ends, e.g for unstable connection or remote ends
#reconnectcron=0 0 0 * * ?

# Interval between reconnection attempts when recovering from a communication error,
# in seconds

# Queue data whilst recovering from a connection problem (TCP only)

# Maximum buffer size whilst reading incoming data

# Share connections within the Item binding configurations

# Share connections between Item binding configurations

# Share connections between inbound and outbound connections

# Allow masks in ip:port addressing, e.g.* etc

# Pre-amble that will be put in front of data being sent

# Post-amble that will be appended to data being sent

# Perform all write/read (send/receive) operations in a blocking mode, e.g. the binding
# will wait for a reply from the remote end after data has been sent

# timeout, in milliseconds, to wait for a reply when initiating a blocking write/read
#  operation

# Update the status of Items using the response received from the remote end (if the
# remote end sends replies to commands)

# Timeout - or 'refresh interval', in milliseconds, of the worker thread

# Timeout, in milliseconds, to wait when "Selecting" IO channels ready for communication

# Used character set

in my item file I have defined the following item

Switch  Klingel {tcp="<[ON:'REGEX((ON))']", autoupdate="false" }

In the openhab log I see the following after restart of openhab

2017-01-29 18:31:45.475 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - The maximum buffer will be set to the default value of 1024
2017-01-29 18:31:45.475 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - The interval to retry connection setups will be set to the default value of 5
2017-01-29 18:31:45.475 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - The cron job to reset connections will be set to the default value of 0 0 0 * * ?
2017-01-29 18:31:45.475 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - The setting to queue write operation until a channel gets connected will be set to the default value of true
2017-01-29 18:31:45.475 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - Listening for incoming connections on /0:0:0:0:0:0:0:0:5100
2017-01-29 18:31:45.480 [INFO ] [ing.tcp.protocol.internal.TCPBinding] - The maximum time out for blocking write operations will be set to the default value of 3000
2017-01-29 18:31:45.480 [INFO ] [ing.tcp.protocol.internal.TCPBinding] - The preamble for all write operations will be set to the default value of ""
2017-01-29 18:31:45.480 [INFO ] [ing.tcp.protocol.internal.TCPBinding] - The postamble for all write operations will be set to the default value of ""
2017-01-29 18:31:45.480 [INFO ] [ing.tcp.protocol.internal.TCPBinding] - The characterset will be set to the default value of ASCII

Based on that information I would expect that all connections will be accepted coming from any IPv4 addresses on port 5100.

However, I have tried to setup and I noticed the following in the log.

2017-01-29 18:17:20.959 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - Received connection request from /
2017-01-29 18:17:20.959 [INFO ] [ing.tcp.AbstractSocketChannelBinding] - Disconnecting the unallowed remote end /

Somehow it’s not allowing a connection from the mobotix.

Anybody any idea how to solve that issue?

Thanks in advance.

Best Regards,