Telegesis ETRX357USB-LRS does not initialize

After a frustrating experience with another Zigbee USB dongle I bought the Telegesis ETRX357USB-LRS but I can’t get it working on my RPi3 with Openhabian and openHAB 2.5.0~M2-1

The dongle is discovered in PaperUI and I’m able to add it but it just won’t come online. Here is the debug log

2019-08-19 22:31:34.912 [DEBUG] [e.telegesis.handler.TelegesisHandler] - Initializing ZigBee Telegesis serial bridge handler.
2019-08-19 22:31:34.912 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Initializing ZigBee network [zigbee:coordinator_telegesis:04000A5E].
2019-08-19 22:31:34.913 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Channel 11
2019-08-19 22:31:34.914 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - PANID 39166
2019-08-19 22:31:34.914 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - EPANID 75E34CE9E3FA69DA
2019-08-19 22:31:34.915 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Network Key 30241D4FCACE09B2C5E796D89724C6F7
2019-08-19 22:31:34.916 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Link Key 5A6967426565416C6C69616E63653039
2019-08-19 22:31:34.917 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Config: zigbee_initialise found, initializeNetwork=true
2019-08-19 22:31:34.917 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Network Key String 30241D4FCACE09B2C5E796D89724C6F7
2019-08-19 22:31:34.919 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Network key final array 30241D4FCACE09B2C5E796D89724C6F7
2019-08-19 22:31:34.920 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Link Key String 5A6967426565416C6C69616E63653039
2019-08-19 22:31:34.921 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Initialising network
2019-08-19 22:31:34.926 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Link key final array 5A6967426565416C6C69616E63653039
2019-08-19 22:31:34.928 [DEBUG] [e.telegesis.handler.TelegesisHandler] - ZigBee Telegesis Coordinator opening Port:'/dev/ttyUSB0' PAN:98fe, EPAN:75E34CE9E3FA69DA, Channel:11
2019-08-19 22:31:34.932 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Scheduling ZigBee start
2019-08-19 22:31:35.933 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - ZigBee network starting
2019-08-19 22:31:35.934 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Initialising ZigBee coordinator
2019-08-19 22:31:35.936 [DEBUG] [e.transaction.ZigBeeTransactionQueue] - Default: Set profile to ZigBeeTransactionProfile [maxOutstandingTransactions=2, interTransactionDelay=50, maxRetries=2]
2019-08-19 22:31:35.937 [DEBUG] [e.transaction.ZigBeeTransactionQueue] - Broadcast: Set profile to ZigBeeTransactionProfile [maxOutstandingTransactions=3, interTransactionDelay=1200, maxRetries=0]
2019-08-19 22:31:35.938 [DEBUG] [e.transaction.ZigBeeTransactionQueue] - Multicast: Set profile to ZigBeeTransactionProfile [maxOutstandingTransactions=3, interTransactionDelay=1200, maxRetries=0]
2019-08-19 22:31:35.939 [DEBUG] [bee.handler.ZigBeeCoordinatorHandler] - Mesh Update Period 86400
2019-08-19 22:31:35.940 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - Adding supported cluster 1280
2019-08-19 22:31:35.941 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNode ] - ClusterMatcher starting
2019-08-19 22:31:35.942 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNode ] - ClusterMatcher adding cluster 1280
2019-08-19 22:31:35.942 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - Adding supported cluster 25
2019-08-19 22:31:35.943 [DEBUG] [com.zsmartsystems.zigbee.ZigBeeNode ] - ClusterMatcher adding cluster 25
2019-08-19 22:31:35.944 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - ZigBeeNetworkManager initialize: networkState=UNINITIALISED
2019-08-19 22:31:35.944 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - Network state is updated to INITIALISING
2019-08-19 22:31:35.945 [DEBUG] [.zigbee.internal.NotificationService] - NotificationService is shutdown. Not scheduling com.zsmartsystems.zigbee.ZigBeeNetworkManager$3
2019-08-19 22:31:35.946 [DEBUG] [ngle.telegesis.ZigBeeDongleTelegesis] - Telegesis dongle initialize.
2019-08-19 22:31:35.947 [DEBUG] [ding.zigbee.handler.ZigBeeSerialPort] - Connecting to serial port [/dev/ttyUSB0] at 19200 baud, flow control FLOWCONTROL_OUT_NONE.
2019-08-19 22:31:35.950 [ERROR] [ding.zigbee.handler.ZigBeeSerialPort] - Serial Error: Port /dev/ttyUSB0 does not exist.
2019-08-19 22:31:35.951 [ERROR] [ngle.telegesis.ZigBeeDongleTelegesis] - Unable to open Telegesis serial port
2019-08-19 22:31:35.952 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - Network state is updated to OFFLINE
2019-08-19 22:31:35.952 [DEBUG] [.zigbee.internal.NotificationService] - NotificationService is shutdown. Not scheduling com.zsmartsystems.zigbee.ZigBeeNetworkManager$3

It says that the port does not exist, any ideas?

Since you have the same problem as with your other stick. I think the problem is not to look in the bindings or sticks, but on the Raspberry, its power supply, USB cable or the configuration of the Raspberry!

I do not think it makes sense to open this second post because the problem is the same.

The most common reason for the “port does not exist” error is that permissions are not set for the user running openHAB. This prevents the binding opening the port, so the binding assumes it doesn’t exist.

Off topic really, curiosity piqued. How does discovery appear to work if there were no port permissions? I guess there is an “announcement” from a service that does have (at least read) permissions.

I’ve no idea - this is not done directly through the binding. There is a USB discovery bundle somewhere that covers this - I think it works at a lower layer and it might bypass this. It also doesn’t mean that because a device can see a file (or a port in this case) that it can open it (although this may depend on the system).

the other usb actually worked for a while and then stopped working, it’s a different brand so I would say it does make sense

Interesting, how do I change the permissions?

Take a look at the installation docs for openhabian - there is a section there on setting up the serial ports and the permissions.

I found it in the openhabian-config tool and I tried 1 & 3 and it seems to be working (it took a while to become online though(! I’ll do some extensive testing later and probably retest the other USB dongle again.

Terrific! Please change the title of your thread to include [SOLVED] and put a check in the post that helped you find the solution to your issue

Talked to soon :frowning:

It went online

2019-08-20 18:52:05.060 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_telegesis:04000A5E' changed from UNKNOWN to ONLINE

And then after 12 minutes, offline again

2019-08-20 19:04:56.380 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_telegesis:04000A5E' changed from ONLINE to OFFLINE (COMMUNICATION_ERROR)

This is what I see in the debug log:

2019-08-20 19:04:54.157 [DEBUG] [gesis.internal.TelegesisFrameHandler] - TX Telegesis queue: 1
2019-08-20 19:04:55.158 [DEBUG] [gesis.internal.TelegesisFrameHandler] - TX Telegesis queue: 2
2019-08-20 19:04:55.226 [DEBUG] [gesis.internal.TelegesisFrameHandler] - RX Telegesis Data:+N=COO,11,-07,1A9A,2F513C02EF1A045B
2019-08-20 19:04:56.159 [DEBUG] [gesis.internal.TelegesisFrameHandler] - TX Telegesis queue: 3
2019-08-20 19:04:56.157 [DEBUG] [gesis.internal.TelegesisFrameHandler] - TELEGESIS Timer: Timeout 2
2019-08-20 19:04:56.359 [DEBUG] [gesis.internal.TelegesisFrameHandler] - RX Telegesis Data:OK
2019-08-20 19:04:56.360 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - ZigBeeNetworkManager transport state updated to OFFLINE
2019-08-20 19:04:56.362 [DEBUG] [tsystems.zigbee.ZigBeeNetworkManager] - Network state is updated to OFFLINE
2019-08-20 19:04:56.363 [DEBUG] [gesis.internal.TelegesisFrameHandler] - Error: number of retries exceeded [3].

Here I’m adding the full log: (267.0 KB)

This seems to show the dongle stops responding - I can’t really comment more than that. I would say it is possibly a problem with the serial port, but that’s a guess.