I still have this issue! Any news when it will be fixed?

// Martin

I have the same problem. I think that there may be a problem with the java version (32/64?) or missing components since when looking at the logs:

“Caused by: java.lang.ClassNotFoundException: io.netty.handler.ssl.JdkSslContext cannot be found by org.openhab.binding.tellstick_2.5.1”

Maybe someone kind soul could explain what this means and what could be done to sort it out?


I have tested this )and all the released “stable” 2.5.x versions in newly created Docker containers. With the latest (2.5.1) build, I see the following errors:

  • Log file complains that Tellstick core library is not installed.
  • Error seen above, io.netty.handler.ssl.JdkSslContext cannot be found…

I currently run 2.5.0 M3 in my production Docker container, and it works there.

I opened a bug in Github for this, to see if that helps. I cannot imagine the maintainers of OpenHAB having time to look through all of these forums, but at least they probably look through the “bugs” section in the repository.


Tack Ole Kristian,

So … 2.5.0 M3…? .I simply installed the latest Openhabian system image . I guess that then i need to install Raspbian first, install java and then Openhab 2.5.0 M3 ?

Ah, yeah, I guess… With the early 2.5 beta releases of OpenHAB, I simply extracted the 2.4 version of the Tellstick binding, and added that to my 2.5 manually. I will try if that can do the trick here…

How familiar are you with Linux? Some hints on how to install specific milestone builds can be found here: Still possible to install Milestone Builds?

No change in OH 2.5.2 :frowning:

So what is the problem with OpenHab supporting Telldus Tellstick?

To me it looks like Tellldus themselves also are quite uninterested in supporting OpenHab. (Is there a channel to them in this forum?)

Not easy to read but is OpenHab focused on a specific useage or geograpical (non scandinavian) area?


Who is the developer of the binding?

It’s probably some nice guy or group trying their best. I would very much like to contribute myself but at the moment … i understand some of what is going on but unfortunately not enough to really contribute.

But back to my question, are we too few that have Telldus Tellstick Live to bother? or is it a really hard problem. Just that hint could maybe get us going.

My thought is if we could get Telldus to help us or are they not interested? Maybe they “want to rule the world” on their own?

Anyway, how do we get a focus on this issue?

I am not sure that everyone is affected by the error.

Well I am another one affected by the same problem. I’m still running the pre-ZNet Tellstick Net. I did not really bother to upgrade since all my devices are old 433 MHz. Anyhow this might be the reason to skip Tellstick altogether.

The 433 sensors are superior regarding battery consumption… But other then that I agree.

I had the same issue when upgrading to 2.5.2. I though found this post where a link to an updated jar file is provided. I uninstalled the 2.5.2. binding and put the (2.4.0) jar file in my addons folder, restarted OH and now it works again. It’s still a temporary solution but perhaps something to use while waiting for the original binding to work.


1 Like

Hi Per,

So, i

  • removed the bindings from my paper UI and from the addons cfg file.
  • i then went to Y:\openhab2-sys\runtime\system\org\openhab\distro\openhab-addons\ and created a new folder 2.4.0 ,
  • pasted the .jar file for 2.4.0 in the new directory,
  • removed the 2.5.2 directory
  • Rebooted
  • put this: “binding = astro, ntp, tellstick” in the addons.cfg again
  • Added the “Bridge tellstick:telldus-live:2 “Tellstick ZWave” [publicKey=…” in the things file
  • Rebooted
  • Checked config bindings in th Paper UI and there was a Tellstick binding availabe with no version displayed (didn’t add it)
  • Checked config things in the Paper UI and teh tellstic now has the error as usual “UNINITIALIZED - HANDLER_INITIALIZING_ERROR io/netty/handler/ssl/JdkSslContext”

This is what happens if you give the instructions you gave in your post to an “real beginner”, but a positive and brave one :slight_smile:

So…what should i have done?

Appreciate any help a lot!


Sweet thaks for this. It seems to work great!!!

All i did was uninstall the original binding. Then i replaced the org.openhab.binding.tellstick-2.5.2.jar with the one downloaded from here and renamed it to org.openhab.binding.tellstick-2.5.2.jar. Then i just installed the binding again and it worked!! :slight_smile:


Try putting the jar file in the openhab root directory (there should be a folder named addons) and restart. Then configure it either using a .thing file or in the paper UI (add your public and private keys etc)…

I’m not really familiar with the path you provided (Y:\openhab2-sys…)

Thanks Per

I did as you said…but did not work
There is a file called openhab2-addons …(?) …i copied the jar file there and rebooted…no change.

It looks like the 2.5.2 was still there. Manged to remove it after a while. Now i, if i look in Paper-UI.config-things there is no tellstick binding (ok good?). If i go to config bindings i can see Astro (ok) NTP (ok) and Tellstick by Jarle …(?) …as if it was still installed or what?,. if i click “add binding” and scroll down i can see Tellstick 2.5.2 as an installable item but nothing about 2.4.0

B.t.w: If i just put a jar file somewhere just like you propose…will it automaticllay be “installed”?

Played around with configurations and now things started working! …at least i can see my devices and the communication w tellstick live is working. Unfortunately, I have absolutely no clue as to what i did to make it work but (in addition to the above) i removed and added the “bridge” line in a things file, and removed and added “tellstick” in the addons.cfg file, shutdown and started

Thanks for the help! Really appreciated. Do we now know how to make this a part of an official build?

Yes, you don’t have to do an install if you have placed the jar-file in the addons folder.