Tellstick Binding and latest 2.5 UNINITIALIZED - HANDLER_INITIALIZING_ERROR

Sweet thaks for this. It seems to work great!!!

All i did was uninstall the original binding. Then i replaced the org.openhab.binding.tellstick-2.5.2.jar with the one downloaded from here and renamed it to org.openhab.binding.tellstick-2.5.2.jar. Then i just installed the binding again and it worked!! :slight_smile:

2 Likes

Try putting the jar file in the openhab root directory (there should be a folder named addons) and restart. Then configure it either using a .thing file or in the paper UI (add your public and private keys etc)…

I’m not really familiar with the path you provided (Y:\openhab2-sys…)

Thanks Per

I did as you said…but did not work
There is a file called openhab2-addons …(?) …i copied the jar file there and rebooted…no change.

It looks like the 2.5.2 was still there. Manged to remove it after a while. Now i, if i look in Paper-UI.config-things there is no tellstick binding (ok good?). If i go to config bindings i can see Astro (ok) NTP (ok) and Tellstick by Jarle …(?) …as if it was still installed or what?,. if i click “add binding” and scroll down i can see Tellstick 2.5.2 as an installable item but nothing about 2.4.0

B.t.w: If i just put a jar file somewhere just like you propose…will it automaticllay be “installed”?

Played around with configurations and now things started working! …at least i can see my devices and the communication w tellstick live is working. Unfortunately, I have absolutely no clue as to what i did to make it work but (in addition to the above) i removed and added the “bridge” line in a things file, and removed and added “tellstick” in the addons.cfg file, shutdown and started

Thanks for the help! Really appreciated. Do we now know how to make this a part of an official build?

Yes, you don’t have to do an install if you have placed the jar-file in the addons folder.

So did I but I also had to uninstall all Things and Items connected to the Tellstick Live GW. Then all Things appeared in the Paper UI Inbox and I could configure them again. Just a lot of work!

Anyone knows if Telldus Live works with openhab 3?

  • Its listed as avaliable binding but I get error when installing.
  • I got it to work with OH 2.5 (placing .jar file in addon) and tried the same solution with OH 3, but still get error.

HANDLER_INITIALIZING_ERROR
io/netty/handler/ssl/JdkSslContext

Anyone have working Telldus / Tellstick on OH 3?

Yes I finally got it to work in version 3 but I first had to fix this bug https://github.com/openhab/openhab-addons/issues/7024.
I have a fix in progress, that at least makes it work for me and it is currently in review.

Any chance of posting the compiled jar file?

I added a comment on the PR that includes a link to a compiled jar.

https://github.com/openhab/openhab-addons/pull/9634#issuecomment-753417638

1 Like

Sounds great.
Is it enough to replace the jar file and restart?
I still get the same handler error.

I replaced the jar file in: (tried both the new name, and renamed as the original)
C:\openhab300\userdata\tmp\mvn\org\openhab\addons\bundles\org.openhab.binding.tellstick

Also tried putting it in /addons

When I tested it I first uninstalled the original binding using the main UI.
I then placed the jar file in the openhab/addons directory and restarted OpenHAB.
I could then manually add the Telldus Live Gateway using the main UI.

Just to be clear I still get the “java.lang.UnsatisfiedLinkError: Unable to load library ‘telldus-core’” error but I have always had that error.
The fix only fixes the “java.lang.NoClassDefFoundError: io/netty/handler/ssl/JdkSslContext” error.

Great, thanx :slight_smile: :ok_hand:
I seem to get two of all Telldus things, but got it to work. No visible errors for me.

A million thanks from me as well! I am just in the progress of slowly migrating to 3.0, learning on the way. I will stick to the few Telldus switches I have on my remote site since Telldus Live is an efficient way of getting in touch with them without having a local OH installation.

I made a new installation OH 3.2 with Telldus Live and it works great without any custom adjustments. But I randomly (ca twice a day) following error. Dont know if its something I should care about?

2022-01-15 09:30:16.956 [WARN ] [nal.live.TelldusLiveDeviceController] - TimeoutException error in get
java.util.concurrent.TimeoutException: null
	at java.util.concurrent.CompletableFuture.timedGet(CompletableFuture.java:1886) ~[?:?]
	at java.util.concurrent.CompletableFuture.get(CompletableFuture.java:2021) ~[?:?]
	at org.asynchttpclient.netty.NettyResponseFuture.get(NettyResponseFuture.java:206) ~[?:?]
	at org.openhab.binding.tellstick.internal.live.TelldusLiveDeviceController.innerCallRest(TelldusLiveDeviceController.java:309) ~[?:?]
	at org.openhab.binding.tellstick.internal.live.TelldusLiveDeviceController.callRestMethod(TelldusLiveDeviceController.java:283) ~[?:?]
	at org.openhab.binding.tellstick.internal.live.TelldusLiveBridgeHandler.updateDevices(TelldusLiveBridgeHandler.java:129) ~[?:?]
	at org.openhab.binding.tellstick.internal.live.TelldusLiveBridgeHandler.refreshDeviceList(TelldusLiveBridgeHandler.java:116) ~[?:?]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) [?:?]
	at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:305) [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:305) [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128) [?:?]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628) [?:?]
	at java.lang.Thread.run(Thread.java:834) [?:?]