Temperature offset for HS-FLS100-G2 Floodlight Sensor

I would like to set the temperature offset on a Zwave HS-FLS100-G2 Floodlight Sensor. That is parameter 7 for device ID 0x0C, device Type 0x0201 found here: OpenSmartHouse Z-Wave Device Database This parameter should be an offset of -100 to +100 meaning -10.0C to +10.0C. All good so far.

But I cannot set an offset in the OpenHAB Main UI. I’ve tried with 3.4.2 and now with 4.0M1. I can click up and down to set a positive or negative value, but the moment I click on Save, it resets to 0 and no offset is applied. I tried to directly enter a positive or negative decimal value with the same result. I tried to enter a hex value, but it won’t let me enter the ‘x’ of 0x01.

Any suggestions? It’s probably obvious, but I don’t see a way to get a new value in there…

Hmm, just tried editing in the code tab and possibly that works. I’ll know on the next temperature update. The value seems to be retained. Still the questions why it can’t be changed on the Thing tab?

I’m guessing it could be a validation issue caused by how the parameter is set-up;
You could try setting the UI thing to either 100 or 156 and see if it sticks (could confirm theory/). Oddly the values 101-155 won’t get accepted by the device, even if the UI lets them to be assigned. I think the min should be 0 and the max 255 with a note that the values 101-155 are not allowed.

Edit: Here’s another theory (I do not see the limits in the XML, so maybe it not that). The parameter does not have a 1 byte size, so maybe 0 is all it can do?

I had it set to 195 via the code tab. Then I tried 156 in the GUI, hit save, and it bounced back to 195. Then I entered 100, hit save, and it went to 0. But the event log didn’t show any activity for either of these, so I think nothing went out.

When I tried 195 earlier in the code tab, I saw online/offline and offline/online messages in the event log. However, it did not appear to change the reported temperature.

I think that leans toward the missing byte parameter, but I’d suggest making both changes to the db entry just to be safe.

I have seen (particularly with the controller) that changes to code tab cause a restart of the device. You might be able to check to see if there is an updated XML in the zwave folder after editing the code tab, but since it is not changing anything, I think it is the zero-byte size configuration of the parameter.

I requested the changes in the database. I do not see the xml getting updated. Here’s what I see for that parameter despite the code tab saying 195:



That snippet shows the parameter is one byte, but the binding xml showed 0 bytes? For testing you could modify the jar while waiting for the db update. Also I was wondering if using the pc controller to send the parameter might be something to try.

This issue is solved with the database update. I can successfully set the offset.