Temperature Reading Errors on Aoetec Z-Wave Sensor

This has been going on for quite a while and over a number of versions of openHAB. Currently running on 2.5.0 Release Build. Not sure if this is showing up now due to the heat here in Oz.
Z-Wave Stick = Aoetec Gen 5

2019-12-31 15:08:34.108 [vent.ItemStateChangedEvent] - KitchenMultisensor_SensorTemperature changed from 31.9 °C to 3E+1 °C


I have these entries also, but 3E+1 means just 3x10^1 which is 30 °C.
So I am sure this is not an error.


That’s a curiousity, isn’t it? I wonder what causes the difference in the logged format. In both cases, the number will be held as BigDecimal, so it’s just a format-to-string oddity. Noting that 30.00000 is actually stored differently from 30 or 30.0, I expect that it’s something to do with that, the way it gets updated by binding.
Might be specific to QuantityType (with units)

Hi @chris4789
Yes, this is probably what it means but it does mean I need to add a rule to convert it vs other readings back from the sensor. I also did try this within NodeRed but never worked.

Rather have the binding just return a full decimal value. I do appreciate that most do not have to deal with temperatures like this but I do have to. 30C+ is not unusual for us done here.


Why, what are you doing with it in a rule? Comparisons etc. should function just the same.
Or do you mean it displays in E style in your UI?
What display format have you specified (in Item label, or sitemap)?

Why? 3E1 is the same as 30 - it’s just a different format. You should simply be able to configure the formatting in your item.


Just out of curiosity and to confirm your theory, following item entry

Number:Temperature ThermostatSollDevoloLENI "HK LENI Solltemp [%.1f °C]" {channel="zwave:device:Razberry2:node10:thermostat_setpoint_heating"}

leads to a log entry:

ThermostatSollDevoloLENI changed from 2E+1 °C to 16.0 °C


Number ThermostatSollDevoloMax "HK MAX Solltemp [%.1f °C]" {channel="zwave:device:Razberry2:node8:thermostat_setpoint_heating"}


ThermostatSollDevoloMax changed from 20 to 16.0
1 Like

Are these log entries? They will not be formatted using the format you specify - I think they are formatted simply using the toString method in Java.

One of these is a QantityType (it has the °C) and the other is probably a plain Number - that’s likely why they are formatting differently here.

What is important is what is displayed in the UI - not the log file. The number is still the same and it’s just a presentation issue.


Hi @chris
The first entry was from my openHab logs so I’m thinking that removes the issue of pulling them from the nodeRed node as it is only getting the value stored by openHab. That leaves the question as to why OpenHab is showing temperatures in certain ways.

I’m going to step very gently here as @chris has done an amazing job of the Zwave interface and there have been alot of issues with the upgrade to 2.5 which he has done a very diligent on fixing.

I can confirm that this issue is way back in time and I just adjusted to it. As we are now on a stable release and well it’s hot down under I thought time to ask.

Some have suggested a conversion issue which I can understand. However to be a stable consumer platform we need to move beyond temp below 30c being in one format and above being in another format.

Back to Chris.
Let me find at time when it occurs again and I’ll send over the logs and take your guidance on log levels. Now is a good time as temps here are well above 30c each day.


It’s as I said above -:

This is only the log file you’re looking at - it doesn’t matter. What matters is the UI and this should use the formatting that you specify in your item.

Again, this is only the logging - forget about it. What matters is what shows in your user interface.