Tesla Powerwall 2 Integration

Hi - you need an installer logon to change mode/reserve with the local api. I have a version mostly working that uses the tesla web api - based on the Tesla vehicle binding, but haven’t gotten around to adding code to change mode/reserve yet.

Too many projects, not enough time!

1 Like

I know what you mean. I’ve noticed my app changes take effect nearly instantaneously (at least for now) so I’ll anxiously await you checking that box off the list.

(This is why I was at first using the web password in the thing- I noticed you mentioned this and had hoped :grimacing:)

Well the original plan was to support changing reserver, etc in this binding, but as I got further into investigating what was required, it all just got too hard - plus I don’t need the functionality myself, so I got distracted onto other projects :slight_smile:

Boo Sad to hear that. Did you get operating mode change at all? I would love to have that. Sadly not so many of us have the powerwalls yet so I see there is very little documentation relating to the api for it / no real tools out there like there are for the cars.

Just in case anyone here is also looking for powerwall control over the web API I just wanted to put a placeholder that I found a developed version of this for Smartthings or Hubitat hubs. Link attached for easy reference. (I use OH code for real-time polling every few seconds and his for issuing commands - his doesn’t currently allow independent polling of web vs local and also doesn’t authenticate to the local gateway for the extra mode info allowed that way.)

@Paul_Smedley thanks for your work on the binding but I cannot seem to make it work and the link to the source on github does not work anymore. I am running Openhab 2.5.6 on docker using a RPI and have been for a number of years and have many configurations and setup (so sort of familiar with openhab, but always learning). I copied in the JAR file and caraf shows

280 │ Active │ 80 │ │ org.openhab.binding.teslapowerwall

I then restarted the docker container (generally I use caraf system:shutdown) Upon reboot I see nothing at all in the logs - in paperui I can see the binding is loaded but there is no configuration options, nor any ability to add things etc. I enabled logging to TRACE but still nothing seems to be happening. I am unclear if I need to configure anything in any configuration files etc so looking for any level of help that can be offered. I have or already had installed http, exec and the json translation bindings.

EDIT ADDITIONAL: I went the approach to manually configure the cert, http.cfg and items and can report that it is now working but nothing ever came of the binding.

For those with docker this helped me install the certificate [SOLVED] How can I use http binding with a https site and openhab docker?

Hi @itbeyond you need to add the powerwall manually - there is no autodetection code (yet)

Hey Paul - curious if you planned to make this binding compatible with OH 3 or is it already?


HI - I haven’t tested with OH 3 yet - but will do at some point in time. I’m busy on other non-OH projects rights now

OK following up on this - the binding will need to be rebuilt for OH3…

1 Like

Untested - I’ll try and test this evening - but https://smedley.id.au/tmp/org.openhab.binding.teslapowerwall-3.0.0-SNAPSHOT.jar will hopefully with with OH3

Edit: I tested at one of my sites today, and the rebuilt module seems to work fine with OH3

1 Like

as soon as get my test OH 3 pi set up I’ll give this a try. Thank you!!

EDIT: it looks like your link doesn’t let me download the file. Getting file not found error.

Oops I made a typo in the link - should be good now. I’ve moved both my installs across to OH3 and using this binding - all seems good so far :slight_smile:

1 Like

as soon as I get openhabian to play nice with installing 3.0 I should be good to go. I probably should have just done a bare ubuntu install but I like the sdcard optimizations built in with openhabian

Edit: after yet another freeze / failure - direct to ubuntu I go. Had it up in moments last time. Not sure what is going on with openhabian:/

1 Like

looks like it worked just fine for me as well. Thank you!

1 Like

Looks like things went a bit haywire on 3RC1 - just updated and my powerwall thing is stuck in ‘initializing’

Yep, hadn’t noticed that when I updated last night. I’ll investigate this evening - hopefully it’s as simple as updating git and rebuilding.



1 Like

OK build is updated - same link as before - https://smedley.id.au/tmp/org.openhab.binding.teslapowerwall-3.0.0-SNAPSHOT.jar

The breaking change was https://github.com/openhab/openhab-addons/commit/ac6f08908fe3123d664cc41037880f4d33b8cf64

1 Like

Sorry for the question, but how to install the *.jar?

Thanks again Paul - much appreciated re v3 upgrade

1 Like