Testing Z-Wave binding on openHAB-2

Same here, after some time of running (ca. 15 min.) without problems the Z-Wave Binding is looping as reported by @shorty707 :confused: Hope you can find the cause @chris :wink:

Hopefully tonight - it’s linked to polling…

a question about:
Remove device from controller…

this is available for initialized and working items

I do however have some items which I just resettet on the device itself and made a new inclusion.
these now get listed as “new devices” with their old (obsolete) node id in the inbox at every startup.
for these devices that option to “remove device from controller” in advanced mode is not visisble. Is that possible somehow?

Can you raise an issue on this one please?

since (I think) the last zwave binding update all my things have the controller as associated group
that was blank before… just if that information might me related to something

Good - something is better then :slight_smile:

I’ve uploaded a new test binding to the [HABmin repo] (https://github.com/cdjackson/HABmin2/tree/master/output).

Hi,

I am having trouble making this binding work. It simply does not start, in the logs there is nothing after the message that the binding is installed (even when debug is on), but it gets listed in active bundles.

also tried copying in the addons folder (also the latest built) or installing through paper ui.

it works ok with 1.9 though.

any suggestion why?

The problem sounds like dependency issues. The easiest way is to start with paper UI as this should manage the dependencies. It’s also a good idea to check in the karaf console to see what bindings are really running.

I looks like it’s bouncing between 2 values every 2 seconds, I could not explain that :slight_smile:

2016-03-15 23:12:35.765 [INFO ] [marthome.event.ItemStateChangedEvent] - zwave_device_1537b28fd20_node9_color_color changed from 240,100,20 to 240,100,100
2016-03-15 23:12:35.814 [INFO ] [marthome.event.ItemStateChangedEvent] - zwave_device_1537b28fd20_node9_color_color changed from 240,100,100 to 240,100,20
2016-03-15 23:12:37.574 [INFO ] [marthome.event.ItemStateChangedEvent] - zwave_device_1537b28fd20_node9_color_color changed from 240,100,20 to 240,100,100
2016-03-15 23:12:37.628 [INFO ] [marthome.event.ItemStateChangedEvent] - zwave_device_1537b28fd20_node9_color_color changed from 240,100,100 to 240,100,20
2016-03-15 23:12:39.385 [INFO ] [marthome.event.ItemStateChangedEvent] - zwave_device_1537b28fd20_node9_color_color changed from 240,100,20 to 240,100,100
2016-03-15 23:12:39.439 [INFO ] [marthome.event.ItemStateChangedEvent] - zwave_device_1537b28fd20_node9_color_color changed from 240,100,100 to 240,100,20

Good point - I wasn’t looking at the event reports…

Can you provide a short debug log? I suspect the 2 second update was caused by the polling problem, so that might be fixed now, but presumably it’s still flicking back and forward…

Just a reminder… You need to make sure you are running the latest version of OH2 with the latest binding since we fixed a few problems in ESH earlier in the week, and the latest binding needs this…

I have tried installing though paper ui, and the console says the binging is active:

177 | Active | 80 | 2.0.0.201603162056 | ZWave Binding

but it is not working.

Please provide some information on what isn’t working!

There is no trace in the log that the biding starts or active, and none of the sensors/switches are working.

I don’t see it anymore, but I’ll keep an eye out, thanks!

It won’t happen very often now - part of the problem was the bug in the polling period which is fixed, but it should still happen (I guess!) when polling occurs (every 30 minutes maybe?).

Actually, I don’t see any polling debug messages anymore…

It looks like it should default to 30 minutes if it’s not set, and 2 hours is the maximum so if there’s a bad setting, it could end up there… Have you tried resetting the period - I’ll check to see if there’s anything I can spot, but I’m definately seeing polling in my logs.

Sorry, was my bad, polling loox fine :sweat_smile: