Testing Z-Wave binding on openHAB-2

Yes, sorry for the edits, I got confused with node number… :slight_smile: They are minus one in UI as opposed to the debug log.
Anyway, this is a test network on my desktop with a few devices that I had laying around. Only about two meters between them. But I guess the greenwave could be broken. I never had OH1 running, it came directly from my house network (vera), but it has not been actively used for some months.

Maybe I’m overanalysing the logs.

I also get, on my 4 node “Transacation not completed: node address inconsistent.” Maybe it is the greenwave that messes up everything.
I will disconnect it for now, and concentrate on the other devices.

@chris, I started clean again, and when I click node 4’s wake up button, it is showing node 11. This stick was recently reset and has only 3 nodes on it, 2, 3, 4. This is the 2035 jar

This is perfectly normal. It happens whenever a device sends a message unsolicited, and it just means that the received message doesn’t complete the previous transaction…

Hi Jim,
Are you using discovery at all? I don’t thin discovery is being enabled other than when it’s manually enabled, but I might be wrong. Otherwise I’m not sure why the node should be advancing… Do you see anything in the log about discovery?

Chris

So if I do it through HabMin, it creates loads of junk Items, one for each channel and a group. That’s fine, I can then go and delete them all and link my own. The problem came that then all the labels would disappear and I then wouldn’t be able to add my own. It was a bit strange.

Creating them directly through PaperUI kept the ability to change the label. A strange little bug that I’m sure will get ironed out.

All these APIs are changing at the moment so things are a bit mixed up. I guess PaperUI has already changed - I should take a look to see if the issue with thing labels has been addressed - if it has I’ll change HABmin to also use the API that doesn’t create the items…

Yeah I know things will change, just flagging it.
One usability thing, I’ve realised I now don’t have polling enabled. Should this be part of the “thing” or the item"? Currently I thought items were now a lot more sparse as you only need it to exist and then link it to a thing for functionality. So one of mine is just:

Dimmer light_nursery2 "Nursery - Lamp" (lights)

So then it’s linked to a thing and is fully capable, no need to add {zwave=id} etc…
But should I add the refresh_interval here like this?

Dimmer light_nursery2 "Nursery - Lamp" (lights) {refresh_interval=300}

Is that the way we should be doing it now?
Thanks
Christian

Correct. After I start up, set the port and restart, I get the normal binding messages in the log stating it knows nodes 1-4, which is great. They don’t appear yet in the Inbox yet though, so I kick off a manual discovery. This particular time, it did not discover any devices (they are all battery), so I force one to come live by pressing the button on the device. This is where the node 11 thing happened. After restarting again, I cannot get node4 to wake up the same way, so perhaps it is a device anomaly. I will keep trying to reproduce it and let you know if I see it again.

I wasn’t aware you could define items configuration like this but for sure, refresh_interval won’t work since it’s not supported.

Currently polling is enabled on all channels at 60 second interval. Once channel config is supported in HABmin then I’ll add it as a config option.

@xsnrg I’m not sure why this would happen - unless the binding has gone into discovery/inclusion mode it shouldn’t be able to change device IDs.

Were some entries removed from the database? I tried the binding a couple of days ago and it picked up my Aeontec MultiSensor 6 but today I’ve tried it and it doesn’t want to identify it.

We went through and renamed all the Aeon devices to make them consistent (ie to use model numbers rather than names which was confusing)…

Anyway, yes, it looks like this wasn’t re-published, so it’s not in the database. I’ll put it back in in a few minutes…

Cheers. Was beginning to think there was something wrong with my comprehension of basic instructions! :grin:

No - just the ever changing world of test software :wink:.

We thought it was better to clean it up before too many people started to use it - I should have posted that it had changed - sorry…

Hopefully it’s back now (if I got the right devices) - if not, please yell (again :slightly_smiling:).

duh… you are right
but in Addons I have only the correct one… so there must be a caching of the old bindings… somewhere

173 | Active | 80 | 2.0.0.201602141415 | ZWave Binding
193 | Installed | 80 | 2.0.0.201602151850 | ZWave Binding
197 | Installed | 80 | 2.0.0.201602152328 | ZWave Binding

bundle:uninstall did it now

for my question above… what happens to an “unknow device” after it was compiled to the jar at a later time

–> it stays unknow --> I did delete it from Habmin …Thats pobably not an exclusion but just kicking them out?

  1. NON battery device was without any ado popping up as new device and was added as same node
  2. battery powered device needed be put into inclusion again and was popping up again then in habmin at the same node

If you delete a thing, it doesn’t change anything on the stick - if you immediately enable discovery it will be added back to the inbox and you can add it as a thing again.

Battery devices work the same but with the current binding a device won’t be ‘discovered’ (by which I mean it shows up in openhab) until certain phases of the initialisation are complete. For battery devices this could mean that the device needs to be woken up once or twice.

You don’t need to go into inclusion mode again to add things.

Chris

Hi Chris,

I have an OH2 installation here and I’m testing your binding. Works wonderful so far.
3 of my devices are recognized and working fine. The other 6 devices aren’t supportet yet, I guess.
I have the .XML-files of 4 of these devices here, so I will upload them to my OneDrive and post the link here: http://1drv.ms/1QiUmzy

Node 2 is an Everspring AN158 Smart Plug - http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/27
Node 5 is a Fibaro FIB_FGMS-001 Multi Sensor - http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/115
Node 6 is a PSR04 Smart Color Button/ Dimmer/ Timer - Not found in your DB
Node 8 is a Fibaro FGD-212 Dimmer - http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/133

I also have a Fibaro FGRM-222 Roller Shutter ( http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/116) and an Aeotec Micro Switch G2 (2nd Edition) ( http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/82) here. One of these devices has to be Node 1 I think and Node 3 (the last without working Device) has no XML-File generated.

I hope these files will help.

Greetings
Marvin

I got another XML

since this is a little special device I post it here to be sure it doesnt harm the DB …

Its the Nodon (NODECRC3100) Controller.

This has so many modes (single, gateway, solo, duo, whatever) how it can be used I am not sure if all this ends in the same XML… I added it in Gateway mode …
the XML is uploaded to the DB … I hope thats ok.

node8.xml (4.1 KB)

also by adding this device I got some more questions: (It took about 20 trys until it was generating the Node.xml)

  1. Even the XML was generated (and I could see the inclusion was confirmed by a blinking green light on the Nodon)…
    still the Device is not visible as (unknown) device in Habmin … as if it was not included???
    edit: ! after refreshing habmin it did popup as new device to add … its now there as unknown :slightly_smiling:

  2. It was generated as Node8 … I never has Node 4,5,6,7 … why does it skip some numbers?

thanks @chris

Ok - thanks for clearing up

Hopefully a quick question…

With ZWave 1.x I’d previously bound the motion sensor to a Contact item using the following: {zwave="4:command=sensor_binary,respond_to_basic=true"}

Now with ZWave2.0 the database suggests that the item should be a Switch. As the motion sensor alarm isn’t something I can turn on or off (and therefore doesn’t make sense to have as a Switch) is there a way to have it as a Contact item?