Text-to-Speech with OpenHab in Docker and LMS sink

Tags: #<Tag:0x00007efecf51a778> #<Tag:0x00007efecf51a6b0>

OpenHab and LMS are running in to seperate dockers in the same network.
However TextToSpeech gives me an error on the LMS side:

Slim::Utils::Scanner::Remote::__ANON__ (193) Error: Can't connect to remote server to retrieve playlist for, http://172.18.0.8:8080/audio/845244ad-1113-4d6f-a45d-d3f8ebf1c4cd.mp3: 404 Not Found.

The IP (172.18.0.8) for OpenHab is correct however LMS can’t find the needed file.
And shouldn’t it be https://172.18.0.8:8080/audio/845244ad-1113-4d6f-a45d-d3f8ebf1c4cd.mp3
instead of just http?
How could I change the http to https so I can test this?

EDIT:
And why can I not acces the file when I replace the IP with the real outside the Docker IP?

HTTP ERROR 404
Problem accessing /audio/845244ad-1113-4d6f-a45d-d3f8ebf1c4cd.mp3. Reason:

Not Found

There are not many of us who run OH in Docker. There are many fewer of us who run it using TTS. what ever is wrong here is going to be a networking issue between the containers. You might get better support on a Docker container.

But I can say the following:

  • Port 8080 is the HTTP port. For HTTPS you need to use port 8443.

  • If you haven’t configure the container to use --net=host or exported and mapped the ports in your docker run command, openHAB is no accessible outside the docker container network.

I feared that almost no one uses OH in a Docker…
But should I be able to access the file by copy the URL to the Webbrowser?
If so then the problem would lay by the OH network config.

I think it has something to do with the proxy. The LMS will receive the URL form OH and does it send the URL directly to the Player so that the player needs to access the stream by himself or will it stream the content to the player?

Try configuring the callbackUrl to the external IP of your openHAB server as outlined in the documentation:

I think this might be the solution butt sorry I have to ask…
I searched now for a whole hour but can’t figure out how to set the callbackUrl parameter. I can’t find any Option to set this…

I might found a Bug or the Problem:
I’ve saw the the KODI binding has also a callback url and this can be set by clicking the pen Icon see Image.
However the Squeezbox Binding has no such Icon although in the Binding.xml it is mentioned like in the Kodi binding.xml…

Maybe it’s not yet available in your version? It got added in 2.5.0:

hmm I only got 2.4
How do I get the new version? I use docker and it seems up to date…

image

Add a tag to the Docker image name e.g.: openhab/openhab:2.5.0.M4

Yep in 2.5.0.M4 the CallbackURL option is available and when set it works with my system!!!

So of course my last question is when the 2.5 stable version will be released?

1 Like

Great! :slight_smile: The final 2.5.0 release is scheduled for December.

Awesome great news. Will wait then for the final release but its great that this CallbackURL is working!

1 Like