The most basic tutorial?

Just installed openHAB 2 on a Pi3 and it’s all up and running no problem :slight_smile:
Connected to the GUI remotely and added my hue lights as “things”.
That’s as far as I can get, checked the “documentation”, but it’s either non-existent or massively over-complicated talking about item syntaxes etc for some reason - useless information as it isn’t in context whatsoever.
Surely there must be some kind of documentation out there which will at least show how to turn a light bulb on and off!!

Someone please point me in the right direction.
Thanks in advance,
Wayne

Sure there is:
http://docs.openhab.org/addons/bindings/hue/readme.html

Thanks Sihui,
That’s great.
I should have been more specific though, I can’t figure out how to even create some kind of control element, never mind link it to a light, and can’t find any documentation showing how to.
In the “Paper UI” there is a “Control” section, surely thats where control elements would go? I’ve no idea how to add them and can’t find documentation to show me.
:-/

Scroll down to the bottom of my link: there you have a complete set of config files: things, items, sitemaps.

If you need to know more about items:
http://docs.openhab.org/configuration/items.html

More about sitemaps:
http://docs.openhab.org/configuration/sitemaps.html

More about things:
http://docs.openhab.org/concepts/things.html

Be aware that this is not an off the shelf solution where you just flip a switch and it works (but works very limited), you have to invest some time and reading to get it going.

Have fun.

Also, if you are a beginner, try the demo setup:

http://docs.openhab.org/tutorials/demo.html

Thanks again Sihui,
I should have tried the demo instead of selecting “basic install”, I’ll see if I can still install it.
I think what’s confused me a lot is this paper ui thing, I should have just ignored that, as there’s no documentation for it yet.
I’ll edit my sitemap file and use the examples from your link and see how it goes :slight_smile:

Go to /userdata/etc/org.openhab.addons.cfg and edit
package = standard to
package = demo, then restart openHAB -> never tried that but should work.

http://docs.openhab.org/configuration/paperui.html

http://docs.openhab.org/addons/uis/paper/readme.html

Hmm my Hue lights are currently shown in the Paper UI - Configuration - Things, however there is no files in <openhab_config>/things folder (besides the readme.txt file)
Why? Is it not saving for some reason?

Ok I should have said “very limited documentation for it”.
Paper UI has found and added my Hue stuff, yet did not create .things files. I have to do that myself, so what is the point in it?

Ok so I try to ignore Paper UI, and create my own files, since Paper UI can’t do it for me; right away I’m stuck with the .things file, as I need the generated username for my hub.

The documentation states:
“A user to authenticate against the Hue bridge is automatically generated. Please note that the generated user name cannot be written automatically to the .thing file, and has to be set manually. The generated user name can be found in the log files after pressing the authentication button on the bridge.”

What log file? I can’t find it. I already did the authentication when discovering the hub via Paper UI.

Anyone have any recommendations on initial set-ups? Can it be done partially via UI or is that a bad idea?

Things and Items can be defined in two places:
1.) The database (MapDB or JSON depending on your version)
2.) The config files

When you make changes to items from the UI, those changes are persisted to the database.

In order to ask the right question, you will first need to have a reasonable (not perfect) understanding of how the system works.

I started by reading docs.openhab.org from start to finish and then jumped to the form, I suggest you do the same. The form can be confusing since there are two versions, but you’ll eventually get the hang of it.

Don’t give up on it, this is the most capable HA software you can find and it’s worth the effort

  • my $0.02

Thanks that explains why I can’t find the generated .things file!

It’s probably talking about he event log, you can read more about it here docs.openhab.org/administration/logging.html

Ahh yes.
I checked the JSON files, and sure enough, my hub was automatically added correctly in there, along with username etc.
(documentation said it would have to be done manually - maybe it’s outdated)

Was trying to create items via the UI but can’t seem to link them to things so I’ll try via text files.
edit: Ah now I can link! Must have been doing something different/wrong before. Now controls appear and work in the “control” section. Great.

I just want to see some kind of results before I invest too much time, as I’m also considering indigodomo (OS X HA server)

Thanks kdub454 :slight_smile:

edited for spelling and other stuff