The "new" Milight IBox and milight binding

I ran this in karaf. This was right after I updated to 2.2. I’m no computer wiz so I’m not sure what negative effects this would have but it stopped the flood of milight updates in the log.

log:set ERROR smarthome.event.ThingUpdatedEvent

1 Like

@David_Graeff it is possible use ONE Milight bridge to control 16 groups
“Note that you can assign an rgbw, rgbww, white and dimmer group to the same group number, effectively allowing 16 groups (4 rgbww, 4 rgbw, 4 white and 4 dimmer) per bridge.”
so could you update openhab bindings to support this? this is about milight bridge produced after July 2017

The hardware supports only 4 groups afaik. The new bridge doesn’t even support old bulbs, does it.

Thank you for reply. Why this THING

Bridge milight:bridgeV6:F0FE6B17E890 “iBox Bridge” [ ADDR=“”, ID=“F0FE6B17E890”, CUSTOM_PORT=5987, REFRESH_IN_SEC=20] {

produces (auto discovery)10 inbox entries = 4 rgbw (zone1,zone2,zone3,zone4) + 4 rgbww (zone1,zone2,zone3,zone4) + 1 all zones rgbw + 1 all zones rgbww
Could I use 8 groups then?

You need to specify your bulb type because they expect different commands. Those two bulbs types still belong to group 1 to 4. Milight doesn’t support a proper discovery, that’s why you are presented with all possible types.

Somehow I am having troubles with the detection of the IBox1. It just won’t discover it and when adding it manually it gives me an error 500 in PaperUI. I made a post here. Can anyone give advice?

Nobody has problems with {channel=“milight:rgbwLed:bridge:1:animation_speed_relative”,autoupdate=“false”}
on rgbw strip
i’ve checked several times for errors in my OH configuration and seems everything ok.
the issue is that in binding only decrease animation speed works, but it is impossible for me to increase it.
in Karaf consolle, in debug mode filtered on Milight binding, i discovered that no packet are sent to gateway only sending increase command on animation_speed_relative.
in all other strip functions everything works fine
thanks for any help


Sounds like a bug to me. Would you please open a bug report on GitHub to track this issue?

Cheers, David


i trying to add mi light box to openhab it won’t show up automagically like the old one

i tripe the ip and id in from box but does not work it does error id not long

before i did openhab on computers with old bridge i install the image of openhab image on raspberry pi

and it picks it up i trying do it on raspberry pi auto openhab image is there a different setting on the new bridge ibox any help would be good

Hey Oliver,

If I remember correctly, I had to “manually” search for the iBox/iBox 2 Bridge in OpenHab via PaperUI, then it would auto discover all of the zones after that.

When I manually added it, I had already configured my router to give it a static internal IP, so that OpenHAB would not have to look for it. So I entered that IP, then entered the MAC address of the Bridge as the “Bridge ID”. Bear in mind that this field requires no delimiter, so should just be a string of 12 characters with no colons.

Also, when manually adding, be sure to select the correct type of bridge. The iBox is the one that is a small dome with built in LED, while the older milight bridge is thinnish rectangular box with a label.

Hopefully that helps!

1 Like

i try putting in manually it say offline can it pick it up automatically and it did say the id not long do i have to change a setting on ibox

What does the exact error say?

You mention “id not long” - are you referring to the Bridge ID? It should be a string of 12 alphanumeric characters. I cannot remember if the MAC address is printed on the iBox itself, but if you connect directly to its IP address and login using admin as user and pass, you will find the MAC address listed on the main page.

If you do login to the iBox, double check the Port ID under the “Other Setting” tab and let me know what it says.

i will turn in on openhab tooromow and try it and let you know and will it find it automagic like the old bridge or do i have to add it again

I don’t believe mine found automatically found it. If I recall correctly, I had to manually configure mine. But once I had completed steps like I said before, it has worked flawlessly. Once it connects to bridge, you will automatically see all zones and options in auto-discover inbox in PaperUI.

I got mine working by change the port in mi light still add to add it but I need to do Alexa next

what does is this changed from UNINITIALIZED to UNINITIALIZED (BRIDGE_UNINITIALIZED) It when office and I add it again and it works it does when you charge the bridge setting or put on the other raspberry pi

I like the old bridge because it does automatic without tripping its in but this does work

from Oliver

I may be wrong, but generally when a bridge is “uninitialized”, openHAB may be having a hard time keeping the connection to the bridge.

I would double check that your iBox is using a static IP and that static is in the Paper settings. I would also double check that the you set it to is not being utilized by something else. Probably stick with the default options. Mine uses 8899.

The other thing to check is the “Keep Alive Interval” in the bridge settings. If the value is too high, then the connection can drop. I have mine set at “5”, which I believe is default.

Beyond that, we may have to have @David_Graeff 's input. He is the man when it comes to this :slight_smile:

Thank you for I will check that tonight or torromow and hope to all of our I lights on it does work but I will check that and come back to you and other guy if I need more help I will let you know if I got all you should be able to turn off the pi and back on it does keep it a bit and other you have keep adding it so I will have to that

Thank you

hi what type is the server mode on ibox

The Milight bridges (old and new) respond to specific network packets.
That is how auto discovery is implemented.

For the old bridges this response is also used as a “heart-beat” to know if a bridge is still online.

The new bridges require to establish a “network session” with their own heart-beat function. That means,
the bridge can still work in OpenHAB even if the auto-discovery failed (probably because the receiving port is blocked by a firewall).

Unlike many suggested, the Milight bridge does not need a static IP. The binding figures out if the bridge IP changed and re-establish a new session. Unfortunately there is still a bug in the binding that I couldn’t find time to resolve yet. Every time a new session is established (which happens automatically after a day or so), the old session was kept as well. After a certain time the bridge is bombarded by network packets from all those active sessions and will eventually fail.

I really hope I can find some time for this issue.

Cheers, David