The "new" Milight IBox and milight binding

milight
binding
Tags: #<Tag:0x00007f0146cc1570> #<Tag:0x00007f0146cc1318>

(DSN) #284

Hi everybody,

first thanks for the great work with this binding, its amazing.

The only thing that i cant get to run is the disco mode. I read about the issues with the whitemode or the nightmode
but is there also a problem with the discomode?

Each time i send an number to my animation mode item, the only reaction from my bulbs is to reduce the brightness.

Hope anyone could help me, thanks for your answers!


(Lorenzo Giordano) #285

Hi Ramasouto,
I have the same problem after update at 2.3.0 … I tried to reload the 2.0 binding but whitemode doesn’t work.
I read the ESP8266 bridge but I don’t understand how can the whitemode be solved.
Can you share your solution?
Thanks
Lorenzo


(Stolly82) #286

Hey,

now I have the same issue!

[nal.protocol.MilightV6SessionManager] - Bridge reports an invalid command: xx

It´s with stable 2.2.0 and 2.3.0.


(furax54) #287

I open an issue for the log flood : https://github.com/openhab/openhab2-addons/issues/3046


(Licht77) #288

There is a fix in github…


(Peter) #289

Where?


(Tertius Hyman) #290

Please provide a link to this fix. Thank you!


(Martin Zorn) #291

Hi Rob & Ramiro,
how did you do that? Where can I download / install that org.openhab.binding.milight_2.1.0.ref-rc11?
Thanks in advance…


(Peter) #293

Ok, where can i find a solution? My logs are full of these.
Found noting in the docs. pls help


(Jeff McCusker) #294

I ran this in karaf. This was right after I updated to 2.2. I’m no computer wiz so I’m not sure what negative effects this would have but it stopped the flood of milight updates in the log.

log:set ERROR smarthome.event.ThingUpdatedEvent


(Roberto2) #295

@David_Graeff it is possible use ONE Milight bridge to control 16 groups
“Note that you can assign an rgbw, rgbww, white and dimmer group to the same group number, effectively allowing 16 groups (4 rgbww, 4 rgbw, 4 white and 4 dimmer) per bridge.”
so could you update openhab bindings to support this? this is about milight bridge produced after July 2017


(David Graeff) #296

The hardware supports only 4 groups afaik. The new bridge doesn’t even support old bulbs, does it.


(Roberto2) #297

Thank you for reply. Why this THING

Bridge milight:bridgeV6:F0FE6B17E890 “iBox Bridge” [ ADDR=“10.10.100.200”, ID=“F0FE6B17E890”, CUSTOM_PORT=5987, REFRESH_IN_SEC=20] {

}
produces (auto discovery)10 inbox entries = 4 rgbw (zone1,zone2,zone3,zone4) + 4 rgbww (zone1,zone2,zone3,zone4) + 1 all zones rgbw + 1 all zones rgbww
Could I use 8 groups then?


(David Graeff) #298

You need to specify your bulb type because they expect different commands. Those two bulbs types still belong to group 1 to 4. Milight doesn’t support a proper discovery, that’s why you are presented with all possible types.


(w) #299

Somehow I am having troubles with the detection of the IBox1. It just won’t discover it and when adding it manually it gives me an error 500 in PaperUI. I made a post here. Can anyone give advice?


(Andrea_Pic) #300

Hi,
Nobody has problems with {channel=“milight:rgbwLed:bridge:1:animation_speed_relative”,autoupdate=“false”}
?
on rgbw strip
i’ve checked several times for errors in my OH configuration and seems everything ok.
the issue is that in binding only decrease animation speed works, but it is impossible for me to increase it.
in Karaf consolle, in debug mode filtered on Milight binding, i discovered that no packet are sent to gateway only sending increase command on animation_speed_relative.
in all other strip functions everything works fine
thanks for any help

Andrea


(David Graeff) #301

Sounds like a bug to me. Would you please open a bug report on GitHub to track this issue?

Cheers, David


(Oliver) #302

hi

i trying to add mi light box to openhab it won’t show up automagically like the old one

i tripe the ip and id in from box but does not work it does error id not long

before i did openhab on computers with old bridge i install the image of openhab image on raspberry pi

and it picks it up i trying do it on raspberry pi auto openhab image is there a different setting on the new bridge ibox any help would be good


(John McMillan) #303

Hey Oliver,

If I remember correctly, I had to “manually” search for the iBox/iBox 2 Bridge in OpenHab via PaperUI, then it would auto discover all of the zones after that.

When I manually added it, I had already configured my router to give it a static internal IP, so that OpenHAB would not have to look for it. So I entered that IP, then entered the MAC address of the Bridge as the “Bridge ID”. Bear in mind that this field requires no delimiter, so should just be a string of 12 characters with no colons.

Also, when manually adding, be sure to select the correct type of bridge. The iBox is the one that is a small dome with built in LED, while the older milight bridge is thinnish rectangular box with a label.

Hopefully that helps!
John


(Oliver) #304

i try putting in manually it say offline can it pick it up automatically and it did say the id not long do i have to change a setting on ibox