The "new" Milight IBox and milight binding

milight
binding
Tags: #<Tag:0x00007f014cef7fa0> #<Tag:0x00007f014cef7cf8>

(John McMillan) #305

What does the exact error say?

You mention “id not long” - are you referring to the Bridge ID? It should be a string of 12 alphanumeric characters. I cannot remember if the MAC address is printed on the iBox itself, but if you connect directly to its IP address and login using admin as user and pass, you will find the MAC address listed on the main page.

If you do login to the iBox, double check the Port ID under the “Other Setting” tab and let me know what it says.


(Oliver) #306

i will turn in on openhab tooromow and try it and let you know and will it find it automagic like the old bridge or do i have to add it again


(John McMillan) #307

I don’t believe mine found automatically found it. If I recall correctly, I had to manually configure mine. But once I had completed steps like I said before, it has worked flawlessly. Once it connects to bridge, you will automatically see all zones and options in auto-discover inbox in PaperUI.


(Oliver) #308

I got mine working by change the port in mi light still add to add it but I need to do Alexa next


(Oliver) #309

what does is this changed from UNINITIALIZED to UNINITIALIZED (BRIDGE_UNINITIALIZED) It when office and I add it again and it works it does when you charge the bridge setting or put on the other raspberry pi

I like the old bridge because it does automatic without tripping its in but this does work

from Oliver


(John McMillan) #310

I may be wrong, but generally when a bridge is “uninitialized”, openHAB may be having a hard time keeping the connection to the bridge.

I would double check that your iBox is using a static IP and that static is in the Paper settings. I would also double check that the you set it to is not being utilized by something else. Probably stick with the default options. Mine uses 8899.

The other thing to check is the “Keep Alive Interval” in the bridge settings. If the value is too high, then the connection can drop. I have mine set at “5”, which I believe is default.

Beyond that, we may have to have @David_Graeff 's input. He is the man when it comes to this :slight_smile:


(Oliver) #311

Thank you for I will check that tonight or torromow and hope to all of our I lights on it does work but I will check that and come back to you and other guy if I need more help I will let you know if I got all you should be able to turn off the pi and back on it does keep it a bit and other you have keep adding it so I will have to that

Thank you


(Oliver) #312

hi what type is the server mode on ibox


(David Graeff) #313

The Milight bridges (old and new) respond to specific network packets.
That is how auto discovery is implemented.

For the old bridges this response is also used as a “heart-beat” to know if a bridge is still online.

The new bridges require to establish a “network session” with their own heart-beat function. That means,
the bridge can still work in OpenHAB even if the auto-discovery failed (probably because the receiving port is blocked by a firewall).

Unlike many suggested, the Milight bridge does not need a static IP. The binding figures out if the bridge IP changed and re-establish a new session. Unfortunately there is still a bug in the binding that I couldn’t find time to resolve yet. Every time a new session is established (which happens automatically after a day or so), the old session was kept as well. After a certain time the bridge is bombarded by network packets from all those active sessions and will eventually fail.

I really hope I can find some time for this issue.

Cheers, David


(Oliver) #314

what should I try


(David Graeff) #315

Disable any firewalls. Make sure the WiFi reception is good enough. Try the Milight app first and find and control lights with it.

Auto-discovery of the newer bridge should work. If it is a very recent model (please tell me your exact Milight bridge variant, by a picture of the backside for example), it might not be supported by the binding.

Thanks,
David


(Oliver) #316

so is the bug making it do this UNINITIALIZED to UNINITIALIZED (BRIDGE_UNINITIALIZED sometime it works and other when I start the pi up it does sones one works fine we got the old and new bridge ibox they do work with app but old bridge does automatic new one does not sound I wait into the bug fix and use the old bridge for now


(Oliver) #317

what server setting should ibox be on


(Oliver) #318

Is anybody there to address this


(David Graeff) #319

There are no “server settings”. Please elaborate on what you exactly mean?


(Oliver) #320

Network Parameters setting

Protocol

TCP-Server TCP-Client UDP


(David Graeff) #321

I would really like you to use punctuation in your posts. I’m not sure if your native language is maybe Mandarin and you are not used to punctuation. But it is really hard to decipher the meaning of your posts sometimes :slight_smile:

Regarding the “Network Parameters”. Please make a screenshot and attach the picture. I don’t know if you mean the binding, the mibridge device, your router…


(Oliver) #322

im in uk engish langage am I not great with spelling like with my mum and dad. are you going to fix that bug


(Oliver) #323

08 This what I mean tcp-server is this helpful.


(Oliver) #324

have you seen the picture yet