The repository 'https://dl.bintray.com/openhab/apt-repo2 stable Release' is not signed. (Raspberry pi 3)

Tags: #<Tag:0x00007f7464dc24d8> #<Tag:0x00007f7464dc2398>

Still the same here.

Just did work for me - thanks Marcel !

1 Like

Could someone please let us know if jfrog.io is temporary or permanent as @UlfK asked? That way we know we need to revisit this some time soon to revert the changes.

I would say for now that using jfrog for stable releases should be a temporary measure.

I am running on ubuntu 18.04
Edited /etc/apt/sources.list.d/openhab2.list.
1st attempt using:-
deb https://openhab.jfrog.io/openhab/openhab-linuxpkg stable main
2nd attempt using:-
deb [arch=amd64] https://openhab.jfrog.io/openhab/openhab-linuxpkg stable main.

Both attempts have the same error message " ‘http://repos.azul.com/azure-only/zulu/apt stable InRelease’ doesn’t support architecture ‘i386’"

Your Azul repo location does not match with what is listed on this page.

Check your /etc/apt/sources.list file and any files in /etc/apt/sources.list.d/ to locate where you have defined the Zulu repository location and update accordingly.

Then do sudo apt update to activate the new repository location.

Hi
I commented off deb-src http://repos.azul.com/azure-only/zulu/apt stable main in /etc/apt/source.list.
Problem solved.

Are you using 32-bit Ubuntu 18.04?

From the documentation at the Zulu website it is unclear to me whether or not they offer a repository for anything other than 64-bit x86 Linux systems.

The repository page has this message on the page which seems to indicate that they only offer 64-bit x86 packages via the repository.

The Azul Repo provides free public downloads of Zulu 64-bit packages for x86 Linux under the Zulu Terms of Use

http://repos.azulsystems.com/

Having this issue

Linux openHABianPi 4.19.42-v7+ #1219 SMP Tue May 14 21:20:58 BST 2019 armv7l

Getting

[18:06:01] openhabian@openHABianPi:~$ sudo apt-get update
[sudo] password for openhabian:
Ign:1 http://repos.azulsystems.com/debian stable InRelease
Hit:2 http://repos.azulsystems.com/debian stable Release
Hit:3 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Get:4 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Ign:5 https://dl.bintray.com/openhab/apt-repo2 stable InRelease
Get:6 https://dl.bintray.com/openhab/apt-repo2 stable Release [6,051 B]
Ign:7 https://dl.bintray.com/openhab/apt-repo2 stable Release.gpg
Reading package lists... Done
E: The repository 'https://dl.bintray.com/openhab/apt-repo2 stable Release' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Any final solution?

Same here…
OH 2.4.0
On rPi Stretch

# [2019-08-28 21:26] maxg@rpi3ohv2 ~ $
sudo apt-get update
Get:1 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Get:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
Ign:3 https://dl.bintray.com/openhab/apt-repo2 stable InRelease
Get:4 https://dl.bintray.com/openhab/apt-repo2 stable Release [6,051 B]
Get:5 http://archive.raspberrypi.org/debian stretch/main armhf Packages [221 kB]
Ign:6 https://dl.bintray.com/openhab/apt-repo2 stable Release.gpg
Get:7 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages [11.7 MB]
Hit:8 http://repo.owntracks.org/debian stretch InRelease
Reading package lists... Done
E: The repository 'https://dl.bintray.com/openhab/apt-repo2 stable Release' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

You both are still on the bintray repo. You need to switch to the jfrog repo.

So, somebody should fix official documentation, don’t you think? There’s still “bintray” repo mentioned on https://www.openhab.org/download/

That somebody could be you :wink:

I’m getting the same problem:

The repository 'https://dl.bintray.com/openhab/apt-repo2 stable Release' is not signed.

Maybe the error is back?

yes, I have the same iussue. Can anyone fix this?

Did you change the repo from bintray to jfrog?

Neither bintray or jfrog works for stable release, how to solve?

1 Like

This issue should be resolved now, I’d reccomend using Bintray for stable releases.

1 Like

An update, disable signed verification does work…

echo ‘deb [trusted=yes] https://dl.bintray.com/openhab/apt-repo2 stable main’ | sudo tee /etc/apt/sources.list.d/openhab2.list

How frustrating this has been… this is a new install on an existing pi I’ve had. I’m trying to test the latest with my setup but can’t even get the basic image installed and from the looks of the thread I’m not the only once having issues for quite a while now… Everything seemed to work fine with exception to upgdate/upgrade to Openhabian on the provided image, the apt process seems to fail against the repository. Any guidance? I’m assuming a manual install would result the same?

[17:57:03] openhabian@openhab : ~ $ wget -qO - ‘https://bintray.com/user/downloadSubjectPublicKey?username=openhab’ | sudo apt-key add -

OK

[17:57:07] openhabian@openhab : ~ $ sudo apt-get install apt-transport-https

Reading package lists… Done

Building dependency tree

Reading state information… Done

apt-transport-https is already the newest version (1.8.2).

The following packages were automatically installed and are no longer required:

rpi.gpio-common triggerhappy

Use ‘sudo apt autoremove’ to remove them.

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

[17:57:24] openhabian@openhab : ~ $ sudo apt autoremove

Reading package lists… Done

Building dependency tree

Reading state information… Done

The following packages will be REMOVED:

rpi.gpio-common triggerhappy

0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.

After this operation, 115 kB disk space will be freed.

Do you want to continue? [Y/n] y

(Reading database … 45105 files and directories currently installed.)

Removing rpi.gpio-common:armhf (0.6.5-1) …

Removing triggerhappy (0.5.0-1) …

Warning: Stopping triggerhappy.service, but it can still be activated by:

triggerhappy.socket

Processing triggers for man-db (2.8.5-2) …

Updating FireMotD available updates count …

[17:57:53] openhabian@openhab : ~ $ sudo apt-get install apt-transport-https

Reading package lists… Done

Building dependency tree

Reading state information… Done

apt-transport-https is already the newest version (1.8.2).

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

[17:57:59] openhabian@openhab : ~ $ echo ‘deb https://dl.bintray.com/openhab/apt-repo2 stable main’ | sudo tee /etc/apt/sources.list.d/openhab2.list

deb https://dl.bintray.com/openhab/apt-repo2 stable main

[17:58:15] openhabian@openhab : ~ $ sudo apt-get update && sudo apt-get install openhab2

Hit:1 http://archive.raspberrypi.org/debian buster InRelease

Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease

Ign:3 https://dl.bintray.com/openhab/apt-repo2 stable InRelease

Get:4 https://dl.bintray.com/openhab/apt-repo2 stable Release [6,051 B]

Ign:5 https://dl.bintray.com/openhab/apt-repo2 stable Release.gpg

Reading package lists… Done

E: The repository ‘https://dl.bintray.com/openhab/apt-repo2 stable Release’ is not signed.

N: Updating from such a repository can’t be done securely, and is therefore disabled by default.

N: See apt-secure(8) manpage for repository creation and user configuration details.

[17:58:34] openhabian@openhab : ~ $

But you appear to be running openhabian. Why are you not using its tools? You should be installing OpenHAB using sudo openhabian-config as listed in the documentation.